summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2012-09-25 13:56:20 +0000
committerRalph Sennhauser <sera@gentoo.org>2012-09-25 13:56:20 +0000
commitf8947fc2f8ca1b6fbd34f1a19a5ed584beb65b9b (patch)
tree04ec788de5ef63aad40c224b48652b8861f7a980 /dev-java/icedtea-web
parentx86 stable, see bug 421351. (diff)
downloadgentoo-2-f8947fc2f8ca1b6fbd34f1a19a5ed584beb65b9b.tar.gz
gentoo-2-f8947fc2f8ca1b6fbd34f1a19a5ed584beb65b9b.tar.bz2
gentoo-2-f8947fc2f8ca1b6fbd34f1a19a5ed584beb65b9b.zip
Version bump. #434094
Add missing dependencies on glib, gtk+ and pkgconfig. Add gtk+:2/gtk+:3 support. Simplyfy src_configure and src_install. (Portage version: 2.1.11.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/icedtea-web')
-rw-r--r--dev-java/icedtea-web/ChangeLog12
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.3-r7.ebuild127
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.3.ebuild127
-rw-r--r--dev-java/icedtea-web/metadata.xml36
4 files changed, 285 insertions, 17 deletions
diff --git a/dev-java/icedtea-web/ChangeLog b/dev-java/icedtea-web/ChangeLog
index d15988674630..242d42b49d57 100644
--- a/dev-java/icedtea-web/ChangeLog
+++ b/dev-java/icedtea-web/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-java/icedtea-web
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.27 2012/09/06 14:10:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.28 2012/09/25 13:56:20 sera Exp $
+
+*icedtea-web-1.3-r7 (25 Sep 2012)
+*icedtea-web-1.3 (25 Sep 2012)
+
+ 25 Sep 2012; Ralph Sennhauser <sera@gentoo.org> +icedtea-web-1.3.ebuild,
+ +icedtea-web-1.3-r7.ebuild, metadata.xml:
+ Version bump. #434094
+ Add missing dependencies on glib, gtk+ and pkgconfig.
+ Add gtk+:2/gtk+:3 support.
+ Simplyfy src_configure and src_install.
06 Sep 2012; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Spelling.
diff --git a/dev-java/icedtea-web/icedtea-web-1.3-r7.ebuild b/dev-java/icedtea-web/icedtea-web-1.3-r7.ebuild
new file mode 100644
index 000000000000..041b41ea02cd
--- /dev/null
+++ b/dev-java/icedtea-web/icedtea-web-1.3-r7.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.3-r7.ebuild,v 1.1 2012/09/25 13:56:20 sera Exp $
+# Build written by Andrew John Hughes (ahughes@redhat.com)
+
+EAPI="4"
+
+inherit autotools eutils java-pkg-2 java-vm-2
+
+DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
+HOMEPAGE="http://icedtea.classpath.org"
+SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
+SLOT="7"
+KEYWORDS="~amd64 ~ia64 ~x86"
+
+IUSE="build doc gtk2 gtk3 javascript +nsplugin test"
+
+COMMON_DEP="
+ dev-java/icedtea:${SLOT}
+ nsplugin? (
+ >=dev-libs/glib-2.16
+ gtk2? (
+ !gtk3? ( >=x11-libs/gtk+-2.6:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+ )
+ !gtk2? ( x11-libs/gtk+:3 )
+ )"
+RDEPEND="${COMMON_DEP}"
+# Need system junit 4.8+. Bug #389795
+DEPEND="${COMMON_DEP}
+ virtual/pkgconfig
+ javascript? ( dev-java/rhino:1.6 )
+ nsplugin? ( net-misc/npapi-sdk )
+ test? ( >=dev-java/junit-4.8:4 )"
+
+pkg_setup() {
+ JAVA_PKG_WANT_BUILD_VM="icedtea-${SLOT} icedtea${SLOT}"
+ JAVA_PKG_WANT_SOURCE="1.6"
+ JAVA_PKG_WANT_TARGET="1.6"
+
+ java-vm-2_pkg_setup
+ java-pkg-2_pkg_setup
+
+ VMHANDLE="icedtea-${SLOT}"
+}
+
+src_prepare() {
+ # bug #356645
+ epatch "${FILESDIR}"/0002-Respect-LDFLAGS.patch
+ eautoreconf
+}
+
+src_configure() {
+ local vmhome=$(java-config -O)
+
+ if use build; then
+ icedteadir="${ICEDTEA_BIN_DIR}"
+ [[ -z ${icedteadir} ]] && die "USE=build is an internal flag and should not be enabled"
+ installdir="/opt/icedtea-web-bin-${SLOT}"
+ else
+ icedteadir="/usr/$(get_libdir)/icedtea${SLOT}"
+ installdir="/usr/$(get_libdir)/icedtea${SLOT}-web"
+ [[ "${vmhome}" == "${icedteadir}" ]] \
+ || die "Unexpected install location of IcedTea ${SLOT} '${vmhome}'"
+ fi
+
+ einfo "Installing IcedTea-Web in '${installdir}'"
+ einfo "Installing IcedTea-Web for IcedTea${SLOT} in '${icedteadir}'"
+
+ local gtk_ver=3
+ use gtk2 && gtk_ver=2
+ use gtk3 && gtk_ver=3
+
+ local myconf=(
+ # we need to override all *dir variables that econf sets.
+ # man page (javaws) is installed directly to icedteadir because it's
+ # easier than symlinking, as we don't know the suffix the man page will
+ # end up compressed with, anyway
+ --prefix="${installdir}"
+ --mandir="${icedteadir}"/man
+ --infodir="${installdir}"/share/info
+ --datadir="${installdir}"/share
+ --with-jdk-home="${icedteadir}"
+ --with-gtk=${gtk_ver}
+ $(use_enable doc docs)
+ $(use_enable nsplugin plugin)
+ $(use_with javascript rhino)
+ )
+
+ unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ # we need this to override the src_compile from java-pkg-2
+ default
+}
+
+src_install() {
+ default
+
+ if use nsplugin; then
+ install_mozilla_plugin "${installdir}/$(get_libdir)/IcedTeaPlugin.so";
+ fi
+
+ for binary in javaws itweb-settings; do
+ dosym ${installdir}/bin/${binary} ${icedteadir}/bin/${binary}
+ dosym ${installdir}/bin/${binary} ${icedteadir}/jre/bin/${binary}
+ done
+}
+
+pkg_postinst() {
+ java-vm_check-nsplugin
+ java_mozilla_clean_
+
+ if use nsplugin; then
+ elog "The icedtea browser plugin (NPPlugin) can be enabled using eselect java-nsplugin"
+ fi
+}
+
+pkg_prerm() {
+ # override the java-vm-2 eclass check for removing a system VM, as it
+ # doesn't make sense here.
+ :;
+}
diff --git a/dev-java/icedtea-web/icedtea-web-1.3.ebuild b/dev-java/icedtea-web/icedtea-web-1.3.ebuild
new file mode 100644
index 000000000000..aa1151fc9be0
--- /dev/null
+++ b/dev-java/icedtea-web/icedtea-web-1.3.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.3.ebuild,v 1.1 2012/09/25 13:56:20 sera Exp $
+# Build written by Andrew John Hughes (ahughes@redhat.com)
+
+EAPI="4"
+
+inherit autotools eutils java-pkg-2 java-vm-2
+
+DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
+HOMEPAGE="http://icedtea.classpath.org"
+SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
+SLOT="6"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+
+IUSE="build doc gtk2 gtk3 javascript +nsplugin test"
+
+COMMON_DEP="
+ dev-java/icedtea:${SLOT}
+ nsplugin? (
+ >=dev-libs/glib-2.16
+ gtk2? (
+ !gtk3? ( >=x11-libs/gtk+-2.6:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+ )
+ !gtk2? ( x11-libs/gtk+:3 )
+ )"
+RDEPEND="${COMMON_DEP}"
+# Need system junit 4.8+. Bug #389795
+DEPEND="${COMMON_DEP}
+ virtual/pkgconfig
+ javascript? ( dev-java/rhino:1.6 )
+ nsplugin? ( net-misc/npapi-sdk )
+ test? ( >=dev-java/junit-4.8:4 )"
+
+pkg_setup() {
+ JAVA_PKG_WANT_BUILD_VM="icedtea-${SLOT} icedtea${SLOT}"
+ JAVA_PKG_WANT_SOURCE="1.6"
+ JAVA_PKG_WANT_TARGET="1.6"
+
+ java-vm-2_pkg_setup
+ java-pkg-2_pkg_setup
+
+ VMHANDLE="icedtea-${SLOT}"
+}
+
+src_prepare() {
+ # bug #356645
+ epatch "${FILESDIR}"/0002-Respect-LDFLAGS.patch
+ eautoreconf
+}
+
+src_configure() {
+ local vmhome=$(java-config -O)
+
+ if use build; then
+ icedteadir="${ICEDTEA_BIN_DIR}"
+ [[ -z ${icedteadir} ]] && die "USE=build is an internal flag and should not be enabled"
+ installdir="/opt/icedtea-web-bin-${SLOT}"
+ else
+ icedteadir="/usr/$(get_libdir)/icedtea${SLOT}"
+ installdir="/usr/$(get_libdir)/icedtea${SLOT}-web"
+ [[ "${vmhome}" == "${icedteadir}" ]] \
+ || die "Unexpected install location of IcedTea ${SLOT} '${vmhome}'"
+ fi
+
+ einfo "Installing IcedTea-Web in '${installdir}'"
+ einfo "Installing IcedTea-Web for IcedTea${SLOT} in '${icedteadir}'"
+
+ local gtk_ver=3
+ use gtk2 && gtk_ver=2
+ use gtk3 && gtk_ver=3
+
+ local myconf=(
+ # we need to override all *dir variables that econf sets.
+ # man page (javaws) is installed directly to icedteadir because it's
+ # easier than symlinking, as we don't know the suffix the man page will
+ # end up compressed with, anyway
+ --prefix="${installdir}"
+ --mandir="${icedteadir}"/man
+ --infodir="${installdir}"/share/info
+ --datadir="${installdir}"/share
+ --with-jdk-home="${icedteadir}"
+ --with-gtk=${gtk_ver}
+ $(use_enable doc docs)
+ $(use_enable nsplugin plugin)
+ $(use_with javascript rhino)
+ )
+
+ unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ # we need this to override the src_compile from java-pkg-2
+ default
+}
+
+src_install() {
+ default
+
+ if use nsplugin; then
+ install_mozilla_plugin "${installdir}/$(get_libdir)/IcedTeaPlugin.so";
+ fi
+
+ for binary in javaws itweb-settings; do
+ dosym ${installdir}/bin/${binary} ${icedteadir}/bin/${binary}
+ dosym ${installdir}/bin/${binary} ${icedteadir}/jre/bin/${binary}
+ done
+}
+
+pkg_postinst() {
+ java-vm_check-nsplugin
+ java_mozilla_clean_
+
+ if use nsplugin; then
+ elog "The icedtea browser plugin (NPPlugin) can be enabled using eselect java-nsplugin"
+ fi
+}
+
+pkg_prerm() {
+ # override the java-vm-2 eclass check for removing a system VM, as it
+ # doesn't make sense here.
+ :;
+}
diff --git a/dev-java/icedtea-web/metadata.xml b/dev-java/icedtea-web/metadata.xml
index 9e085cc70cc1..0460a68c90c2 100644
--- a/dev-java/icedtea-web/metadata.xml
+++ b/dev-java/icedtea-web/metadata.xml
@@ -1,20 +1,24 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>java</herd>
-<maintainer>
- <email>gnu_andrew@member.fsf.org</email>
- <name>Andrew John Hughes</name>
- <description>Proxy Maintainer</description>
-</maintainer>
-<maintainer>
- <email>caster@gentoo.org</email>
- <name>Vlastimil Babka</name>
- <description>Committer (CC me)</description>
-</maintainer>
-<longdescription>FOSS Java Web Start and optional browser plugin implementation based on NetX, to be used with icedtea.</longdescription>
-<use>
- <flag name="javascript">Enable support for using proxy auto config (PAC) files.</flag>
- <flag name="nsplugin">Enable the browser plugin (NPPlugin).</flag>
-</use>
+ <herd>java</herd>
+ <maintainer>
+ <email>gnu_andrew@member.fsf.org</email>
+ <name>Andrew John Hughes</name>
+ <description>Proxy Maintainer</description>
+ </maintainer>
+ <maintainer>
+ <email>caster@gentoo.org</email>
+ <name>Vlastimil Babka</name>
+ <description>Committer (CC me)</description>
+ </maintainer>
+ <longdescription>
+ FOSS Java Web Start and optional browser plugin implementation based on NetX, to be used with icedtea.
+ </longdescription>
+ <use>
+ <flag name="javascript">Enable support for using proxy auto config (PAC) files.</flag>
+ <flag name="nsplugin">Enable the browser plugin (NPPlugin).</flag>
+ <flag name="gtk2">Use x11-libs/gtk+:2 instead of x11-libs/gtk+:3</flag>
+ <flag name="gtk3">Use x11-libs/gtk+:3 (default)</flag>
+ </use>
</pkgmetadata>