summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-11 13:27:01 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-11 13:27:01 +0000
commit2acb6cde9c3c4e330e50b76077ddf55edb2abcd9 (patch)
tree99d71ef475d4883a11a8a4785d7ff12be114c3d6 /dev-java/ibm-jre-bin
parentbug 69542: javaws broken, add preload hack. bug 94056: useflag rename mozilla... (diff)
downloadgentoo-2-2acb6cde9c3c4e330e50b76077ddf55edb2abcd9.tar.gz
gentoo-2-2acb6cde9c3c4e330e50b76077ddf55edb2abcd9.tar.bz2
gentoo-2-2acb6cde9c3c4e330e50b76077ddf55edb2abcd9.zip
bug 94056: useflag rename mozilla -> browserplugin
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/ibm-jre-bin')
-rw-r--r--dev-java/ibm-jre-bin/ChangeLog6
-rw-r--r--dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild16
-rw-r--r--dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild15
3 files changed, 28 insertions, 9 deletions
diff --git a/dev-java/ibm-jre-bin/ChangeLog b/dev-java/ibm-jre-bin/ChangeLog
index 7c7e22dcc428..81a6dea0a525 100644
--- a/dev-java/ibm-jre-bin/ChangeLog
+++ b/dev-java/ibm-jre-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/ibm-jre-bin
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ChangeLog,v 1.17 2005/05/18 15:45:12 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ChangeLog,v 1.18 2005/07/11 13:27:01 axxo Exp $
+
+ 11 Jul 2005; Thomas Matthijs <axxo@gentoo.org>
+ ibm-jre-bin-1.4.1-r1.ebuild, ibm-jre-bin-1.4.2.ebuild:
+ bug 94056: useflag rename mozilla -> browserplugin
18 May 2005; Thomas Matthijs <axxo@gentoo.org>
ibm-jre-bin-1.4.1-r1.ebuild, ibm-jre-bin-1.4.2.ebuild:
diff --git a/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild b/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild
index 27a18c79c619..3f68ea2de839 100644
--- a/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild
+++ b/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild,v 1.15 2005/05/22 15:52:08 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild,v 1.16 2005/07/11 13:27:01 axxo Exp $
inherit java
@@ -11,10 +11,10 @@ SRC_URI="ppc? ( mirror://gentoo/IBMJava2-JRE-141.ppc.tgz )
ppc64? ( mirror://gentoo/IBMJava2-JRE-141.ppc64.tgz )
x86? ( mirror://gentoo/IBMJava2-JRE-141.tgz )"
PROVIDE="virtual/jre"
-IUSE="mozilla"
+IUSE="browserplugin mozilla"
SLOT="1.4"
LICENSE="IBM-J1.4"
-KEYWORDS="ppc ~x86 ppc64"
+KEYWORDS="ppc ~x86 ppc64 -*"
DEPEND="virtual/libc
>=dev-java/java-config-0.2.5"
RDEPEND=""
@@ -48,7 +48,7 @@ src_install() {
> ${D}/etc/env.d/java/20${P} \
|| die "unable to install environment file"
- if use mozilla; then
+ if use browserplugin || use mozilla; then
local plugin="libjavaplugin_oji.so"
if has_version '>=gcc-3*' ; then
plugin="libjavaplugin_ojigcc3.so"
@@ -57,3 +57,11 @@ src_install() {
fi
}
+
+pkg_postinst() {
+ if ! use browserplugin && use mozilla; then
+ ewarn
+ ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
+ ewarn "has been renamed to 'browserplugin' please update your USE"
+ fi
+}
diff --git a/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild b/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild
index d3652041aa58..8fef30798042 100644
--- a/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild
+++ b/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild,v 1.9 2005/05/22 15:52:08 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild,v 1.10 2005/07/11 13:27:01 axxo Exp $
inherit java
@@ -11,10 +11,10 @@ SRC_URI="ppc? ( mirror://gentoo/IBMJava2-JRE-142.ppc.tgz )
ppc64? ( mirror://gentoo/IBMJava2-JRE-142.ppc64.tgz )
x86? ( mirror://gentoo/IBMJava2-JRE-142.tgz )"
PROVIDE="virtual/jre"
-IUSE="mozilla"
+IUSE="browserplugin mozilla"
SLOT="1.4"
LICENSE="IBM-J1.4"
-KEYWORDS="ppc ~x86 ppc64"
+KEYWORDS="ppc ~x86 ppc64 -*"
DEPEND="virtual/libc
>=dev-java/java-config-0.2.5"
RDEPEND=""
@@ -48,7 +48,7 @@ src_install() {
> ${D}/etc/env.d/java/20${P} \
|| die "unable to install environment file"
- if useq mozilla && ! ( useq ppc || useq ppc64 ); then
+ if ( use browserplugin || use mozilla ) && ! ( use ppc || use ppc64 ); then
local plugin="libjavaplugin_oji.so"
if has_version '>=gcc-3*' ; then
plugin="libjavaplugin_ojigcc3.so"
@@ -57,3 +57,10 @@ src_install() {
fi
}
+pkg_postinst() {
+ if ! use browserplugin && use mozilla; then
+ ewarn
+ ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
+ ewarn "has been renamed to 'browserplugin' please update your USE"
+ fi
+}