summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-05-01 10:12:48 +0000
committerVlastimil Babka <caster@gentoo.org>2007-05-01 10:12:48 +0000
commit32f9e5ab8586e65bbad6af2980fab26c70b99252 (patch)
treec1a9228320a1dd3115c725e89fdd7ba2d4cf8821 /dev-java/fastutil
parentAdded ~ppc64 (diff)
downloadgentoo-2-32f9e5ab8586e65bbad6af2980fab26c70b99252.tar.gz
gentoo-2-32f9e5ab8586e65bbad6af2980fab26c70b99252.tar.bz2
gentoo-2-32f9e5ab8586e65bbad6af2980fab26c70b99252.zip
Raise JDK heap size only for compilers other than javac, because fork for javac causes twice memory consumption otherwise - bug #175578.
(Portage version: 2.1.2.5)
Diffstat (limited to 'dev-java/fastutil')
-rw-r--r--dev-java/fastutil/ChangeLog6
-rw-r--r--dev-java/fastutil/fastutil-5.0.5.ebuild7
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-java/fastutil/ChangeLog b/dev-java/fastutil/ChangeLog
index 14b1700e032a..0ca03b8734d2 100644
--- a/dev-java/fastutil/ChangeLog
+++ b/dev-java/fastutil/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/fastutil
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/ChangeLog,v 1.28 2007/04/12 13:46:28 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/ChangeLog,v 1.29 2007/05/01 10:12:48 caster Exp $
+
+ 01 May 2007; Vlastimil Babka <caster@gentoo.org> fastutil-5.0.5.ebuild:
+ Raise JDK heap size only for compilers other than javac, because fork for
+ javac causes twice memory consumption otherwise - bug #175578.
12 Apr 2007; <welp@gentoo.org> fastutil-4.4.2-r1.ebuild,
fastutil-5.0.5.ebuild:
diff --git a/dev-java/fastutil/fastutil-5.0.5.ebuild b/dev-java/fastutil/fastutil-5.0.5.ebuild
index 512a37942709..1c7c97639da3 100644
--- a/dev-java/fastutil/fastutil-5.0.5.ebuild
+++ b/dev-java/fastutil/fastutil-5.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/fastutil-5.0.5.ebuild,v 1.5 2007/04/12 13:46:28 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/fastutil-5.0.5.ebuild,v 1.6 2007/05/01 10:12:48 caster Exp $
inherit java-pkg-2 java-ant-2
@@ -19,8 +19,9 @@ RDEPEND=">=virtual/jre-1.5"
src_compile() {
emake sources || die "failed to make sources"
- # bug 162650
- export ANT_OPTS="-Xmx512m"
+ # bug 162650 and #175578
+ java-pkg_init-compiler_
+ [[ ${GENTOO_COMPILER} != "javac" ]] && export ANT_OPTS="-Xmx512m"
java-pkg-2_src_compile
}