summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2008-10-22 11:46:03 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2008-10-22 11:46:03 +0000
commitca4fcb68f1e23f20c45522be38525f5b8e90de53 (patch)
tree3fb93586e88af6b05d90b66fb770750a88b3d236 /dev-java/dbunit
parentQuote (diff)
downloadgentoo-2-ca4fcb68f1e23f20c45522be38525f5b8e90de53.tar.gz
gentoo-2-ca4fcb68f1e23f20c45522be38525f5b8e90de53.tar.bz2
gentoo-2-ca4fcb68f1e23f20c45522be38525f5b8e90de53.zip
Migrated to EAPI-1 and restricted to dev-java/poi:0 because of incompatibility with dev-java/poi-3.2
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'dev-java/dbunit')
-rw-r--r--dev-java/dbunit/ChangeLog6
-rw-r--r--dev-java/dbunit/dbunit-2.2.ebuild21
2 files changed, 16 insertions, 11 deletions
diff --git a/dev-java/dbunit/ChangeLog b/dev-java/dbunit/ChangeLog
index fc1bc3740a03..e40000d917c9 100644
--- a/dev-java/dbunit/ChangeLog
+++ b/dev-java/dbunit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/dbunit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/dbunit/ChangeLog,v 1.16 2008/01/10 22:22:20 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/dbunit/ChangeLog,v 1.17 2008/10/22 11:46:03 fordfrog Exp $
+
+ 22 Oct 2008; Miroslav Šulc <fordfrog@gentoo.org> dbunit-2.2.ebuild:
+ Migrated to EAPI-1 and restricted to dev-java/poi:0 because of
+ incompatibility with dev-java/poi-3.2
10 Jan 2008; Vlastimil Babka <caster@gentoo.org> dbunit-2.2.ebuild:
Restrict junit dependency.
diff --git a/dev-java/dbunit/dbunit-2.2.ebuild b/dev-java/dbunit/dbunit-2.2.ebuild
index b9de38617ed4..086b3f47303b 100644
--- a/dev-java/dbunit/dbunit-2.2.ebuild
+++ b/dev-java/dbunit/dbunit-2.2.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/dbunit/dbunit-2.2.ebuild,v 1.7 2008/01/10 22:22:20 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/dbunit/dbunit-2.2.ebuild,v 1.8 2008/10/22 11:46:03 fordfrog Exp $
+EAPI="1"
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-ant-2
@@ -16,21 +17,21 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
RDEPEND=">=virtual/jre-1.4
- >=dev-java/poi-2.0
- =dev-java/junit-3.8*
- >=dev-java/ant-core-1.6
- dev-java/commons-logging
- >=dev-java/commons-lang-2.1
- dev-java/commons-collections"
+ >=dev-java/poi-2.0:0
+ >=dev-java/junit-3.8:0
+ >=dev-java/ant-core-1.6:0
+ dev-java/commons-logging:0
+ >=dev-java/commons-lang-2.1:2.1
+ dev-java/commons-collections:0"
DEPEND=">=virtual/jdk-1.4
${RDEPEND}"
src_unpack() {
unpack ${A}
- cd ${S}
- cp ${FILESDIR}/build.xml build.xml
+ cd "${S}"
+ cp "${FILESDIR}"/build.xml build.xml
- cd ${S}/lib || die
+ cd "${S}"/lib || die
#rm -v *.jar
java-pkg_jar-from poi
java-pkg_jar-from junit