summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-10-30 19:03:41 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-10-30 19:03:41 +0000
commite01467ae6b775d8905e2658cf36d10a61f3be11c (patch)
treeb045b3e53f41147d12544ea026f506e2a90752f1 /dev-java/concurrent-util/concurrent-util-1.3.4.ebuild
parentcopy'd the wrong file (diff)
downloadgentoo-2-e01467ae6b775d8905e2658cf36d10a61f3be11c.tar.gz
gentoo-2-e01467ae6b775d8905e2658cf36d10a61f3be11c.tar.bz2
gentoo-2-e01467ae6b775d8905e2658cf36d10a61f3be11c.zip
inital import, ebuild contributed by Dan <dan@intuitivelyobvious.net>
Diffstat (limited to 'dev-java/concurrent-util/concurrent-util-1.3.4.ebuild')
-rw-r--r--dev-java/concurrent-util/concurrent-util-1.3.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/concurrent-util/concurrent-util-1.3.4.ebuild b/dev-java/concurrent-util/concurrent-util-1.3.4.ebuild
new file mode 100644
index 000000000000..e7ecad7ae866
--- /dev/null
+++ b/dev-java/concurrent-util/concurrent-util-1.3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/concurrent-util/concurrent-util-1.3.4.ebuild,v 1.1 2004/10/30 19:03:41 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Doug Lea's concurrency utilities provide standardized, efficient versions of utility classes commonly encountered in concurrent Java programming."
+SRC_URI="mirrors://gentoo/gentoo-concurrent-util-1.3.4.tar.bz2"
+HOMEPAGE="http://gee.cs.oswego.edu/dl/classes/EDU/oswego/cs/dl/util/concurrent/intro.html"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RDEPEND=">=virtual/jre-1.2"
+DEPEND=">=virtual/jdk-1.2
+ >=dev-java/ant-core-1.5 "
+IUSE="doc jikes"
+
+src_compile() {
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} doc"
+ ant ${antflags} || die "failed to build"
+}
+
+src_install() {
+ java-pkg_dojar build/lib/concurrent.jar
+ dodoc sun-u.c.license.pdf
+ if use doc ; then
+ cd build
+ java-pkg_dohtml -r javadoc
+ insinto /usr/share/doc/${PF}/demo
+ doins demo/*
+ fi
+}