summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-03-29 15:35:45 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-03-29 15:35:45 +0000
commitb12cc2f9d7961efab8fe244c50058d8c22023f78 (patch)
tree762365e4bbf6761a07f2ecce5fae3259b9209637 /dev-java/commons-net
parentAdded chan_capi fax patch from http://mlkj.net/asterisk/ (diff)
downloadgentoo-2-b12cc2f9d7961efab8fe244c50058d8c22023f78.tar.gz
gentoo-2-b12cc2f9d7961efab8fe244c50058d8c22023f78.tar.bz2
gentoo-2-b12cc2f9d7961efab8fe244c50058d8c22023f78.zip
moved from dev-java/oro to dev-java/jakarta-oro dependency. see #71337. introduced support for the examples and the source useflag.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-java/commons-net')
-rw-r--r--dev-java/commons-net/ChangeLog9
-rw-r--r--dev-java/commons-net/commons-net-1.2.2-r1.ebuild42
-rw-r--r--dev-java/commons-net/commons-net-1.3.0-r1.ebuild61
-rw-r--r--dev-java/commons-net/files/digest-commons-net-1.2.2-r11
-rw-r--r--dev-java/commons-net/files/digest-commons-net-1.3.0-r11
5 files changed, 113 insertions, 1 deletions
diff --git a/dev-java/commons-net/ChangeLog b/dev-java/commons-net/ChangeLog
index 72f4306ca462..898c803bd248 100644
--- a/dev-java/commons-net/ChangeLog
+++ b/dev-java/commons-net/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/commons-net
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/ChangeLog,v 1.25 2005/01/26 21:48:15 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/ChangeLog,v 1.26 2005/03/29 15:35:45 luckyduck Exp $
+
+*commons-net-1.2.2-r1 (29 Mar 2005)
+
+ 29 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org>
+ +commons-net-1.2.2-r1.ebuild, +commons-net-1.3.0-r1.ebuild:
+ moved from dev-java/oro to dev-java/jakarta-oro dependency. see #71337.
+ introduced support for the examples and the source useflag.
26 Jan 2005; Markus Rothe <corsair@gentoo.org> commons-net-1.3.0.ebuild:
Stable on ppc64
diff --git a/dev-java/commons-net/commons-net-1.2.2-r1.ebuild b/dev-java/commons-net/commons-net-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..030f323de1c0
--- /dev/null
+++ b/dev-java/commons-net/commons-net-1.2.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.2.2-r1.ebuild,v 1.1 2005/03/29 15:35:45 luckyduck Exp $
+
+inherit eutils java-pkg
+
+DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions."
+HOMEPAGE="http://jakarta.apache.org/commons/net/"
+SRC_URI="mirror://apache/jakarta/commons/net/source/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-core-1.5.4
+ =dev-java/jakarta-oro-2.0*
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+IUSE="doc jikes source"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gentoo-1.2.diff
+ #for some reason 1.2.2 claims its 1.3
+ sed "s/commons-net-1.3.0-dev/commons-net-1.2.2-dev/" -i build.xml || die "died on sed"
+}
+
+src_compile() {
+ local antflags="-Doro.jar=$(java-config -p jakarta-oro-2.0) jar"
+ use doc && antflags="${antflags} javadoc"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "died on ant"
+}
+
+src_install() {
+ mv ${S}/target/${P}-dev.jar ${S}/target/${PN}.jar
+ java-pkg_dojar target/${PN}.jar
+
+ use doc && java-pkg_dohtml -r dist/docs/
+ use source && java-pkg_dosrc src/java/org
+}
diff --git a/dev-java/commons-net/commons-net-1.3.0-r1.ebuild b/dev-java/commons-net/commons-net-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..4a87ac038148
--- /dev/null
+++ b/dev-java/commons-net/commons-net-1.3.0-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.3.0-r1.ebuild,v 1.1 2005/03/29 15:35:45 luckyduck Exp $
+
+inherit eutils java-pkg
+
+DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions."
+HOMEPAGE="http://jakarta.apache.org/commons/net/"
+SRC_URI="mirror://apache/jakarta/commons/net/source/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-core-1.5.4
+ >=dev-java/jakarta-oro-2.0*
+ junit? ( dev-java/junit )
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64 ~ppc64"
+IUSE="doc examples jikes junit source"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's|depends="get-deps"||' build.xml || die "sed failed"
+ mkdir -p target/lib
+ cd target/lib
+ java-pkg_jar-from jakarta-oro-2.0 jakarta-oro.jar oro.jar
+
+ cd ${S}
+ if ! use junit ; then
+ sed -i 's/depends="compile,test"/depends="compile"/' \
+ build.xml || die "Failed to disable junit"
+ else
+ if ! has_version dev-java/ant-tasks; then
+ sed -i 's/depends="compile,test"/depends="compile"/' \
+ build.xml || die "Failed to disable junit"
+ fi
+ fi
+}
+
+src_compile() {
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ ant ${antflags} || die "died on ant"
+}
+
+src_install() {
+ mv ${S}/target/${P}-dev.jar ${S}/target/${PN}.jar
+ java-pkg_dojar target/${PN}.jar
+
+ use doc && java-pkg_dohtml -r dist/docs/
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r src/java/examples/* ${D}/usr/share/doc/${PF}/examples
+ fi
+ use source && java-pkg_dosrc src/java/org
+}
diff --git a/dev-java/commons-net/files/digest-commons-net-1.2.2-r1 b/dev-java/commons-net/files/digest-commons-net-1.2.2-r1
new file mode 100644
index 000000000000..dd2834f25e40
--- /dev/null
+++ b/dev-java/commons-net/files/digest-commons-net-1.2.2-r1
@@ -0,0 +1 @@
+MD5 3856e8b3f50bdfffbf186e07c477f73b commons-net-1.2.2-src.tar.gz 178572
diff --git a/dev-java/commons-net/files/digest-commons-net-1.3.0-r1 b/dev-java/commons-net/files/digest-commons-net-1.3.0-r1
new file mode 100644
index 000000000000..606eacd19f41
--- /dev/null
+++ b/dev-java/commons-net/files/digest-commons-net-1.3.0-r1
@@ -0,0 +1 @@
+MD5 1394cc644125c9cf69d23db5ac37295b commons-net-1.3.0-src.tar.gz 267046