summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-03-17 05:21:17 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-03-17 05:21:17 +0000
commitfd1b259953fb5c7b384338c4427a62f5250e4f9e (patch)
tree2afee92b42e66075e3a67c03197cd525e461c599 /dev-java/commons-lang
parenttighten DEPEND (bug #44817); sed in src_unpack, not src_compile; use emake (M... (diff)
downloadgentoo-2-fd1b259953fb5c7b384338c4427a62f5250e4f9e.tar.gz
gentoo-2-fd1b259953fb5c7b384338c4427a62f5250e4f9e.tar.bz2
gentoo-2-fd1b259953fb5c7b384338c4427a62f5250e4f9e.zip
Clean ups and not using jakarta-commons.eclass anymore.
Diffstat (limited to 'dev-java/commons-lang')
-rw-r--r--dev-java/commons-lang/ChangeLog6
-rw-r--r--dev-java/commons-lang/commons-lang-2.0-r1.ebuild17
-rw-r--r--dev-java/commons-lang/commons-lang-2.0.ebuild24
-rw-r--r--dev-java/commons-lang/files/digest-commons-lang-2.01
4 files changed, 12 insertions, 36 deletions
diff --git a/dev-java/commons-lang/ChangeLog b/dev-java/commons-lang/ChangeLog
index cd39eb874fd1..e39418ea5d48 100644
--- a/dev-java/commons-lang/ChangeLog
+++ b/dev-java/commons-lang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/commons-lang
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/ChangeLog,v 1.13 2004/03/15 15:28:48 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/ChangeLog,v 1.14 2004/03/17 05:21:17 zx Exp $
+
+ 20 Mar 2004; Chris Aniszczyk <zx@gentoo.org> commons-lang-2.0-r1.ebuild,
+ commons-lang-2.0.ebuild:
+ Not using jakarta-commons.eclass anymore, it's broken. Clean up.
*commons-lang-2.0-r1 (29 Feb 2004)
diff --git a/dev-java/commons-lang/commons-lang-2.0-r1.ebuild b/dev-java/commons-lang/commons-lang-2.0-r1.ebuild
index 8669eceeec94..dc8401324e49 100644
--- a/dev-java/commons-lang/commons-lang-2.0-r1.ebuild
+++ b/dev-java/commons-lang/commons-lang-2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-2.0-r1.ebuild,v 1.1 2004/03/01 04:53:48 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-2.0-r1.ebuild,v 1.2 2004/03/17 05:21:17 zx Exp $
inherit java-pkg
@@ -9,21 +9,17 @@ HOMEPAGE="http://jakarta.apache.org/commons/lang.html"
SRC_URI="mirror://apache/jakarta/commons/lang/source/${P}-src.tar.gz"
DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-1.4
+ jikes? ( dev-java/jikes )
junit? ( >=dev-java/junit-3.7 )"
RDEPEND=">=virtual/jre-1.3"
LICENSE="Apache-1.1"
SLOT="0"
+RESTRICT="nomirror"
KEYWORDS="~x86 ~ppc ~sparc"
IUSE="doc jikes junit"
S="${WORKDIR}/${PN}-${PV}-src"
-src_unpack() {
- unpack ${A}
- cd ${S}
- echo "junit.jar=`java-config -p junit`" >> build.properties
-}
-
src_compile() {
local antflags="jar"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
@@ -33,8 +29,9 @@ src_compile() {
}
src_install() {
- mv dist/commons-lang-2.0.jar dist/${PN}.jar
+ mv dist/${P}.jar dist/${PN}.jar
java-pkg_dojar dist/*.jar
- dohtml *.html
- use doc && dohtml -r dist/docs/*
+ dodoc RELEASE-NOTES.txt
+ dohtml DEVELOPERS-GUIDE.html PROPOSAL.html STATUS.html
+ use doc && dohtml -r dist/docs/
}
diff --git a/dev-java/commons-lang/commons-lang-2.0.ebuild b/dev-java/commons-lang/commons-lang-2.0.ebuild
deleted file mode 100644
index 81638efc3652..000000000000
--- a/dev-java/commons-lang/commons-lang-2.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-2.0.ebuild,v 1.2 2004/03/01 04:53:48 zx Exp $
-
-inherit jakarta-commons
-
-S="${WORKDIR}/${PN}-${PV}-src"
-DESCRIPTION="Jakarta components to manipulate core java classes"
-HOMEPAGE="http://jakarta.apache.org/commons/lang.html"
-SRC_URI="mirror://apache/jakarta/commons/lang/source/${P}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4
- junit? ( >=dev-java/junit-3.7 )"
-RDEPEND=">=virtual/jre-1.3"
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc"
-IUSE="doc jikes junit"
-
-src_compile() {
- cp LICENSE.txt ../LICENSE
- jakarta-commons_src_compile myconf make
- use doc && jakarta-commons_src_compile makedoc
-}
diff --git a/dev-java/commons-lang/files/digest-commons-lang-2.0 b/dev-java/commons-lang/files/digest-commons-lang-2.0
deleted file mode 100644
index 372fd0253970..000000000000
--- a/dev-java/commons-lang/files/digest-commons-lang-2.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 200a40d46fe6a60af76acf973298b8fe commons-lang-2.0-src.tar.gz 440989