summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-07-19 21:43:31 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-07-19 21:43:31 +0000
commitad19ad8fe71c9131bfaf83027ed57d552730cda3 (patch)
tree2a6b61ce835cf165138fa8e2b403658e258611e8 /dev-java/commons-lang/commons-lang-2.0-r2.ebuild
parentMigrated to Generation 2. (diff)
downloadgentoo-2-ad19ad8fe71c9131bfaf83027ed57d552730cda3.tar.gz
gentoo-2-ad19ad8fe71c9131bfaf83027ed57d552730cda3.tar.bz2
gentoo-2-ad19ad8fe71c9131bfaf83027ed57d552730cda3.zip
Migrated to Generation 2.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'dev-java/commons-lang/commons-lang-2.0-r2.ebuild')
-rw-r--r--dev-java/commons-lang/commons-lang-2.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/commons-lang/commons-lang-2.0-r2.ebuild b/dev-java/commons-lang/commons-lang-2.0-r2.ebuild
new file mode 100644
index 000000000000..8bf10a180da6
--- /dev/null
+++ b/dev-java/commons-lang/commons-lang-2.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-2.0-r2.ebuild,v 1.1 2006/07/19 21:43:31 nelchael Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Jakarta components to manipulate core java classes"
+HOMEPAGE="http://jakarta.apache.org/commons/lang/"
+SRC_URI="mirror://apache/jakarta/commons/lang/source/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-core-1.4"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc source"
+
+S="${WORKDIR}/${P}-src"
+
+src_compile() {
+ local antflags="jar"
+ use doc && antflags="${antflags} javadoc"
+ eant ${antflags} || die "compilation failed"
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+
+ if use doc; then
+ dodoc RELEASE-NOTES.txt
+ java-pkg_dohtml DEVELOPERS-GUIDE.html PROPOSAL.html STATUS.html
+ java-pkg_dohtml -r dist/docs/
+ fi
+ use source && java-pkg_dosrc src/java/*
+}