summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2005-12-24 02:24:06 +0000
committerJoshua Nichols <nichoj@gentoo.org>2005-12-24 02:24:06 +0000
commit39ecf7e070b4c7ad0d0f4c91b97ecaf0aa5b2e40 (patch)
treea28c0cf8bd0989e9c6cbf2722b671a53e02b171e /dev-java/commons-jelly
parentStable on alpha + ia64, bug 115849. (diff)
downloadgentoo-2-39ecf7e070b4c7ad0d0f4c91b97ecaf0aa5b2e40.tar.gz
gentoo-2-39ecf7e070b4c7ad0d0f4c91b97ecaf0aa5b2e40.tar.bz2
gentoo-2-39ecf7e070b4c7ad0d0f4c91b97ecaf0aa5b2e40.zip
Initial commit (bug #70847).
(Portage version: 2.1_pre1)
Diffstat (limited to 'dev-java/commons-jelly')
-rw-r--r--dev-java/commons-jelly/ChangeLog11
-rw-r--r--dev-java/commons-jelly/Manifest4
-rw-r--r--dev-java/commons-jelly/commons-jelly-1.0.ebuild76
-rw-r--r--dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch62
-rw-r--r--dev-java/commons-jelly/files/digest-commons-jelly-1.01
-rw-r--r--dev-java/commons-jelly/metadata.xml5
6 files changed, 159 insertions, 0 deletions
diff --git a/dev-java/commons-jelly/ChangeLog b/dev-java/commons-jelly/ChangeLog
new file mode 100644
index 000000000000..0fde5adcfc49
--- /dev/null
+++ b/dev-java/commons-jelly/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-java/commons-jelly
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-jelly/ChangeLog,v 1.1 2005/12/24 02:24:06 nichoj Exp $
+
+*commons-jelly-1.0 (24 Dec 2005)
+
+ 24 Dec 2005; Joshua Nichols <nichoj@gentoo.org>
+ +files/commons-jelly-1.0-gentoo.patch, +metadata.xml,
+ +commons-jelly-1.0.ebuild:
+ Initial commit (bug #70847).
+
diff --git a/dev-java/commons-jelly/Manifest b/dev-java/commons-jelly/Manifest
new file mode 100644
index 000000000000..1f681118e5aa
--- /dev/null
+++ b/dev-java/commons-jelly/Manifest
@@ -0,0 +1,4 @@
+MD5 0bb2246aab186d20ff14b77d4413e933 commons-jelly-1.0.ebuild 1838
+MD5 02f70aa727e825f409b2893f3f165bc4 files/commons-jelly-1.0-gentoo.patch 2371
+MD5 b8e360e5058c49cde7c1a2b1e7d09542 files/digest-commons-jelly-1.0 73
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
diff --git a/dev-java/commons-jelly/commons-jelly-1.0.ebuild b/dev-java/commons-jelly/commons-jelly-1.0.ebuild
new file mode 100644
index 000000000000..4e708e76033d
--- /dev/null
+++ b/dev-java/commons-jelly/commons-jelly-1.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-jelly/commons-jelly-1.0.ebuild,v 1.1 2005/12/24 02:24:06 nichoj Exp $
+
+inherit java-pkg eutils
+
+MY_P="${P}-src"
+DESCRIPTION="A Java and XML based scripting and processing engine"
+HOMEPAGE="http://jakarta.apache.org/commons/jelly/"
+SRC_URI="mirror://apache/jakarta/commons/jelly/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~x86"
+IUSE="doc jikes junit source"
+
+COMMON_DEPS="~dev-java/servletapi-2.3
+ =dev-java/commons-cli-1*
+ dev-java/commons-lang
+ dev-java/commons-discovery
+ dev-java/forehead
+ dev-java/jakarta-jstl
+ =dev-java/commons-jexl-1.0*
+ =dev-java/commons-beanutils-1.6*
+ dev-java/commons-collections
+ =dev-java/dom4j-1*
+ =dev-java/jaxen-1.1*
+ =dev-java/xerces-2*"
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ jikes? ( dev-java/jikes )
+ test? (
+ dev-java/junit
+ dev-java/ant-tasks
+ dev-java/commons-logging
+ )
+ ${COMMON_DEPS}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPS}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # disables dependency fetching, and remove tests as a dependency of jar
+ epatch ${FILESDIR}/${P}-gentoo.patch
+
+ mkdir -p ${S}/lib
+ cd ${S}/lib
+ java-pkg_jar-from servletapi-2.3,commons-cli-1,commons-lang
+ java-pkg_jar-from commons-discovery,forehead,jakarta-jstl,commons-jexl-1.0
+ java-pkg_jar-from commons-beanutils-1.6,commons-collections
+ java-pkg_jar-from dom4j-1,jaxen-1.1,xerces-2
+
+ if use junit; then
+ java-pkg_jar-from commons-logging
+ fi
+}
+
+src_compile() {
+ local antflags="-Dlibdir=lib jar"
+ use doc && antflags="${antflags} javadoc"
+ use junit && antflags="${antflags} test"
+
+ ant ${antflags} || die "Ant failed"
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ dodoc NOTICE.txt README.txt RELEASE-NOTES.txt
+
+ use doc && java-pkg_dohtml -r dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch b/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch
new file mode 100644
index 000000000000..cf12b4826e19
--- /dev/null
+++ b/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch
@@ -0,0 +1,62 @@
+Only in commons-jelly-1.0-src-patched/: .build.xml.swp
+diff -ru commons-jelly-1.0-src/build.xml commons-jelly-1.0-src-patched/build.xml
+--- commons-jelly-1.0-src/build.xml 2005-06-16 10:39:44.000000000 -0400
++++ commons-jelly-1.0-src-patched/build.xml 2005-09-04 19:39:19.000000000 -0400
+@@ -37,6 +37,8 @@
+ <property name="proxy.password" value="">
+ </property>
+ <path id="build.classpath">
++ <fileset dir="${libdir}" includes="**/*.jar"/>
++ <!--
+ <pathelement location="${libdir}/servletapi/jars/servletapi-2.3.jar">
+ </pathelement>
+ <pathelement location="${libdir}/commons-cli/jars/commons-cli-1.0.jar">
+@@ -67,6 +69,7 @@
+ </pathelement>
+ <pathelement location="${libdir}/xerces/jars/xerces-2.2.1.jar">
+ </pathelement>
++ -->
+ </path>
+ <target name="init" description="o Initializes some properties">
+ <mkdir dir="${libdir}">
+@@ -92,7 +95,7 @@
+ </and>
+ </condition>
+ </target>
+- <target name="compile" description="o Compile the code" depends="get-deps">
++ <target name="compile" description="o Compile the code" depends="">
+ <mkdir dir="${classesdir}">
+ </mkdir>
+ <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+@@ -120,10 +123,12 @@
+ <copy todir="${classesdir}/META-INF" file="${basedir}/LICENSE.txt">
+ </copy>
+ </target>
+- <target name="jar" description="o Create the jar" depends="compile,test">
++
++ <target name="jar" description="o Create the jar" depends="compile">
+ <jar jarfile="${defaulttargetdir}/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}">
+ </jar>
+ </target>
++
+ <target name="clean" description="o Clean up the generated directories">
+ <delete dir="${defaulttargetdir}">
+ </delete>
+@@ -213,7 +218,7 @@
+ </fileset>
+ </copy>
+ </target>
+- <target name="javadoc" description="o Generate javadoc" depends="get-deps">
++ <target name="javadoc" description="o Generate javadoc" depends="">
+ <mkdir dir="${javadocdir}">
+ </mkdir>
+ <tstamp>
+@@ -432,4 +437,4 @@
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
+ </unjar>
+ </target>
+-</project>
+\ No newline at end of file
++</project>
+Only in commons-jelly-1.0-src-patched/: dist
+Only in commons-jelly-1.0-src-patched/: target
diff --git a/dev-java/commons-jelly/files/digest-commons-jelly-1.0 b/dev-java/commons-jelly/files/digest-commons-jelly-1.0
new file mode 100644
index 000000000000..7bb4df0cc817
--- /dev/null
+++ b/dev-java/commons-jelly/files/digest-commons-jelly-1.0
@@ -0,0 +1 @@
+MD5 d8c62cf844ca7ad8b6f34366eb2233c1 commons-jelly-1.0-src.tar.gz 174769
diff --git a/dev-java/commons-jelly/metadata.xml b/dev-java/commons-jelly/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-jelly/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>