summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-10-13 17:07:16 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-10-13 17:07:16 +0000
commit91e4b3c5c9971a82f6bace330b860342c9a444d2 (patch)
tree6845758df568020c1bdc76d41b1bebafda1d2e6a /dev-java/commons-httpclient
parentStable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-91e4b3c5c9971a82f6bace330b860342c9a444d2.tar.gz
gentoo-2-91e4b3c5c9971a82f6bace330b860342c9a444d2.tar.bz2
gentoo-2-91e4b3c5c9971a82f6bace330b860342c9a444d2.zip
version bump
Diffstat (limited to 'dev-java/commons-httpclient')
-rw-r--r--dev-java/commons-httpclient/ChangeLog8
-rw-r--r--dev-java/commons-httpclient/Manifest12
-rw-r--r--dev-java/commons-httpclient/commons-httpclient-2.0.2.ebuild48
-rw-r--r--dev-java/commons-httpclient/files/digest-commons-httpclient-2.0.21
4 files changed, 58 insertions, 11 deletions
diff --git a/dev-java/commons-httpclient/ChangeLog b/dev-java/commons-httpclient/ChangeLog
index fe0bd69bf740..106ed7f0b415 100644
--- a/dev-java/commons-httpclient/ChangeLog
+++ b/dev-java/commons-httpclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-httpclient
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/ChangeLog,v 1.9 2004/10/12 19:20:00 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/ChangeLog,v 1.10 2004/10/13 17:07:16 axxo Exp $
+
+*commons-httpclient-2.0.2 (13 Oct 2004)
+
+ 13 Oct 2004; Thomas Matthijs <axxo@gentoo.org>
+ +commons-httpclient-2.0.2.ebuild:
+ version bump
12 Oct 2004; Thomas Matthijs <axxo@gentoo.org>
commons-httpclient-2.0-r1.ebuild, commons-httpclient-2.0.1.ebuild:
diff --git a/dev-java/commons-httpclient/Manifest b/dev-java/commons-httpclient/Manifest
index df54e2f39628..4de5ae8e79a2 100644
--- a/dev-java/commons-httpclient/Manifest
+++ b/dev-java/commons-httpclient/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 ab33374dfff86c590745d0d56a66b709 commons-httpclient-2.0-r1.ebuild 1277
+MD5 5c51aa209417dd687d1f03e2461e9a82 commons-httpclient-2.0.2.ebuild 1557
MD5 5c51aa209417dd687d1f03e2461e9a82 commons-httpclient-2.0.1.ebuild 1557
MD5 56e4a0a544bb367ce3a07ad69fd84576 ChangeLog 1309
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 22c430c6bf50bc578f8095df5fd64cc4 files/digest-commons-httpclient-2.0.1 81
+MD5 63acee983ed2a9669cd20bc47743b8d3 files/digest-commons-httpclient-2.0.2 81
MD5 35bcb566781a909ae25bac9979bf497c files/gentoo.diff 444
MD5 70dbd7a345c0a9f6a17998de0191f13e files/digest-commons-httpclient-2.0-r1 79
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBbC/x/rLF9B432nYRAmzjAJ9ZldOXFC8uXZcOgX1uyhlKCFA6LgCdETx9
-xOZZ40gsw/O59HMcHduL4Nk=
-=YxaT
------END PGP SIGNATURE-----
diff --git a/dev-java/commons-httpclient/commons-httpclient-2.0.2.ebuild b/dev-java/commons-httpclient/commons-httpclient-2.0.2.ebuild
new file mode 100644
index 000000000000..2dd96e2413bb
--- /dev/null
+++ b/dev-java/commons-httpclient/commons-httpclient-2.0.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/commons-httpclient-2.0.2.ebuild,v 1.1 2004/10/13 17:07:16 axxo Exp $
+
+inherit java-pkg eutils
+
+DESCRIPTION="The Jakarta Commons HttpClient provides an efficient, up-to-date, and feature-rich package implementing the client side of the most recent HTTP standards and recommendations."
+HOMEPAGE="http://jakarta.apache.org/commons/httpclient/index.html"
+SRC_URI="mirror://apache/jakarta/commons/httpclient/source/${P/_/-}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="doc jikes"
+
+DEPEND=">=virtual/jdk-1.3
+ sys-apps/sed
+ >=dev-java/log4j-1.2.5
+ >=dev-java/ant-1.4
+ dev-java/commons-logging"
+RDEPEND=">=virtual/jdk-1.3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #make jikes happy
+ if use jikes; then
+ sed '837 s/ConnectionPool/org.apache.commons.httpclient.MultiThreadedHttpConnectionManager.ConnectionPool/' \
+ -i src/java/org/apache/commons/httpclient/MultiThreadedHttpConnectionManager.java \
+ || die "failed to sed"
+ fi
+
+ epatch ${FILESDIR}/gentoo.diff || die "patching failed"
+ echo "commons-logging.jar=/usr/share/commons-logging/lib/commons-logging.jar" >> build.properties
+}
+
+src_compile() {
+ local antflags="dist"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ ant ${antflags} || die "compilation failed"
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ use doc && dohtml -r dist/docs/*
+}
diff --git a/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0.2 b/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0.2
new file mode 100644
index 000000000000..3c685d62670c
--- /dev/null
+++ b/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0.2
@@ -0,0 +1 @@
+MD5 f3ae7736fbfb559cb228291427f22c2d commons-httpclient-2.0.2-src.tar.gz 1447937