summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-04-27 21:46:08 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-04-27 21:46:08 +0000
commit6b25ed8c293c7e399aaa2f624cf3cc66542f723e (patch)
treedfe08496d4b431d31dfb0b57f6aecb155b354c1e /dev-java/commons-grant
parentupdate metadata (diff)
downloadgentoo-2-6b25ed8c293c7e399aaa2f624cf3cc66542f723e.tar.gz
gentoo-2-6b25ed8c293c7e399aaa2f624cf3cc66542f723e.tar.bz2
gentoo-2-6b25ed8c293c7e399aaa2f624cf3cc66542f723e.zip
Remove unneeded dependency on junit, RDEPEND on dev-java/ant-core and stylistic cleanup.
(Portage version: 2.1.2.4)
Diffstat (limited to 'dev-java/commons-grant')
-rw-r--r--dev-java/commons-grant/ChangeLog9
-rw-r--r--dev-java/commons-grant/commons-grant-1.0_beta5-r1.ebuild36
2 files changed, 23 insertions, 22 deletions
diff --git a/dev-java/commons-grant/ChangeLog b/dev-java/commons-grant/ChangeLog
index df49a8bd138a..7ffe13d6c515 100644
--- a/dev-java/commons-grant/ChangeLog
+++ b/dev-java/commons-grant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/commons-grant
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-grant/ChangeLog,v 1.2 2006/07/22 22:46:32 nelchael Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-grant/ChangeLog,v 1.3 2007/04/27 21:46:08 betelgeuse Exp $
+
+ 27 Apr 2007; Petteri Räty <betelgeuse@gentoo.org>
+ commons-grant-1.0_beta5-r1.ebuild:
+ Remove unneeded dependency on junit, RDEPEND on dev-java/ant-core and
+ stylistic cleanup.
*commons-grant-1.0_beta5-r1 (22 Jul 2006)
diff --git a/dev-java/commons-grant/commons-grant-1.0_beta5-r1.ebuild b/dev-java/commons-grant/commons-grant-1.0_beta5-r1.ebuild
index f8c6ee1ca3ff..868c46595764 100644
--- a/dev-java/commons-grant/commons-grant-1.0_beta5-r1.ebuild
+++ b/dev-java/commons-grant/commons-grant-1.0_beta5-r1.ebuild
@@ -1,9 +1,12 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-grant/commons-grant-1.0_beta5-r1.ebuild,v 1.1 2006/07/22 22:46:32 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-grant/commons-grant-1.0_beta5-r1.ebuild,v 1.2 2007/04/27 21:46:08 betelgeuse Exp $
# Note: Upstream is dead... only place to find is on the ibiblio maven repo
# and on jpackage.org
+
+JAVA_PKG_IUSE="doc source"
+
inherit java-pkg-2 java-ant-2 eutils rpm
MY_PN="jakarta-${PN}"
SNAPSHOT_DATE="20040118"
@@ -16,11 +19,9 @@ DESCRIPTION="A small collection of hacks to make using Ant in an embedded envinr
# This link seems dead, but I don't have anywhere else to turn
HOMEPAGE="http://jakarta.apache.org/commons/sandbox/grant/"
SRC_URI="mirror://jpackage/1.6/generic/free/SRPMS/${MY_P}-${JPACKAGE_REVISION}jpp.src.rpm"
-DEPEND=">=virtual/jdk-1.3
- source? ( app-arch/zip )
- dev-java/ant-core
- dev-java/junit"
-RDEPEND=">=virtual/jre-1.3"
+DEPEND=">=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3
+ dev-java/ant-core"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -29,25 +30,20 @@ S="${WORKDIR}/${PN}-${MY_PV}"
src_unpack(){
rpm_src_unpack
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.diff
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.diff"
mkdir -p target/lib
cd target/lib
- java-pkg_jar-from junit
-}
-
-src_compile(){
- local antflags="jar"
- use doc && antflags="${antflags} javadoc"
- eant ${antflags} || die "compile failed"
+ java-pkg_jar-from ant-core
}
src_install(){
java-pkg_newjar target/${PN}-1.0-beta-4.jar ${PN}.jar
- use doc && java-pkg_dohtml -r dist/docs/api
+ use doc && java-pkg_dojavadoc dist/docs/api
use source && java-pkg_dosrc src/java/*
}
-src_test() {
- eant test || die "Test failed"
-}
+#No unit tests although the target exists
+#src_test() {
+# eant test || die "Test failed"
+#}