summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-07-08 13:14:42 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-07-08 13:14:42 +0000
commit5acbb3003e04057afb194a928a573dde1dd310b5 (patch)
tree3f45ea7b3d6cd3d5a4e92302cdb7750b66c0ac48 /dev-java/commons-daemon
parentVersion bump to 1.0.10. (diff)
downloadgentoo-2-5acbb3003e04057afb194a928a573dde1dd310b5.tar.gz
gentoo-2-5acbb3003e04057afb194a928a573dde1dd310b5.tar.bz2
gentoo-2-5acbb3003e04057afb194a928a573dde1dd310b5.zip
Version bump to 1.0.15.
(Portage version: 2.1.12.11/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/commons-daemon')
-rw-r--r--dev-java/commons-daemon/ChangeLog9
-rw-r--r--dev-java/commons-daemon/commons-daemon-1.0.15.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-java/commons-daemon/ChangeLog b/dev-java/commons-daemon/ChangeLog
index 886575424757..e53dc8e6d016 100644
--- a/dev-java/commons-daemon/ChangeLog
+++ b/dev-java/commons-daemon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/commons-daemon
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-daemon/ChangeLog,v 1.57 2012/08/24 12:30:52 xmw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-daemon/ChangeLog,v 1.58 2013/07/08 13:14:42 tomwij Exp $
+
+*commons-daemon-1.0.15 (08 Jul 2013)
+
+ 08 Jul 2013; Tom Wijsman <TomWij@gentoo.org> +commons-daemon-1.0.15.ebuild:
+ Version bump to 1.0.15.
24 Aug 2012; Michael Weber <xmw@gentoo.org> commons-daemon-1.0.9.ebuild:
ppc stable (bug 418709).
diff --git a/dev-java/commons-daemon/commons-daemon-1.0.15.ebuild b/dev-java/commons-daemon/commons-daemon-1.0.15.ebuild
new file mode 100644
index 000000000000..571a933843eb
--- /dev/null
+++ b/dev-java/commons-daemon/commons-daemon-1.0.15.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-daemon/commons-daemon-1.0.15.ebuild,v 1.1 2013/07/08 13:14:42 tomwij Exp $
+
+EAPI="5"
+
+WANT_AUTOCONF=2.5
+JAVA_PKG_IUSE="doc examples source"
+
+inherit eutils autotools java-pkg-2 java-ant-2
+
+DESCRIPTION="Tools to allow Java programs to run as UNIX daemons"
+SRC_URI="mirror://apache/commons/daemon/source/${P}-src.tar.gz"
+HOMEPAGE="http://commons.apache.org/daemon/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="kernel_linux"
+
+COMMON_DEP="kernel_linux? ( sys-libs/libcap )"
+
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.4"
+
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.4"
+
+S="${WORKDIR}/${P}-src"
+
+java_prepare() {
+ cd "${S}/src/native/unix" || die
+ sed -i "s/powerpc/powerpc|powerpc64/g" support/apsupport.m4 || die
+ eautoconf
+}
+
+src_configure() {
+ java-ant-2_src_configure
+ cd "${S}/src/native/unix" || die
+ default
+}
+
+src_compile() {
+ java-pkg-2_src_compile
+ cd "${S}/src/native/unix" || die
+ default
+}
+
+src_install() {
+ dobin src/native/unix/jsvc
+ java-pkg_newjar dist/*.jar
+
+ dodoc README RELEASE-NOTES.txt *.html src/native/unix/CHANGES.txt
+ use doc && java-pkg_dohtml -r dist/docs/*
+ use examples && java-pkg_doexamples src/samples
+ use source && java-pkg_dosrc src/main/java/*
+}