summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-06-05 13:17:59 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-06-05 13:17:59 +0000
commit8b138d3bff4ffbcfe423ef3cf1c0041ea783a43d (patch)
treedfcef6736e7ee41ce9ce0f240351dbe5ad48c61b /dev-java/commons-collections
parentIntroduced support for the source useflag. Cosmetic changes. (diff)
downloadgentoo-2-8b138d3bff4ffbcfe423ef3cf1c0041ea783a43d.tar.gz
gentoo-2-8b138d3bff4ffbcfe423ef3cf1c0041ea783a43d.tar.bz2
gentoo-2-8b138d3bff4ffbcfe423ef3cf1c0041ea783a43d.zip
Introduced support for the source useflag. Cosmetic changes.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/commons-collections')
-rw-r--r--dev-java/commons-collections/ChangeLog6
-rw-r--r--dev-java/commons-collections/Manifest2
-rw-r--r--dev-java/commons-collections/commons-collections-3.1.ebuild21
3 files changed, 18 insertions, 11 deletions
diff --git a/dev-java/commons-collections/ChangeLog b/dev-java/commons-collections/ChangeLog
index 7a8a3151fa91..853e628d3974 100644
--- a/dev-java/commons-collections/ChangeLog
+++ b/dev-java/commons-collections/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/commons-collections
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.27 2005/01/26 21:50:46 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.28 2005/06/05 13:17:59 luckyduck Exp $
+
+ 05 Jun 2005; Jan Brinkmann <luckyduck@gentoo.org>
+ commons-collections-3.1.ebuild:
+ Introduced support for the source useflag. Cosmetic changes.
26 Jan 2005; Markus Rothe <corsair@gentoo.org>
commons-collections-3.1.ebuild:
diff --git a/dev-java/commons-collections/Manifest b/dev-java/commons-collections/Manifest
index 99e31efd5c40..1bc61688df70 100644
--- a/dev-java/commons-collections/Manifest
+++ b/dev-java/commons-collections/Manifest
@@ -1,4 +1,4 @@
+MD5 2e1dc2ffb9c4330af232609239d4a32c commons-collections-3.1.ebuild 1207
MD5 59b0ed184e4eed5e92978b7dce35d44d ChangeLog 3901
-MD5 cbd2f05705c0e8fac5e8f680304ca28e commons-collections-3.1.ebuild 1159
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 d6999c3ed2ac2f04284b7b49641afcc9 files/digest-commons-collections-3.1 80
diff --git a/dev-java/commons-collections/commons-collections-3.1.ebuild b/dev-java/commons-collections/commons-collections-3.1.ebuild
index c6f4d04f9b86..d30f938f9856 100644
--- a/dev-java/commons-collections/commons-collections-3.1.ebuild
+++ b/dev-java/commons-collections/commons-collections-3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/commons-collections-3.1.ebuild,v 1.7 2005/01/26 21:50:46 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/commons-collections-3.1.ebuild,v 1.8 2005/06/05 13:17:59 luckyduck Exp $
inherit java-pkg eutils
@@ -11,16 +11,18 @@ SRC_URI="mirror://apache/jakarta/commons/collections/source/${PN}-${PV}-src.tar.
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 sparc ppc amd64 ppc64"
-IUSE="doc jikes"
+IUSE="doc jikes source"
+
DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4
- jikes? ( dev-java/jikes )"
+ dev-java/ant-core
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )"
RDEPEND=">=virtual/jre-1.3"
src_compile() {
local antflags="jar"
- use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
use doc && antflags="${antflags} javadoc"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
#when this is installed as a dep on ant
#junit ant task is not installed yet. so it cannot run
#use junit && antflags="${antflags} test"
@@ -28,9 +30,10 @@ src_compile() {
}
src_install() {
- mv build/${P}.jar build/${PN}.jar
- java-pkg_dojar build/${PN}.jar
- dodoc LICENSE.txt README.txt
+ java-pkg_newjar build/${P}.jar ${PN}.jar
+
+ dodoc README.txt
+ java-pkg_dohtml *.html
use doc && java-pkg_dohtml -r build/docs/apidocs
- dohtml *.html
+ use source && java-pkg_dosrc src/java/*
}