summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-03-28 03:39:38 +0000
committerTim Harder <radhermit@gentoo.org>2013-03-28 03:39:38 +0000
commita07f877d6b22939c0a256e5579cdb28a97b225e5 (patch)
treee3bf9cfbdbe5403b470febd4d53f16ab3d4aec5d /dev-java/cglib
parentConvert to distutils-r1. (diff)
downloadgentoo-2-a07f877d6b22939c0a256e5579cdb28a97b225e5.tar.gz
gentoo-2-a07f877d6b22939c0a256e5579cdb28a97b225e5.tar.bz2
gentoo-2-a07f877d6b22939c0a256e5579cdb28a97b225e5.zip
Version bump.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-java/cglib')
-rw-r--r--dev-java/cglib/ChangeLog10
-rw-r--r--dev-java/cglib/cglib-2.2.3.ebuild64
-rw-r--r--dev-java/cglib/files/cglib-2.2.3-build.patch44
3 files changed, 116 insertions, 2 deletions
diff --git a/dev-java/cglib/ChangeLog b/dev-java/cglib/ChangeLog
index 9e64ded1b863..cba690a949ce 100644
--- a/dev-java/cglib/ChangeLog
+++ b/dev-java/cglib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/cglib
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/cglib/ChangeLog,v 1.51 2010/04/24 17:47:55 grobian Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/cglib/ChangeLog,v 1.52 2013/03/28 03:39:38 radhermit Exp $
+
+*cglib-2.2.3 (28 Mar 2013)
+
+ 28 Mar 2013; Tim Harder <radhermit@gentoo.org> +cglib-2.2.3.ebuild,
+ +files/cglib-2.2.3-build.patch:
+ Version bump.
24 Apr 2010; Fabian Groffen <grobian@gentoo.org> cglib-2.2.ebuild:
Marked ~sparc-solaris ~x86-solaris, bug #314093
diff --git a/dev-java/cglib/cglib-2.2.3.ebuild b/dev-java/cglib/cglib-2.2.3.ebuild
new file mode 100644
index 000000000000..ad79b499d850
--- /dev/null
+++ b/dev-java/cglib/cglib-2.2.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/cglib/cglib-2.2.3.ebuild,v 1.1 2013/03/28 03:39:38 radhermit Exp $
+
+EAPI=5
+JAVA_PKG_IUSE="test doc examples source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="cglib is a powerful, high performance and quality Code Generation Library."
+HOMEPAGE="http://cglib.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PN}.${PV}.zip"
+LICENSE="Apache-2.0"
+SLOT="2.2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+COMMON_DEP="dev-java/asm:3
+ >=dev-java/ant-core-1.7.0:0"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ test? ( dev-java/junit:0 )
+ ${COMMON_DEP}"
+
+S=${WORKDIR}
+
+EANT_GENTOO_CLASSPATH="asm-3,ant-core"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_TEST_JUNIT_INTO="lib"
+EANT_TEST_EXTRA_ARGS="-DdebugLocation=${T}/debug"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unzip -q ${PN}-src-${PV}.jar || die
+}
+
+java_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+
+ # fix line endings otherwise patch fails
+ edos2unix src/test/net/sf/cglib/CodeGenTestCase.java
+ # mem leak tests fail on ppc #284316
+ # assuming gc() guarantees to free all memory is wrong, so don't make them fail
+ epatch "${FILESDIR}/${PN}-2.2-no-leak-test.patch"
+
+ cp "${FILESDIR}"/words.txt src/test/net/sf/cglib/util/ || die
+
+ find . -name '*.jar' -delete
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar
+ dodoc NOTICE README
+
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc src/proxy/net
+ use examples && java-pkg_doexamples --subdir samples src/proxy/samples
+}
diff --git a/dev-java/cglib/files/cglib-2.2.3-build.patch b/dev-java/cglib/files/cglib-2.2.3-build.patch
new file mode 100644
index 000000000000..15aa07dfa987
--- /dev/null
+++ b/dev-java/cglib/files/cglib-2.2.3-build.patch
@@ -0,0 +1,44 @@
+--- cglib.2.2.3/build.xml
++++ cglib.2.2.3/build.xml
+@@ -73,7 +73,7 @@
+ <target depends="prepare" description="Compile shareable components"
+ name="compile">
+ <javac debug="${compile.debug}" deprecation="${compile.deprecation}" destdir="${build.home}/classes" optimize="${compile.optimize}" srcdir="${source.home}"
+- target="${compile.target}" bootclasspath="${compile.bootclasspath}" extdirs="${compile.extdirs}" source="${compile.source}">
++ target="${compile.target}" extdirs="${compile.extdirs}" source="${compile.source}">
+ <classpath refid="compile.classpath"/>
+ <compilerarg compiler="jikes" value="-nowarn"/>
+ </javac>
+@@ -123,15 +123,6 @@
+ <include name="**/*"/>
+ <exclude name="samples/**" />
+ </jar>
+-
+- <taskdef name="jarjar" classname="com.tonicsystems.jarjar.JarJarTask" classpathref="compile.classpath"/>
+- <jarjar basedir="${build.home}/classes" jarfile="${dist.home}/${component.name}-nodep-${component.version}.jar" >
+- <zipfileset dir="lib" includes="asm*.txt"/>
+- <zipfileset src="lib/asm-3.1.jar" excludes="META-INF"/>
+- <rule pattern="org.objectweb.asm.**" result="net.sf.cglib.asm.@1"/>
+- <include name="**/*"/>
+- <exclude name="samples/**"/>
+- </jarjar>
+ </target>
+
+ <target depends="compile,javadoc" description="Create docs and source distribution" name="srcjar">
+@@ -240,15 +231,7 @@
+ fork="yes"
+ >
+
+- <!-- jvmarg value="-Xrunhprof:heap=all,file=debug.txt"/ -->
+- <!-- <jvmarg value="-verbose:gc"/> -->
+- <!-- <jvmarg value="-verbose:class"/> -->
+- <!-- <jvmarg value="-Xprof"/> -->
+- <!-- <jvmarg value="-server"/> -->
+- <!-- <sysproperty key="cglib.debugLocation" value="debug"/> -->
+- <!-- <jvmarg value="-Djava.security.policy==java.policy" /> -->
+- <!-- <jvmarg value="-Djava.security.manager" /> -->
+-
++ <sysproperty key="cglib.debugLocation" value="${debugLocation}"/>
+ <arg value="${test.entry}"/>
+ <classpath>
+ <pathelement path="${build.home}/classes"/>