summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-07-05 05:19:25 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-07-05 05:19:25 +0000
commitc79f75d55ed61a07cdfb13a699fdb5776e3db7d1 (patch)
tree3a4ea84c2e8c77670fb27e3b3343f21270a2a6af /dev-java/cglib/cglib-2.0.2-r2.ebuild
parentremoved unneccesary make clean from src_test (diff)
downloadgentoo-2-c79f75d55ed61a07cdfb13a699fdb5776e3db7d1.tar.gz
gentoo-2-c79f75d55ed61a07cdfb13a699fdb5776e3db7d1.tar.bz2
gentoo-2-c79f75d55ed61a07cdfb13a699fdb5776e3db7d1.zip
Version and revision bumps to support new Java system.
(Portage version: 2.1.1_pre1)
Diffstat (limited to 'dev-java/cglib/cglib-2.0.2-r2.ebuild')
-rw-r--r--dev-java/cglib/cglib-2.0.2-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-java/cglib/cglib-2.0.2-r2.ebuild b/dev-java/cglib/cglib-2.0.2-r2.ebuild
new file mode 100644
index 000000000000..c09744d9b335
--- /dev/null
+++ b/dev-java/cglib/cglib-2.0.2-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/cglib/cglib-2.0.2-r2.ebuild,v 1.1 2006/07/05 05:19:25 nichoj Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="A powerful, high performance and quality Code Generation Library, It is used to extend Java classes and implements interfaces at runtime."
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.jar"
+HOMEPAGE="http://cglib.sourceforge.net"
+LICENSE="Apache-1.1"
+SLOT="2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+COMMON_DEP="
+ source? ( app-arch/zip )
+ =dev-java/asm-1.4*
+ =dev-java/aspectwerkz-2*"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.5
+ ${COMMON_DEP}"
+IUSE="doc source"
+
+S=${WORKDIR}
+
+ant_src_unpack() {
+ jar xf ${DISTDIR}/${A} || die "failed to unpack"
+
+ epatch ${FILESDIR}/${P}-asm-1.4.3.patch
+
+ cd ${S}/lib
+ rm -f *.jar
+ java-pkg_jar-from asm-1.4
+ java-pkg_jar-from aspectwerkz-2
+}
+
+src_compile() {
+ eant jar $(use_doc)
+}
+
+src_install() {
+ java-pkg_newjar dist/${PN}-${PV}.jar ${PN}.jar
+ java-pkg_newjar dist/${PN}-full-${PV}.jar ${PN}-full.jar
+
+ dodoc NOTICE README
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/proxy/net
+}