summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-03-19 23:29:24 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-03-19 23:29:24 +0000
commit3635f9612114cb917737a6510e8fdcd4f2369291 (patch)
tree95a640414625958d967ff95772b2c80e178317ca /dev-java/batik/batik-1.5.ebuild
parentgiflib fixes; bug 85720 (diff)
downloadgentoo-2-3635f9612114cb917737a6510e8fdcd4f2369291.tar.gz
gentoo-2-3635f9612114cb917737a6510e8fdcd4f2369291.tar.bz2
gentoo-2-3635f9612114cb917737a6510e8fdcd4f2369291.zip
version 1.5 is needed to remove the packed jar issue from dev-java/fop, see #63262. now all jars are accessible by jar-from, java-config -p etc
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-java/batik/batik-1.5.ebuild')
-rw-r--r--dev-java/batik/batik-1.5.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-java/batik/batik-1.5.ebuild b/dev-java/batik/batik-1.5.ebuild
new file mode 100644
index 000000000000..5ef239c3f2af
--- /dev/null
+++ b/dev-java/batik/batik-1.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/batik-1.5.ebuild,v 1.8 2005/03/19 23:29:24 luckyduck Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Batik is a Java(tm) technology based toolkit for applications or applets that want to use images in the Scalable Vector Graphics (SVG) format for various purposes, such as viewing, generation or manipulation."
+SRC_URI="mirror://apache/xml/batik/${PN}-src-${PV}.zip"
+HOMEPAGE="http://xml.apache.org/batik/"
+IUSE="doc"
+DEPEND=">=virtual/jdk-1.3
+ =dev-java/rhino-1.5*
+ app-arch/unzip
+ >=dev-java/xerces-2.6.2-r1
+ dev-java/ant"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="1.5"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+
+S=${WORKDIR}/xml-batik
+
+src_unpack() {
+ jar xf ${DISTDIR}/${PN}-src-${PV}.zip
+ cd ${S}/lib
+ rm -f *.jar
+ java-pkg_jar-from xerces-2
+ java-pkg_jar-from rhino-1.5
+}
+
+src_compile() {
+ export ANT_OPTS=-Xmx256m
+ local antflags="jars all-jar"
+ ant ${antflags} || die "compile problem"
+}
+
+src_install () {
+ java-pkg_dojar ${P}/batik*.jar
+
+ cd ${P}/lib
+ rm {js,x*}.jar
+
+ # needed because batik expects this layout:
+ # batik.jar lib/*.jar
+ # there are hardcoded classpathes in the manifest :(
+ for jar in *.jar
+ do
+ java-pkg_dojar ${jar}
+ rm -f ${jar}
+ ln -s ${DESTTREE}/share/${PN}/lib/${jar} ${jar}
+ done
+
+ cd ${S}
+ cp -ra ${P}/lib ${D}${DESTTREE}/share/${PN}/lib/
+
+ dodoc README LICENSE
+ use doc && java-pkg_dohtml -r ${P}/docs/
+
+ echo "#!/bin/sh" > ${PN}
+ echo '${JAVA_HOME}/bin/java -classpath $(java-config -p batik,xerces-2,rhino-1.5) org.apache.batik.apps.svgbrowser.Main $*' >> ${PN}
+ dobin ${PN}
+
+}