summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-07-05 14:38:33 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-07-05 14:38:33 +0000
commit108cf1201fe773b19adf133028aa49f7a56b69df (patch)
tree1c615973e07d2f88fff2359f58ef8dd422548603 /dev-java/ant
parentVersion bump to 1.9.1. (diff)
downloadgentoo-2-108cf1201fe773b19adf133028aa49f7a56b69df.tar.gz
gentoo-2-108cf1201fe773b19adf133028aa49f7a56b69df.tar.bz2
gentoo-2-108cf1201fe773b19adf133028aa49f7a56b69df.zip
Version bump to 1.9.1.
(Portage version: 2.1.12.11/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/ant')
-rw-r--r--dev-java/ant/ChangeLog9
-rw-r--r--dev-java/ant/ant-1.9.1.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/dev-java/ant/ChangeLog b/dev-java/ant/ChangeLog
index 10c1cacef06d..4a0a7bc8d3d6 100644
--- a/dev-java/ant/ChangeLog
+++ b/dev-java/ant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ant
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ChangeLog,v 1.138 2012/12/05 17:26:47 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ChangeLog,v 1.139 2013/07/05 14:38:33 tomwij Exp $
+
+*ant-1.9.1 (05 Jul 2013)
+
+ 05 Jul 2013; Tom Wijsman <TomWij@gentoo.org> +ant-1.9.1.ebuild:
+ Version bump to 1.9.1.
05 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ant-1.8.4.ebuild:
Stable for ppc64, wrt bug #417909
diff --git a/dev-java/ant/ant-1.9.1.ebuild b/dev-java/ant/ant-1.9.1.ebuild
new file mode 100644
index 000000000000..41f031a4f051
--- /dev/null
+++ b/dev-java/ant/ant-1.9.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.9.1.ebuild,v 1.1 2013/07/05 14:38:33 tomwij Exp $
+
+EAPI="5"
+
+inherit versionator
+
+DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd \
+ ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris \
+ ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="~dev-java/ant-core-${PV}"
+RDEPEND="${DEPEND}"
+
+IUSE="X +antlr +bcel +bsf +commonslogging +commonsnet jai +javamail +jdepend jmf
+ +jsch +log4j +oro +regexp +resolver testutil"
+
+RDEPEND="~dev-java/ant-core-${PV}
+ ~dev-java/ant-nodeps-${PV}
+ ~dev-java/ant-junit-${PV}
+ !dev-java/ant-optional
+ !dev-java/ant-tasks
+ ~dev-java/ant-trax-${PV}
+ ~dev-java/ant-apache-xalan2-${PV}
+ antlr? ( ~dev-java/ant-antlr-${PV} )
+ bcel? ( ~dev-java/ant-apache-bcel-${PV} )
+ bsf? ( ~dev-java/ant-apache-bsf-${PV} )
+ log4j? ( ~dev-java/ant-apache-log4j-${PV} )
+ oro? ( ~dev-java/ant-apache-oro-${PV} )
+ regexp? ( ~dev-java/ant-apache-regexp-${PV} )
+ resolver? ( ~dev-java/ant-apache-resolver-${PV} )
+ commonslogging? ( ~dev-java/ant-commons-logging-${PV} )
+ commonsnet? ( ~dev-java/ant-commons-net-${PV} )
+ jai? ( ~dev-java/ant-jai-${PV} )
+ javamail? ( ~dev-java/ant-javamail-${PV} )
+ jdepend? ( ~dev-java/ant-jdepend-${PV} )
+ jmf? ( ~dev-java/ant-jmf-${PV} )
+ jsch? ( ~dev-java/ant-jsch-${PV} )
+ testutil? ( ~dev-java/ant-testutil-${PV} )
+ X? ( ~dev-java/ant-swing-${PV} )"
+
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_compile() { :; }
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ # if we update from a version below 1.7.1
+ if ! version_is_at_least 1.7.1 ${REPLACING_VERSIONS}; then
+ elog "Since 1.7.1, the ant-tasks meta-ebuild has been removed and its USE"
+ elog "flags have been moved to dev-java/ant."
+ elog
+ elog "You may now freely set the USE flags of this package without breaking"
+ elog "building of Java packages, which depend on the exact ant tasks they need."
+ elog "The USE flags default to enabled (except X, jai and jmf) for convenience."
+ fi
+ fi
+}