summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-08-28 22:22:05 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-08-28 22:22:05 +0000
commitee955931fcef2839cd9d17a07b7b98a9b52f986d (patch)
treeaff729ed616fbb924d0a6af79dde202fefcdb8b3 /dev-java/ant-testutil
parentVersion bump to 1.9.2. Fixes security bug #476958. (diff)
downloadgentoo-2-ee955931fcef2839cd9d17a07b7b98a9b52f986d.tar.gz
gentoo-2-ee955931fcef2839cd9d17a07b7b98a9b52f986d.tar.bz2
gentoo-2-ee955931fcef2839cd9d17a07b7b98a9b52f986d.zip
Version bump to 1.9.2. Fixes security bug #476958.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/ant-testutil')
-rw-r--r--dev-java/ant-testutil/ChangeLog7
-rw-r--r--dev-java/ant-testutil/ant-testutil-1.9.2.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-java/ant-testutil/ChangeLog b/dev-java/ant-testutil/ChangeLog
index 187ed23d98bd..a7d013e2fc82 100644
--- a/dev-java/ant-testutil/ChangeLog
+++ b/dev-java/ant-testutil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ant-testutil
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ChangeLog,v 1.18 2013/07/05 14:28:11 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ChangeLog,v 1.19 2013/08/28 22:22:05 tomwij Exp $
+
+*ant-testutil-1.9.2 (28 Aug 2013)
+
+ 28 Aug 2013; Tom Wijsman <TomWij@gentoo.org> +ant-testutil-1.9.2.ebuild:
+ Version bump to 1.9.2. Fixes security bug #476958.
*ant-testutil-1.9.1 (05 Jul 2013)
diff --git a/dev-java/ant-testutil/ant-testutil-1.9.2.ebuild b/dev-java/ant-testutil/ant-testutil-1.9.2.ebuild
new file mode 100644
index 000000000000..52c060368582
--- /dev/null
+++ b/dev-java/ant-testutil/ant-testutil-1.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ant-testutil-1.9.2.ebuild,v 1.1 2013/08/28 22:22:05 tomwij Exp $
+
+EAPI="5"
+
+inherit ant-tasks
+
+DESCRIPTION="Apache Ant's optional test utility classes"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux \
+ ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris \
+ ~x64-solaris ~x86-solaris"
+
+CDEPEND="dev-java/ant-core:0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.6
+ >=dev-java/junit-4.11:4
+ ~dev-java/ant-swing-${PV}
+ ~dev-java/ant-junit4-${PV}"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+
+# The build system builds much more than it actually packages, so there are many
+# build-only deps, but since those are quite common, it wasn't worth to patch it.
+
+src_unpack() {
+ ant-tasks_src_unpack base
+ java-pkg_jar-from --build-only junit-4,ant-junit4,ant-swing
+ java-pkg_jar-from --build-only ant-core ant-launcher.jar
+}
+
+src_compile() {
+ eant test-jar
+}