summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2011-12-31 11:23:53 +0000
committerRalph Sennhauser <sera@gentoo.org>2011-12-31 11:23:53 +0000
commit530a282a8cbe0199ababb31285d01b48dbaf7608 (patch)
treeebc1f2b288dfbb5d8348009055f2b8fad3229ca3 /dev-java/ant-testutil
parentStable for AMD64, wrt bug #396513 (diff)
downloadgentoo-2-530a282a8cbe0199ababb31285d01b48dbaf7608.tar.gz
gentoo-2-530a282a8cbe0199ababb31285d01b48dbaf7608.tar.bz2
gentoo-2-530a282a8cbe0199ababb31285d01b48dbaf7608.zip
Restore 1.8.0 as there still are reverse dependencies, drop ia64 keyword
(Portage version: 2.1.10.43/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/ant-testutil')
-rw-r--r--dev-java/ant-testutil/ChangeLog5
-rw-r--r--dev-java/ant-testutil/ant-testutil-1.8.0.ebuild32
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-java/ant-testutil/ChangeLog b/dev-java/ant-testutil/ChangeLog
index f4bba353d714..d13fc49ed32f 100644
--- a/dev-java/ant-testutil/ChangeLog
+++ b/dev-java/ant-testutil/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-java/ant-testutil
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ChangeLog,v 1.8 2011/12/25 22:35:20 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ChangeLog,v 1.9 2011/12/31 11:23:53 sera Exp $
+
+ 31 Dec 2011; Ralph Sennhauser <sera@gentoo.org> +ant-testutil-1.8.0.ebuild:
+ Restore 1.8.0 as there still are reverse dependencies, drop ia64 keyword
25 Dec 2011; Miroslav Šulc <fordfrog@gentoo.org> ant-testutil-1.8.1.ebuild:
Restricted compilation to JDK 1.6 because of JDBC incompatibility with JDK
diff --git a/dev-java/ant-testutil/ant-testutil-1.8.0.ebuild b/dev-java/ant-testutil/ant-testutil-1.8.0.ebuild
new file mode 100644
index 000000000000..7754ca2d9994
--- /dev/null
+++ b/dev-java/ant-testutil/ant-testutil-1.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ant-testutil-1.8.0.ebuild,v 1.4 2011/12/31 11:23:53 sera Exp $
+
+EAPI="1"
+
+inherit ant-tasks
+
+DESCRIPTION="Apache Ant's optional test utility classes"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="dev-java/junit:0
+ ~dev-java/ant-nodeps-${PV}
+ ~dev-java/ant-swing-${PV}
+ ~dev-java/ant-trax-${PV}
+ ~dev-java/ant-junit-${PV}"
+RDEPEND=""
+
+IUSE=""
+
+# the build system builds much more than it actually packages, so there are many
+# build-only deps, but since those are quite common, it wasn't worth to patch it
+
+src_unpack() {
+ ant-tasks_src_unpack base
+ java-pkg_jar-from --build-only junit,ant-nodeps,ant-junit,ant-swing,ant-trax
+ java-pkg_jar-from --build-only ant-core ant-launcher.jar
+}
+
+src_compile() {
+ eant test-jar
+}