summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-05-23 15:28:08 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-05-23 15:28:08 +0000
commit345a073fbc8a3dc9a7166b14339d6d51b87b9c41 (patch)
tree8e2d84c43946bd508b5caca10691f4e2aa441e81 /dev-java/ant-core
parentappend -fno-pic instead of filtering -fPIC for hardened gcc. (diff)
downloadgentoo-2-345a073fbc8a3dc9a7166b14339d6d51b87b9c41.tar.gz
gentoo-2-345a073fbc8a3dc9a7166b14339d6d51b87b9c41.tar.bz2
gentoo-2-345a073fbc8a3dc9a7166b14339d6d51b87b9c41.zip
version bump
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/ant-core')
-rw-r--r--dev-java/ant-core/ChangeLog8
-rw-r--r--dev-java/ant-core/Manifest13
-rw-r--r--dev-java/ant-core/ant-core-1.6.4.ebuild74
-rw-r--r--dev-java/ant-core/files/1.6.4-ant169
-rw-r--r--dev-java/ant-core/files/digest-ant-core-1.6.41
5 files changed, 254 insertions, 11 deletions
diff --git a/dev-java/ant-core/ChangeLog b/dev-java/ant-core/ChangeLog
index c4216f5c9c56..d3bbfc939464 100644
--- a/dev-java/ant-core/ChangeLog
+++ b/dev-java/ant-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/ant-core
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ChangeLog,v 1.22 2005/05/14 16:09:55 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ChangeLog,v 1.23 2005/05/23 15:27:38 axxo Exp $
+
+*ant-core-1.6.4 (23 May 2005)
+
+ 23 May 2005; Thomas Matthijs <axxo@gentoo.org> +files/1.6.4-ant,
+ +ant-core-1.6.4.ebuild:
+ version bump
*ant-core-1.6.3-r1 (14 May 2005)
*ant-core-1.6.2-r3 (14 May 2005)
diff --git a/dev-java/ant-core/Manifest b/dev-java/ant-core/Manifest
index e9969b858de9..cd1ef2713e2f 100644
--- a/dev-java/ant-core/Manifest
+++ b/dev-java/ant-core/Manifest
@@ -1,24 +1,17 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 86bcd9a42032995117fea267bb534a81 ant-core-1.6.3-r1.ebuild 1892
MD5 e9577f39414ff99938fdadbd15ce5359 ant-core-1.5.4-r2.ebuild 3054
MD5 d7a1be742cbb1bb5559d98a30c3f9f8f ant-core-1.6.2-r3.ebuild 2006
MD5 a9dd55887d945e2f3c6e9226eccea099 ChangeLog 17057
MD5 123cf9440c1d4ac78f2caba1624765f9 metadata.xml 158
+MD5 86bcd9a42032995117fea267bb534a81 ant-core-1.6.4.ebuild 1892
MD5 d7186edf4c71dc0531330f90e2c08fe9 files/1.5.4-ant 2283
MD5 266150e6155c8ed106991dc0cac5814f files/1.6.2-ant 5066
MD5 7a35d5c1dcf78f1fe704e35baebee961 files/1.6.3-ant 5066
+MD5 7a35d5c1dcf78f1fe704e35baebee961 files/1.6.4-ant 5066
MD5 4383441650437fec5622070e48e4324c files/build.sh-exit-fix.patch.gz 256
MD5 55ece9ccf573b244b3dff966839528c5 files/rpmbuild.patch.gz 1164
MD5 8d86f265f37d0d73cdd2e8a3fd2ff6eb files/digest-ant-core-1.5.4-r2 70
MD5 aac477e88787ed6f0ad5cabe0f6a001a files/digest-ant-core-1.6.2-r3 74
MD5 4abd275148cde1e1c88e8ff4097cbcd8 files/digest-ant-core-1.6.3-r1 74
MD5 8c69a473b88559829069ac80730f2f1b files/1.6.2-scp.patch 877
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFChiLn06ebR+OMO78RAodWAJ9dN7LUag8cLcSHx7kXoDMINc8WgACfWRUI
-mC/wItW4b5LwCLhPp/MwRok=
-=0G/f
------END PGP SIGNATURE-----
+MD5 76459e58a469653b3d3cfd4993b22373 files/digest-ant-core-1.6.4 74
diff --git a/dev-java/ant-core/ant-core-1.6.4.ebuild b/dev-java/ant-core/ant-core-1.6.4.ebuild
new file mode 100644
index 000000000000..21f702302514
--- /dev/null
+++ b/dev-java/ant-core/ant-core-1.6.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.6.4.ebuild,v 1.1 2005/05/23 15:27:38 axxo Exp $
+
+inherit java-pkg eutils
+
+MY_PN=${PN/-core}
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
+SRC_URI="mirror://apache/ant/source/apache-${MY_PN}-${PV}-src.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~ppc64"
+IUSE="doc"
+
+DEPEND="virtual/libc
+ >=virtual/jdk-1.4
+ >=dev-java/java-config-1.2"
+RDEPEND=">=virtual/jdk-1.4
+ app-shells/bash
+ >=dev-java/java-config-1.2"
+
+S="${WORKDIR}/apache-ant-${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Patch build.sh to die with non-zero exit code in case of errors.
+ # This patch may be useful for all ant versions.
+ epatch ${FILESDIR}/build.sh-exit-fix.patch.gz
+}
+
+src_compile() {
+ addwrite "/proc/self/maps"
+ if [ `arch` == "ppc" ] ; then
+ # We're compiling _ON_ PPC
+ export THREADS_FLAG="green"
+ fi
+
+
+ local myc
+ myc="${myc} -Ddist.dir=${D}/usr/share/${PN}"
+ myc="${myc} -Djavac.target=1.4"
+ echo $CLASSPATH
+ CLASSPATH="." ./build.sh -Ddist.dir=${D}/usr/share/${PN} || die
+
+ use doc && ./build.sh dist_javadocs
+}
+
+src_install() {
+ newbin ${FILESDIR}/${PV/_*}-ant ant || die "failed to install wrapper"
+
+ dodir /usr/share/${PN}/bin
+ for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
+ dobin ${S}/src/script/${each}
+ dosym /usr/bin/${each} /usr/share/${PN}/bin/${each}
+ done
+
+ dodir /etc/env.d
+ echo "ANT_HOME=\"/usr/share/${PN}\"" > ${D}/etc/env.d/20ant
+
+ java-pkg_dojar build/lib/ant.jar
+ java-pkg_dojar build/lib/ant-launcher.jar
+
+ dodoc README WHATSNEW KEYS
+ use doc && dohtml welcome.html
+ use doc && java-pkg_dohtml -r docs/*
+ use doc && java-pkg_dohtml -r dist/docs/manual/api/*
+}
diff --git a/dev-java/ant-core/files/1.6.4-ant b/dev-java/ant-core/files/1.6.4-ant
new file mode 100644
index 000000000000..eafe25e88985
--- /dev/null
+++ b/dev-java/ant-core/files/1.6.4-ant
@@ -0,0 +1,169 @@
+#! /bin/bash
+
+# Copyright 2001-2004 The Apache Software Foundation
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# Edited for Gentoo Linux
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/files/1.6.4-ant,v 1.1 2005/05/23 15:27:38 axxo Exp $
+
+# Extract launch and ant arguments, (see details below).
+ant_exec_args=
+no_config=false
+use_jikes_default=false
+ant_exec_debug=false
+show_help=false
+for arg in "$@" ; do
+ if [ "$arg" = "--noconfig" ] ; then
+ no_config=true
+ elif [ "$arg" = "--usejikes" ] ; then
+ use_jikes_default=true
+ elif [ "$arg" = "--execdebug" ] ; then
+ ant_exec_debug=true
+ elif [ my"$arg" = my"--h" -o my"$arg" = my"--help" ] ; then
+ show_help=true
+ ant_exec_args="$ant_exec_args -h"
+ else
+ if [ my"$arg" = my"-h" -o my"$arg" = my"-help" ] ; then
+ show_help=true
+ fi
+ ant_exec_args="$ant_exec_args \"$arg\""
+ fi
+done
+
+# Source/default ant configuration
+if $no_config ; then
+ rpm_mode=false
+ usejikes=$use_jikes_default
+else
+ # load system-wide ant configuration
+ if [ -f "/etc/ant.conf" ] ; then
+ . /etc/ant.conf
+ fi
+
+ # load user ant configuration
+ if [ -f "$HOME/.ant/ant.conf" ] ; then
+ . $HOME/.ant/ant.conf
+ fi
+ if [ -f "$HOME/.antrc" ] ; then
+ . "$HOME/.antrc"
+ fi
+
+ # provide default configuration values
+ if [ -z "$rpm_mode" ] ; then
+ rpm_mode=false
+ fi
+ if [ -z "$usejikes" ] ; then
+ usejikes=$use_jikes_default
+ fi
+fi
+
+
+if [ -z $JAVA_HOME ] ; then
+ if [ -f $HOME/.gentoo/java-env ] ; then
+ source $HOME/.gentoo/java-env
+ else
+ JAVA_HOME=`java-config --jdk-home`
+ CLASSPATH=`java-config --classpath`:${CLASSPATH}
+ fi
+fi
+
+if [ -z $JAVA_HOME ] ; then
+ echo "Error: No JDK found!"
+ echo "Try using java-config script to set your JDK"
+ echo "Remember that you need a JDK not a JRE"
+ exit 1
+fi
+
+ANT_HOME=/usr/share/ant-core
+
+# set ANT_LIB location
+ANT_LIB="${ANT_HOME}/lib"
+
+JAVACMD="`java-config --java`"
+
+if [ ! -x "$JAVACMD" ] ; then
+ echo "Error: JAVA_HOME is not defined correctly."
+ echo " We cannot execute $JAVACMD"
+ exit 1
+fi
+
+if [ -z "$LOCALCLASSPATH" ] ; then
+ LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar
+else
+ LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar:$LOCALCLASSPATH
+fi
+
+# add in the dependency .jar files
+LOCALCLASSPATH="${LOCALCLASSPATH}:`java-config --classpath=ant-core,ant-tasks,log4j,xerces-2,xalan,junit,antlr,bcel,bsh,commons-beanutils-1.6,commons-collections,commons-logging,commons-net,jakarta-oro-2.0,jdepend,jsch,jakarta-regexp-1.3,rhino-1.5,jython,jta,jaf,javamail 2> /dev/null`"
+
+if [ -n "$JAVA_HOME" ] ; then
+ if [ -f "$JAVA_HOME/lib/tools.jar" ] ; then
+ LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/tools.jar"
+ fi
+
+ if [ -f "$JAVA_HOME/lib/classes.zip" ] ; then
+ LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/classes.zip"
+ fi
+
+else
+ echo "Warning: JAVA_HOME environment variable is not set (or not exported)."
+ echo " If build fails because sun.* classes could not be found"
+ echo " you will need to set the JAVA_HOME environment variable"
+ echo " to the installation directory of java."
+ echo " Try using java-config script"
+fi
+
+# Allow Jikes support (off by default)
+if $usejikes; then
+ ANT_OPTS="$ANT_OPTS -Dbuild.compiler=jikes"
+fi
+
+# Show script help if requested
+if $show_help ; then
+ echo $0 '[script options] [options] [target [target2 [target3] ..]]'
+ echo 'Script Options:'
+ echo ' --help, --h print this message and ant help'
+ echo ' --noconfig suppress sourcing of /etc/ant.conf,'
+ echo ' $HOME/.ant/ant.conf, and $HOME/.antrc'
+ echo ' configuration files'
+ echo ' --usejikes enable use of jikes by default, unless'
+ echo ' set explicitly in configuration files'
+ echo ' --execdebug print ant exec line generated by this'
+ echo ' launch script'
+ echo ' '
+fi
+
+# Execute ant using eval/exec to preserve spaces in paths,
+# java options, and ant args
+ant_sys_opts=
+
+
+if [ -n "$JIKESPATH" ]; then
+ ant_sys_opts="-Djikes.class.path=\"$JIKESPATH\""
+fi
+
+# 2002-11-02, karltk@gentoo.org:
+# The Blackdown JDK on PPC hiccups with native threads
+#
+if [ "`arch`" == "ppc" ] ; then
+ export THREADS_FLAG="green"
+fi
+
+
+ant_exec_command="exec \"$JAVACMD\" $ANT_OPTS -classpath \"$LOCALCLASSPATH\" -Dant.home=\"$ANT_HOME\" -Dant.library.dir=\"$ANT_LIB\" $ant_sys_opts org.apache.tools.ant.launch.Launcher $ANT_ARGS -lib \"$CLASSPATH\" $ant_exec_args"
+
+if $ant_exec_debug ; then
+ echo $ant_exec_command
+fi
+eval $ant_exec_command
diff --git a/dev-java/ant-core/files/digest-ant-core-1.6.4 b/dev-java/ant-core/files/digest-ant-core-1.6.4
new file mode 100644
index 000000000000..3e14c7c6e4b5
--- /dev/null
+++ b/dev-java/ant-core/files/digest-ant-core-1.6.4
@@ -0,0 +1 @@
+MD5 64e99d5c0c51572e7323abf6c497b294 apache-ant-1.6.4-src.tar.bz2 6283215