summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-01-03 08:07:20 +0000
committerMark Wright <gienah@gentoo.org>2015-01-03 08:07:20 +0000
commite8bd704916296aaafc775b935a839bc2fac5be17 (patch)
tree9989aec3dae0f43fd070961c86934620196237f7 /dev-haskell
parentrevbump; conversion -> distutils-r1, rm old (diff)
downloadgentoo-2-e8bd704916296aaafc775b935a839bc2fac5be17.tar.gz
gentoo-2-e8bd704916296aaafc775b935a839bc2fac5be17.tar.bz2
gentoo-2-e8bd704916296aaafc775b935a839bc2fac5be17.zip
Bump glib to 0.13.0.7. Patch glib 0.13.0.6 and 0.13.0.7 for ghc 7.10, restore the KEYWORDS that ghc 7.8.4 has.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/glib/ChangeLog12
-rw-r--r--dev-haskell/glib/files/glib-0.13.0.7-ghc-7.10.patch11
-rw-r--r--dev-haskell/glib/glib-0.13.0.6.ebuild10
-rw-r--r--dev-haskell/glib/glib-0.13.0.7.ebuild37
4 files changed, 64 insertions, 6 deletions
diff --git a/dev-haskell/glib/ChangeLog b/dev-haskell/glib/ChangeLog
index eb65f1c363e9..5383e668031d 100644
--- a/dev-haskell/glib/ChangeLog
+++ b/dev-haskell/glib/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-haskell/glib
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glib/ChangeLog,v 1.27 2014/12/13 13:53:07 gienah Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glib/ChangeLog,v 1.28 2015/01/03 08:07:20 gienah Exp $
+
+*glib-0.13.0.7 (03 Jan 2015)
+
+ 03 Jan 2015; Mark Wright <gienah@gentoo.org>
+ +files/glib-0.13.0.7-ghc-7.10.patch, +glib-0.13.0.7.ebuild,
+ glib-0.13.0.6.ebuild:
+ Bump glib to 0.13.0.7. Patch glib 0.13.0.6 and 0.13.0.7 for ghc 7.10, restore
+ the KEYWORDS that ghc 7.8.4 has.
*glib-0.13.0.6 (13 Dec 2014)
diff --git a/dev-haskell/glib/files/glib-0.13.0.7-ghc-7.10.patch b/dev-haskell/glib/files/glib-0.13.0.7-ghc-7.10.patch
new file mode 100644
index 000000000000..75943a09ee0a
--- /dev/null
+++ b/dev-haskell/glib/files/glib-0.13.0.7-ghc-7.10.patch
@@ -0,0 +1,11 @@
+--- glib-0.13.0.7-orig/SetupWrapper.hs 2014-12-24 20:57:16.000000000 +1100
++++ glib-0.13.0.7/SetupWrapper.hs 2015-01-03 17:39:42.464000600 +1100
+@@ -18,7 +18,7 @@
+
+ import System.Environment
+ import System.Process
+-import System.Exit
++import System.Exit (exitWith, ExitCode(..))
+ import System.FilePath
+ import System.Directory
+ import qualified Control.Exception as Exception
diff --git a/dev-haskell/glib/glib-0.13.0.6.ebuild b/dev-haskell/glib/glib-0.13.0.6.ebuild
index 8abbf8fa8ee2..6ea958b43b7e 100644
--- a/dev-haskell/glib/glib-0.13.0.6.ebuild
+++ b/dev-haskell/glib/glib-0.13.0.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glib/glib-0.13.0.6.ebuild,v 1.1 2014/12/13 13:53:07 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glib/glib-0.13.0.6.ebuild,v 1.2 2015/01/03 08:07:20 gienah Exp $
EAPI=5
@@ -8,7 +8,7 @@ EAPI=5
#nocabaldep is for the fancy cabal-detection feature at build-time
CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
-inherit haskell-cabal
+inherit base haskell-cabal
DESCRIPTION="Binding to the GLIB library for Gtk2Hs"
HOMEPAGE="http://projects.haskell.org/gtk2hs/"
@@ -16,7 +16,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="+closure_signals"
RDEPEND=">=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
@@ -29,6 +29,8 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=("${FILESDIR}/${PN}-0.13.0.7-ghc-7.10.patch")
+
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag closure_signals closure_signals)
diff --git a/dev-haskell/glib/glib-0.13.0.7.ebuild b/dev-haskell/glib/glib-0.13.0.7.ebuild
new file mode 100644
index 000000000000..439e3128b703
--- /dev/null
+++ b/dev-haskell/glib/glib-0.13.0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glib/glib-0.13.0.7.ebuild,v 1.1 2015/01/03 08:07:20 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
+inherit base haskell-cabal
+
+DESCRIPTION="Binding to the GLIB library for Gtk2Hs"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+closure_signals"
+
+RDEPEND=">=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-0.4:=[profile?]
+ >=dev-lang/ghc-7.8.1:=
+ dev-libs/glib:2
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/gtk2hs-buildtools-0.13.0.3:0=
+ virtual/pkgconfig
+"
+
+PATCHES=("${FILESDIR}/${PN}-0.13.0.7-ghc-7.10.patch")
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag closure_signals closure_signals)
+}