summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-11-15 17:46:56 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-11-15 17:46:56 +0000
commitd928728fa92e9795b27e76383ade6dc4d397ecf2 (patch)
tree60bb5365651dbce131bcf7dcff3960ba597b2493 /dev-haskell
parentEnable git useflag by default (diff)
downloadgentoo-2-d928728fa92e9795b27e76383ade6dc4d397ecf2.tar.gz
gentoo-2-d928728fa92e9795b27e76383ade6dc4d397ecf2.tar.bz2
gentoo-2-d928728fa92e9795b27e76383ade6dc4d397ecf2.zip
Version bump (bug #491276 by Luis Ressel).
(Portage version: 2.2.7_p18/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hdbc-postgresql/ChangeLog10
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2.ebuild61
2 files changed, 69 insertions, 2 deletions
diff --git a/dev-haskell/hdbc-postgresql/ChangeLog b/dev-haskell/hdbc-postgresql/ChangeLog
index 39df7ef7600a..0e4d1b1a2c24 100644
--- a/dev-haskell/hdbc-postgresql/ChangeLog
+++ b/dev-haskell/hdbc-postgresql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/hdbc-postgresql
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/ChangeLog,v 1.21 2012/12/24 15:35:57 slyfox Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/ChangeLog,v 1.22 2013/11/15 17:46:56 slyfox Exp $
+
+*hdbc-postgresql-2.3.2.2 (15 Nov 2013)
+
+ 15 Nov 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +hdbc-postgresql-2.3.2.2.ebuild:
+ Version bump (bug #491276 by Luis Ressel).
24 Dec 2012; Sergei Trofimovich <slyfox@gentoo.org>
+files/HDBC-postgresql-2.3.2.1-ghc-7.6.patch, -hdbc-postgresql-2.2.3.3.ebuild,
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2.ebuild
new file mode 100644
index 000000000000..744c32022e5f
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.2.ebuild,v 1.1 2013/11/15 17:46:56 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC-postgresql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL driver for HDBC"
+HOMEPAGE="http://github.com/hdbc/hdbc-postgresql"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # requires configured postgresql
+
+RDEPEND=">=dev-db/postgresql-base-7
+ dev-haskell/convertible:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ >=dev-haskell/hdbc-2.2.0:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( >=dev-haskell/hdbc-2.2.6:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/quickcheck:=[profile?]
+ dev-haskell/testpack:=[profile?] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}