summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-07-02 19:09:02 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-07-02 19:09:02 +0000
commitcc13611462225691dd348d333d35b92583c664af (patch)
tree8fb219754357c26f76ab7de12cc1db412c49d35a /dev-haskell
parentStable on ppc. (diff)
downloadgentoo-2-cc13611462225691dd348d333d35b92583c664af.tar.gz
gentoo-2-cc13611462225691dd348d333d35b92583c664af.tar.bz2
gentoo-2-cc13611462225691dd348d333d35b92583c664af.zip
New 1.0 version of HDBC and backends.
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hdbc-odbc/ChangeLog7
-rw-r--r--dev-haskell/hdbc-odbc/files/digest-hdbc-odbc-1.0.0.03
-rw-r--r--dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild32
3 files changed, 41 insertions, 1 deletions
diff --git a/dev-haskell/hdbc-odbc/ChangeLog b/dev-haskell/hdbc-odbc/ChangeLog
index 6c009396d7aa..4182e04ab946 100644
--- a/dev-haskell/hdbc-odbc/ChangeLog
+++ b/dev-haskell/hdbc-odbc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hdbc-odbc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-odbc/ChangeLog,v 1.7 2006/03/30 16:05:50 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-odbc/ChangeLog,v 1.8 2006/07/02 19:09:02 dcoutts Exp $
+
+*hdbc-odbc-1.0.0.0 (02 Jul 2006)
+
+ 02 Jul 2006; Duncan Coutts <dcoutts@gentoo.org> +hdbc-odbc-1.0.0.0.ebuild:
+ New 1.0 version of HDBC and backends.
30 Mar 2006; Duncan Coutts <dcoutts@gentoo.org> hdbc-odbc-0.99.2.1.ebuild:
Patch build bug as recommened by upstream.
diff --git a/dev-haskell/hdbc-odbc/files/digest-hdbc-odbc-1.0.0.0 b/dev-haskell/hdbc-odbc/files/digest-hdbc-odbc-1.0.0.0
new file mode 100644
index 000000000000..b3b197b090f3
--- /dev/null
+++ b/dev-haskell/hdbc-odbc/files/digest-hdbc-odbc-1.0.0.0
@@ -0,0 +1,3 @@
+MD5 7db49cc29f8b106c92059ce15fd675ff hdbc-odbc_1.0.0.0.tar.gz 36486
+RMD160 8d727479f85ca7b432a26a179ee68ca76829e127 hdbc-odbc_1.0.0.0.tar.gz 36486
+SHA256 cadfb22db6a02e0cc07dd32c90b7280b4c2fae32f79258394cd985b6c5ef5f80 hdbc-odbc_1.0.0.0.tar.gz 36486
diff --git a/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild b/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild
new file mode 100644
index 000000000000..f6d5f337a7ca
--- /dev/null
+++ b/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild,v 1.1 2006/07/02 19:09:02 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit base haskell-cabal versionator
+
+DESCRIPTION="ODBC database driver for HDBC"
+HOMEPAGE="http://quux.org/devel/hdbc/"
+SRC_URI="http://quux.org/devel/hdbc/${PN}_${PV}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+hdbc_PV=$(get_version_component_range 1-3)
+
+DEPEND=">=virtual/ghc-6.4.1
+ ~dev-haskell/hdbc-${hdbc_PV}
+ >=dev-db/unixODBC-2.2"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ base_src_unpack
+
+ # temp patch for missing #include. It seems different versions of
+ # dev-db/unixODBC #include their headers in each other differently.
+ sed -i 's/#include <sqlext.h>/#include <sqlext.h>\n#include <sqlucode.h>/' \
+ "${S}/Database/HDBC/ODBC/TypeConv.hsc"
+}