summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-07-08 18:01:09 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-07-08 18:01:09 +0000
commitb207f4e97e2a8c00125f08eb5b44f04b0a1d5cee (patch)
treee42b186cbef18b1e6742775e2b2294208c31cb36 /dev-haskell
parentRe-add ~ia64/~x86 because welp fails (diff)
downloadgentoo-2-b207f4e97e2a8c00125f08eb5b44f04b0a1d5cee.tar.gz
gentoo-2-b207f4e97e2a8c00125f08eb5b44f04b0a1d5cee.tar.bz2
gentoo-2-b207f4e97e2a8c00125f08eb5b44f04b0a1d5cee.zip
New version.
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/happy/ChangeLog9
-rw-r--r--dev-haskell/happy/files/digest-happy-1.163
-rw-r--r--dev-haskell/happy/happy-1.16.ebuild41
3 files changed, 51 insertions, 2 deletions
diff --git a/dev-haskell/happy/ChangeLog b/dev-haskell/happy/ChangeLog
index a56a76d4eae9..3de84ba386a7 100644
--- a/dev-haskell/happy/ChangeLog
+++ b/dev-haskell/happy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/happy
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.24 2006/10/12 18:51:42 dcoutts Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.25 2007/07/08 18:01:09 dcoutts Exp $
+
+*happy-1.16 (08 Jul 2007)
+
+ 08 Jul 2007; Duncan Coutts <dcoutts@gentoo.org> +happy-1.16.ebuild:
+ New version.
12 Oct 2006; Duncan Coutts <dcoutts@gentoo.org>
-files/happy-1.14-gcc3.4.patch, -happy-1.14.ebuild:
diff --git a/dev-haskell/happy/files/digest-happy-1.16 b/dev-haskell/happy/files/digest-happy-1.16
new file mode 100644
index 000000000000..15e51b7bffcd
--- /dev/null
+++ b/dev-haskell/happy/files/digest-happy-1.16
@@ -0,0 +1,3 @@
+MD5 b9fd2f5eba61974dab8e12873cadee6f happy-1.16.tar.gz 226566
+RMD160 ebe54b1c3ee7623de96e56bc69299dd236323781 happy-1.16.tar.gz 226566
+SHA256 4da47f4904dbdddfb58140edb0395383feba72dfc77759e57587a526dd9496c5 happy-1.16.tar.gz 226566
diff --git a/dev-haskell/happy/happy-1.16.ebuild b/dev-haskell/happy/happy-1.16.ebuild
new file mode 100644
index 000000000000..a5065aac20c1
--- /dev/null
+++ b/dev-haskell/happy/happy-1.16.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.16.ebuild,v 1.1 2007/07/08 18:01:09 dcoutts Exp $
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal autotools
+
+DESCRIPTION="A yacc-like parser generator for Haskell"
+HOMEPAGE="http://haskell.org/happy/"
+SRC_URI="http://haskell.org/happy/dist/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=virtual/ghc-6.4
+ >=dev-haskell/cabal-1.1.6.1
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/doc && eautoconf
+}
+
+src_compile() {
+ cabal_src_compile
+ if use doc; then
+ cd doc
+ econf || die "econf failed in /doc"
+ emake -j1 || die "emake failed in /doc"
+ fi
+}
+
+src_install() {
+ cabal_src_install
+ use doc && cd doc && dohtml -r happy/*
+}
+