summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-03-01 20:08:17 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-03-01 20:08:17 +0000
commit7ffe0ef58732c8489f757697539fb897c5f2c2ef (patch)
tree6212ae0ead9e5cdd7ced804800e3c876f6fa7a76 /dev-haskell
parentRemoved old (diff)
downloadgentoo-2-7ffe0ef58732c8489f757697539fb897c5f2c2ef.tar.gz
gentoo-2-7ffe0ef58732c8489f757697539fb897c5f2c2ef.tar.bz2
gentoo-2-7ffe0ef58732c8489f757697539fb897c5f2c2ef.zip
Removed old
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/wxhaskell/ChangeLog8
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild101
2 files changed, 6 insertions, 103 deletions
diff --git a/dev-haskell/wxhaskell/ChangeLog b/dev-haskell/wxhaskell/ChangeLog
index cb6af8ef6abe..792fb4407af9 100644
--- a/dev-haskell/wxhaskell/ChangeLog
+++ b/dev-haskell/wxhaskell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/wxhaskell
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/ChangeLog,v 1.31 2010/09/07 17:35:04 kolmodin Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/ChangeLog,v 1.32 2011/03/01 20:08:16 slyfox Exp $
+
+ 01 Mar 2011; Sergei Trofimovich <slyfox@gentoo.org>
+ -wxhaskell-0.9.4.ebuild:
+ Removed old
07 Sep 2010; Lennart Kolmodin <kolmodin@gentoo.org>
wxhaskell-0.12.1.6.ebuild:
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild
deleted file mode 100644
index a7f169d89122..000000000000
--- a/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild,v 1.13 2007/12/13 00:52:24 dcoutts Exp $
-
-inherit flag-o-matic wxwidgets ghc-package multilib
-
-DESCRIPTION="a portable and native GUI library for Haskell"
-HOMEPAGE="http://wxhaskell.sourceforge.net/"
-SRC_URI="mirror://sourceforge/wxhaskell/${PN}-src-${PV}.zip"
-
-LICENSE="wxWinLL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="doc"
-
-RDEPEND="<dev-lang/ghc-6.6
- =x11-libs/wxGTK-2.6*"
-
-DEPEND="${RDEPEND}
- app-arch/unzip
- doc? ( >=dev-haskell/haddock-0.6-r2 )"
-
-pkg_setup() {
- if ! built_with_use =x11-libs/wxGTK-2.6* X; then
- eerror "wxhaskell needs wxGTK that has been built with X11 support."
- eerror "Please re-emerge wxGTK with USE=\"X -odbc -unicode\""
- die "wxhaskell requires wxGTK to be built with USE=\"X -odbc -unicode\""
- fi
- if built_with_use =x11-libs/wxGTK-2.6* odbc; then
- eerror "Sadly wxhaskell does not work with wxGTK that has been built"
- eerror "with USE=\"odbc\"."
- eerror "Please re-emerge wxGTK with USE=\"-odbc\""
- die "wxhaskell requires wxGTK to be built with USE=\"-odbc\""
- fi
-}
-
-src_unpack() {
- unpack ${A}
- # adapt to Gentoo path convention
- sed -i 's:/doc/html:/share/doc/html:' "${S}/configure"
- # fix superfluous dependencies on hslibs packages
- sed -i -e 's:,lang::' -e 's:,"lang"::' \
- -e 's:,concurrent::' -e 's:,"concurrent"::' "${S}/configure"
- # fix Makefile to respect CXXFLAGS
- sed -i 's:^\(WXC-CXXFLAGS.*=\):\1\$(CXXFLAGS) :' "${S}/makefile"
-}
-
-src_compile() {
- ghc-setup-pkg
-
- #wxhaskell supports gtk or gtk2, but not unicode yet. However since the gtk2
- #USE flag is deprecated we now only build with gtk2:
- WX_GTK_VER=2.6
- need-wxwidgets gtk2
-
- # every C compiler result ends up in a shared lib
- append-flags -fPIC
-
- # non-standard configure, so econf is not an option
- # --wx-config must appear first according to configure file comments
- ./configure \
- --wx-config="${WX_CONFIG}" \
- --prefix=/usr \
- --with-opengl \
- --libdir=/usr/$(get_libdir)/${P} \
- --package-conf="${S}/$(ghc-localpkgconf)" \
- || die "./configure failed"
-
- emake -j1 || die "make failed"
-
- # create documentation
- if use doc; then
- emake -j1 doc || die "make doc failed"
- fi
-}
-
-src_install() {
- local f
-
- # don't register the packages, just install the files
- emake -j1 install-files DESTDIR="${D}" || die "make install failed"
-
- # the .so needs to be on the lib path
- mkdir -p "${D}/usr/$(get_libdir)"
- for f in "${D}/usr/$(get_libdir)/${P}/"libwxc-*.so; do
- mv ${f} "${D}/usr/$(get_libdir)/"
- done
-
- if use doc; then
- dohtml -A haddock -r out/doc/*
- cp -r samples "${D}/usr/share/doc/${PF}"
- fi
-
- # substitute for the ${wxhlibdir} in package files and register them
- # for ghc-6.2 change the package to be exposed by default.
- sed -i -e "s:\${wxhlibdir}:${D}/usr/$(get_libdir)/${P}:" \
- -e "s:auto = False:auto = True:" \
- "${D}/usr/$(get_libdir)/${P}/"*.pkg
- ghc-setup-pkg "${D}/usr/$(get_libdir)/${P}/"*.pkg
- ghc-install-pkg
-}