summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-11-25 06:09:58 +0000
committerMark Wright <gienah@gentoo.org>2012-11-25 06:09:58 +0000
commit72f2030099bd956ce0f657dd9ae96839aa4ec058 (patch)
treede913c69929705d34042a95d2b7710b83ab57e8d /dev-haskell
parentBump terminfo to 0.3.2.5 (diff)
downloadgentoo-2-72f2030099bd956ce0f657dd9ae96839aa4ec058.tar.gz
gentoo-2-72f2030099bd956ce0f657dd9ae96839aa4ec058.tar.bz2
gentoo-2-72f2030099bd956ce0f657dd9ae96839aa4ec058.zip
Bump texmath to 0.6.1.1
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/texmath/ChangeLog7
-rw-r--r--dev-haskell/texmath/texmath-0.6.1.1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-haskell/texmath/ChangeLog b/dev-haskell/texmath/ChangeLog
index f764843fd385..c664d6ce3d49 100644
--- a/dev-haskell/texmath/ChangeLog
+++ b/dev-haskell/texmath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/texmath
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/ChangeLog,v 1.5 2012/09/12 15:39:15 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/ChangeLog,v 1.6 2012/11/25 06:09:58 gienah Exp $
+
+*texmath-0.6.1.1 (25 Nov 2012)
+
+ 25 Nov 2012; Mark Wright <gienah@gentoo.org> +texmath-0.6.1.1.ebuild:
+ Bump texmath to 0.6.1.1
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org> texmath-0.5.0.1.ebuild,
texmath-0.6.0.3.ebuild, texmath-0.6.0.4.ebuild, texmath-0.6.0.6.ebuild:
diff --git a/dev-haskell/texmath/texmath-0.6.1.1.ebuild b/dev-haskell/texmath/texmath-0.6.1.1.ebuild
new file mode 100644
index 000000000000..361bccd0893a
--- /dev/null
+++ b/dev-haskell/texmath/texmath-0.6.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.1.1.ebuild,v 1.1 2012/11/25 06:09:58 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion of LaTeX math formulas to MathML or OMML."
+HOMEPAGE="http://github.com/jgm/texmath"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="cgi test"
+
+RDEPEND=">=dev-haskell/parsec-3:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/xml:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ cgi? ( dev-haskell/json:=[profile?]
+ dev-haskell/cgi:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag cgi) \
+ $(cabal_flag test)
+}
+
+src_install() {
+ cabal_src_install
+
+ # remove test and it's data
+ rm -f "${ED}/usr/bin/texmath" 2> /dev/null
+ rm -rf "${ED}/usr/share/${P}"/ghc-*/tests 2> /dev/null
+}