summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-12-16 20:27:54 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-12-16 20:27:54 +0000
commit7104eef3191cb8c18cd253ec7215461657d0c043 (patch)
tree5a8a78b5485a92b5184cb6da9eddb6ca64868a5b /dev-haskell
parentStable for HPPA (bug #296432). (diff)
downloadgentoo-2-7104eef3191cb8c18cd253ec7215461657d0c043.tar.gz
gentoo-2-7104eef3191cb8c18cd253ec7215461657d0c043.tar.bz2
gentoo-2-7104eef3191cb8c18cd253ec7215461657d0c043.zip
Version bump dev-haskell/cabal-install.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/cabal-install/ChangeLog7
-rw-r--r--dev-haskell/cabal-install/cabal-install-0.6.4.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-haskell/cabal-install/ChangeLog b/dev-haskell/cabal-install/ChangeLog
index 06a1663e8def..d2722d37d767 100644
--- a/dev-haskell/cabal-install/ChangeLog
+++ b/dev-haskell/cabal-install/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/cabal-install
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal-install/ChangeLog,v 1.1 2009/04/19 13:57:42 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal-install/ChangeLog,v 1.2 2009/12/16 20:27:54 kolmodin Exp $
+
+*cabal-install-0.6.4 (16 Dec 2009)
+
+ 16 Dec 2009; <kolmodin@gentoo.org> +cabal-install-0.6.4.ebuild:
+ Version bump.
19 Apr 2009; Lennart Kolmodin <kolmodin@gentoo.org> ChangeLog:
Initial version.
diff --git a/dev-haskell/cabal-install/cabal-install-0.6.4.ebuild b/dev-haskell/cabal-install/cabal-install-0.6.4.ebuild
new file mode 100644
index 000000000000..21ff21dabd3d
--- /dev/null
+++ b/dev-haskell/cabal-install/cabal-install-0.6.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal-install/cabal-install-0.6.4.ebuild,v 1.1 2009/12/16 20:27:54 kolmodin Exp $
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal bash-completion
+
+DESCRIPTION="The command-line interface for Cabal and Hackage."
+HOMEPAGE="http://www.haskell.org/cabal/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# supports ghc 6.6-6.10
+RDEPEND="<dev-lang/ghc-6.11
+ =dev-haskell/cabal-1.6*"
+DEPEND="${RDEPEND}
+ >=dev-haskell/filepath-1.0
+ >=dev-haskell/http-4000.0.2
+ dev-haskell/network
+ >=dev-haskell/zlib-0.4"
+
+src_install() {
+ haskell-cabal_src_install
+
+ dobashcompletion "${S}/bash-completion/cabal"
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+
+ bash-completion_pkg_postinst
+}