summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-11-25 05:43:19 +0000
committerMark Wright <gienah@gentoo.org>2012-11-25 05:43:19 +0000
commit67a4fd029e37c72dcf984da5b9f272b4da521431 (patch)
tree18bc93924c75e4aaf4894dff5adf8ea353da01c9 /dev-haskell
parentPatch gtk2hs-buildtools-0.12.3.1 for ghc 7.6.1 (diff)
downloadgentoo-2-67a4fd029e37c72dcf984da5b9f272b4da521431.tar.gz
gentoo-2-67a4fd029e37c72dcf984da5b9f272b4da521431.tar.bz2
gentoo-2-67a4fd029e37c72dcf984da5b9f272b4da521431.zip
Patch glib-0.12.3.1 for ghc 7.6.1
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/glib/ChangeLog6
-rw-r--r--dev-haskell/glib/files/glib-0.12.3.1-ghc-7.6.patch31
-rw-r--r--dev-haskell/glib/glib-0.12.3.1.ebuild12
3 files changed, 46 insertions, 3 deletions
diff --git a/dev-haskell/glib/ChangeLog b/dev-haskell/glib/ChangeLog
index 86ec7ffbafc2..083bc5f70f50 100644
--- a/dev-haskell/glib/ChangeLog
+++ b/dev-haskell/glib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/glib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glib/ChangeLog,v 1.8 2012/09/23 08:42:04 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glib/ChangeLog,v 1.9 2012/11/25 05:43:19 gienah Exp $
+
+ 25 Nov 2012; Mark Wright <gienah@gentoo.org>
+ +files/glib-0.12.3.1-ghc-7.6.patch, glib-0.12.3.1.ebuild:
+ Patch glib-0.12.3.1 for ghc 7.6.1
23 Sep 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> glib-0.12.3.1.ebuild:
x86 stable wrt bug #428930
diff --git a/dev-haskell/glib/files/glib-0.12.3.1-ghc-7.6.patch b/dev-haskell/glib/files/glib-0.12.3.1-ghc-7.6.patch
new file mode 100644
index 000000000000..3c9ab53ab3aa
--- /dev/null
+++ b/dev-haskell/glib/files/glib-0.12.3.1-ghc-7.6.patch
@@ -0,0 +1,31 @@
+--- glib-0.12.3.1-orig/System/Glib/GObject.chs 2012-05-28 08:18:53.000000000 +1000
++++ glib-0.12.3.1/System/Glib/GObject.chs 2012-10-11 09:48:16.313701201 +1100
+@@ -127,8 +127,6 @@
+
+ {#pointer GDestroyNotify as DestroyNotify#}
+
+-foreign import ccall "wrapper" mkDestroyNotifyPtr :: IO () -> IO DestroyNotify
+-
+ -- | This function wraps any newly created objects that derives from
+ -- GInitiallyUnowned also known as objects with
+ -- \"floating-references\". The object will be refSink (for glib
+--- glib-0.12.3.1-orig/System/Glib/MainLoop.chs 2012-05-28 08:18:53.000000000 +1000
++++ glib-0.12.3.1/System/Glib/MainLoop.chs 2012-10-11 09:48:04.779383615 +1100
+@@ -71,7 +71,7 @@
+
+ {#pointer SourceFunc#}
+
+-foreign import ccall "wrapper" mkSourceFunc :: IO {#type gint#} -> IO SourceFunc
++foreign import ccall "wrapper" mkSourceFunc :: (Ptr () -> IO {#type gint#}) -> IO SourceFunc
+
+ type HandlerId = {#type guint#}
+
+@@ -79,7 +79,7 @@
+ --
+ makeCallback :: IO {#type gint#} -> IO (SourceFunc, DestroyNotify)
+ makeCallback fun = do
+- funPtr <- mkSourceFunc fun
++ funPtr <- mkSourceFunc (const fun)
+ return (funPtr, destroyFunPtr)
+
+ -- | Sets a function to be called at regular intervals, with the default
diff --git a/dev-haskell/glib/glib-0.12.3.1.ebuild b/dev-haskell/glib/glib-0.12.3.1.ebuild
index 818759e1dca6..35cef84c9c88 100644
--- a/dev-haskell/glib/glib-0.12.3.1.ebuild
+++ b/dev-haskell/glib/glib-0.12.3.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glib/glib-0.12.3.1.ebuild,v 1.4 2012/09/23 08:42:04 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glib/glib-0.12.3.1.ebuild,v 1.5 2012/11/25 05:43:19 gienah Exp $
EAPI=4
#nocabaldep is for the fancy cabal-detection feature at build-time
CABAL_FEATURES="lib profile haddock hscolour hoogle nocabaldep"
-inherit base haskell-cabal
+inherit haskell-cabal
DESCRIPTION="Binding to the GLIB library for Gtk2Hs."
HOMEPAGE="http://projects.haskell.org/gtk2hs/"
@@ -21,3 +21,11 @@ RDEPEND=">=dev-lang/ghc-6.10.1
dev-libs/glib:2"
DEPEND="${RDEPEND}
dev-haskell/gtk2hs-buildtools"
+
+src_prepare() {
+ # c2hs ignores #if __GLASGOW_HASKELL__ >= 706
+ # I do not know which earlier ghc versions the patch submitted upstream works with
+ if has_version ">=dev-lang/ghc-7.6.1"; then
+ epatch "${FILESDIR}/${PN}-0.12.3.1-ghc-7.6.patch"
+ fi
+}