summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-05-10 21:49:10 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-05-10 21:49:10 +0000
commit4bd71146ff89dcb0433c88768430c957bdb7f172 (patch)
treec6f032b04bd91a0878e2f93b75d0640cf0b1a336 /dev-haskell
parentNew version for GNOME 2.26. Clean up old revisions. (diff)
downloadgentoo-2-4bd71146ff89dcb0433c88768430c957bdb7f172.tar.gz
gentoo-2-4bd71146ff89dcb0433c88768430c957bdb7f172.tar.bz2
gentoo-2-4bd71146ff89dcb0433c88768430c957bdb7f172.zip
Version bump dev-haskell/http
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/http/ChangeLog7
-rw-r--r--dev-haskell/http/http-4000.0.6.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-haskell/http/ChangeLog b/dev-haskell/http/ChangeLog
index c53d42ac6430..342d773d2aae 100644
--- a/dev-haskell/http/ChangeLog
+++ b/dev-haskell/http/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/http
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.10 2009/04/19 11:11:40 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.11 2009/05/10 21:49:10 kolmodin Exp $
+
+*http-4000.0.6 (10 May 2009)
+
+ 10 May 2009; Lennart Kolmodin <kolmodin@gentoo.org> +http-4000.0.6.ebuild:
+ Version bump.
*http-4000.0.5 (19 Apr 2009)
diff --git a/dev-haskell/http/http-4000.0.6.ebuild b/dev-haskell/http/http-4000.0.6.ebuild
new file mode 100644
index 000000000000..cb61bd743434
--- /dev/null
+++ b/dev-haskell/http/http-4000.0.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-4000.0.6.ebuild,v 1.1 2009/05/10 21:49:10 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+MY_PN="HTTP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library for client-side HTTP"
+HOMEPAGE="http://projects.haskell.org/http/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.6.1
+ dev-haskell/mtl
+ dev-haskell/network
+ dev-haskell/parsec"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"