summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-02-09 19:21:10 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-02-09 19:21:10 +0000
commit39ab107753584f5ef92d3892ff21daf1bc6abc72 (patch)
tree2789f3e6596d7f8b9256cb36d0d23780d8d3f2ae /dev-haskell
parentold (diff)
downloadgentoo-2-39ab107753584f5ef92d3892ff21daf1bc6abc72.tar.gz
gentoo-2-39ab107753584f5ef92d3892ff21daf1bc6abc72.tar.bz2
gentoo-2-39ab107753584f5ef92d3892ff21daf1bc6abc72.zip
Version bump.
(Portage version: 2.2.0_alpha153_p6/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/highlighting-kate/ChangeLog8
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.5.3.5.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-haskell/highlighting-kate/ChangeLog b/dev-haskell/highlighting-kate/ChangeLog
index 7ca8e7ffb4f7..ebe12c306170 100644
--- a/dev-haskell/highlighting-kate/ChangeLog
+++ b/dev-haskell/highlighting-kate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/highlighting-kate
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.7 2013/01/05 04:43:47 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.8 2013/02/09 19:21:10 slyfox Exp $
+
+*highlighting-kate-0.5.3.5 (09 Feb 2013)
+
+ 09 Feb 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +highlighting-kate-0.5.3.5.ebuild:
+ Version bump.
*highlighting-kate-0.5.3.4 (05 Jan 2013)
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.5.3.5.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.5.3.5.ebuild
new file mode 100644
index 000000000000..6d5218b889f7
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.5.3.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/highlighting-kate-0.5.3.5.ebuild,v 1.1 2013/02/09 19:21:10 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting"
+HOMEPAGE="http://github.com/jgm/highlighting-kate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable pcre-light"
+
+RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?]
+ <dev-haskell/blaze-html-0.6:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/regex-pcre-builtin:=[profile?]
+ pcre-light? ( dev-haskell/pcre-light:=[profile?] )
+ !pcre-light? ( dev-haskell/regex-pcre-builtin:=[profile?] )
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10"
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag executable) \
+ $(cabal_flag pcre-light)
+}