summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2010-07-12 14:23:38 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2010-07-12 14:23:38 +0000
commit2663502cb7f43f7e06c57fe6e897585da042be68 (patch)
tree9054e9c22b5732a9f094a6fbdf4d5d15c08ceb02 /dev-haskell
parentFix "assignment discards qualifiers from pointer target type" warning caused ... (diff)
downloadgentoo-2-2663502cb7f43f7e06c57fe6e897585da042be68.tar.gz
gentoo-2-2663502cb7f43f7e06c57fe6e897585da042be68.tar.bz2
gentoo-2-2663502cb7f43f7e06c57fe6e897585da042be68.zip
Fixed bug #227519 (missing dev-haskell/parsec dep). Fixed parsec constraints, fixed QA warnings.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/wash/ChangeLog10
-rw-r--r--dev-haskell/wash/files/wash-2.12-ghc-io.patch13
-rw-r--r--dev-haskell/wash/wash-2.12.ebuild19
3 files changed, 36 insertions, 6 deletions
diff --git a/dev-haskell/wash/ChangeLog b/dev-haskell/wash/ChangeLog
index ebd8adc55874..895f55e3d18d 100644
--- a/dev-haskell/wash/ChangeLog
+++ b/dev-haskell/wash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/wash
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/ChangeLog,v 1.14 2008/01/26 20:17:16 dcoutts Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/ChangeLog,v 1.15 2010/07/12 14:23:37 slyfox Exp $
+
+ 12 Jul 2010; Sergei Trofimovich <slyfox@gentoo.org> wash-2.12.ebuild,
+ +files/wash-2.12-ghc-io.patch:
+ Fixed bug #227519 (missing dev-haskell/parsec dep). Thanks to Evil Compile
+ Person <bugs@dev.gentooexperimental.org> for the report and thanks to
+ Sebastian Magrí <sebasmagri@gmail.com> for the fix.
26 Jan 2008; Duncan Coutts <dcoutts@gentoo.org>
-files/wash-2.5.6-ghc66.patch, -wash-2.0.6.ebuild, -wash-2.3.1.ebuild,
diff --git a/dev-haskell/wash/files/wash-2.12-ghc-io.patch b/dev-haskell/wash/files/wash-2.12-ghc-io.patch
new file mode 100644
index 000000000000..fd8227e256f9
--- /dev/null
+++ b/dev-haskell/wash/files/wash-2.12-ghc-io.patch
@@ -0,0 +1,13 @@
+diff --git a/WASH/Utility/BulkIO.hs b/WASH/Utility/BulkIO.hs
+index 2828bf4..fe8543f 100644
+--- a/WASH/Utility/BulkIO.hs
++++ b/WASH/Utility/BulkIO.hs
+@@ -6,7 +6,7 @@ import Ptr
+ import CString
+ import CTypes
+ import Foreign.Marshal.Alloc (mallocBytes, free)
+-import GHC.IO (hGetBuf, hPutBuf)
++import System.IO (hGetBuf, hPutBuf)
+
+ rawGetBytes :: Handle -> Int -> IO String
+ rawGetBytes h n =
diff --git a/dev-haskell/wash/wash-2.12.ebuild b/dev-haskell/wash/wash-2.12.ebuild
index aad1072cce05..edc58454be02 100644
--- a/dev-haskell/wash/wash-2.12.ebuild
+++ b/dev-haskell/wash/wash-2.12.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/wash-2.12.ebuild,v 1.1 2007/12/13 17:33:09 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/wash-2.12.ebuild,v 1.2 2010/07/12 14:23:37 slyfox Exp $
+
+EAPI=1
CABAL_FEATURES="profile haddock lib bin"
-inherit haskell-cabal check-reqs
+inherit check-reqs eutils haskell-cabal
MY_PN="WashNGo"
MY_P="${MY_PN}-${PV}"
@@ -18,6 +20,7 @@ KEYWORDS="~amd64 ~x86 ~sparc"
IUSE=""
DEPEND=">=dev-lang/ghc-6.6
+ dev-haskell/parsec:0
dev-haskell/regex-compat"
S="${WORKDIR}/${MY_P}"
@@ -37,7 +40,7 @@ pkg_setup() {
}
src_unpack() {
- unpack "${A}"
+ unpack ${A}
cabal-mksetup
sed -i -e "/Extensions/aGhc-Options: -O +RTS -M${CHECKREQS_MEMORY}m -RTS" \
@@ -51,6 +54,14 @@ src_unpack() {
,containers' \
"${S}/WASH.cabal"
fi
+
+ # dislikes parsec-3
+ sed -i -e 's/parsec/parsec < 3/' \
+ "${S}/WASH.cabal"
+
+ cd "${S}"
+ epatch "${FILESDIR}/wash-2.12-ghc-io.patch"
+
}
src_install() {