summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-06-02 06:34:53 +0000
committerMark Wright <gienah@gentoo.org>2012-06-02 06:34:53 +0000
commit1cfbccafec0b420fe3eb8a1b755f15912eee0442 (patch)
tree96fe1db8e9e160fefce3b4331bd627f4e1d18b8a /dev-haskell
parentAdd ~x86-fbsd. (diff)
downloadgentoo-2-1cfbccafec0b420fe3eb8a1b755f15912eee0442.tar.gz
gentoo-2-1cfbccafec0b420fe3eb8a1b755f15912eee0442.tar.bz2
gentoo-2-1cfbccafec0b420fe3eb8a1b755f15912eee0442.zip
Bump crypto to 4.2.5
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/crypto/ChangeLog7
-rw-r--r--dev-haskell/crypto/crypto-4.2.5.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-haskell/crypto/ChangeLog b/dev-haskell/crypto/ChangeLog
index 0f63d1d10a80..65d06bb40951 100644
--- a/dev-haskell/crypto/ChangeLog
+++ b/dev-haskell/crypto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/crypto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto/ChangeLog,v 1.3 2012/04/17 19:42:55 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto/ChangeLog,v 1.4 2012/06/02 06:34:53 gienah Exp $
+
+*crypto-4.2.5 (02 Jun 2012)
+
+ 02 Jun 2012; Mark Wright <gienah@gentoo.org> +crypto-4.2.5.ebuild:
+ Bump crypto to 4.2.5
17 Apr 2012; Sergei Trofimovich <slyfox@gentoo.org>
+files/crypto-4.2.4-ghc-7.4.patch, crypto-4.2.4.ebuild:
diff --git a/dev-haskell/crypto/crypto-4.2.5.ebuild b/dev-haskell/crypto/crypto-4.2.5.ebuild
new file mode 100644
index 000000000000..3eac39b79a1a
--- /dev/null
+++ b/dev-haskell/crypto/crypto-4.2.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto/crypto-4.2.5.ebuild,v 1.1 2012/06/02 06:34:53 gienah Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Crypto"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Collects together existing Haskell cryptographic functions into a package"
+HOMEPAGE="http://hackage.haskell.org/package/Crypto"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/hunit[profile?]
+ >=dev-haskell/quickcheck-2.4.0.1[profile?]
+ dev-haskell/random[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ TESTS="SymmetricTest SHA1Test RSATest QuickTest HMACTest WordListTest"
+
+ for t in $TESTS; do
+ einfo "Running test $t..."
+ # the quickcheck tests doesn't fail when the test fails...
+ "${S}/dist/build/$t/$t" || die "Test $t failed"
+ done
+}
+
+src_install() {
+ cabal_src_install
+
+ rm -rf "${D}/usr/bin" 2>/dev/null
+}