summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-01-12 16:55:23 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-01-12 16:55:23 +0000
commit137963dcb616d71b4c781e91b5eedf5482be6a4c (patch)
treef84e298da211dc34cbb2f1b5549adcb38532e42d /dev-haskell
parentold (diff)
downloadgentoo-2-137963dcb616d71b4c781e91b5eedf5482be6a4c.tar.gz
gentoo-2-137963dcb616d71b4c781e91b5eedf5482be6a4c.tar.bz2
gentoo-2-137963dcb616d71b4c781e91b5eedf5482be6a4c.zip
Initial import. Haskell library. An efficient implementation of Int-indexed arrays (both mutable and immutable) with powerful loop optimization framework. Depend for dev-util/bustle-0.3.1.
(Portage version: 2.2.0_alpha84_p18/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/vector/ChangeLog12
-rw-r--r--dev-haskell/vector/Manifest3
-rw-r--r--dev-haskell/vector/metadata.xml69
-rw-r--r--dev-haskell/vector/vector-0.9.1.ebuild24
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-haskell/vector/ChangeLog b/dev-haskell/vector/ChangeLog
new file mode 100644
index 000000000000..7ad781ae297d
--- /dev/null
+++ b/dev-haskell/vector/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-haskell/vector
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/vector/ChangeLog,v 1.1 2012/01/12 16:55:23 slyfox Exp $
+
+*vector-0.9.1 (12 Jan 2012)
+
+ 12 Jan 2012; Sergei Trofimovich <slyfox@gentoo.org> +metadata.xml,
+ +vector-0.9.1.ebuild:
+ Initial import. Haskell library. An efficient implementation of Int-indexed
+ arrays (both mutable and immutable) with powerful loop optimization framework.
+ Depend for dev-util/bustle-0.3.1.
+
diff --git a/dev-haskell/vector/Manifest b/dev-haskell/vector/Manifest
new file mode 100644
index 000000000000..94a132987690
--- /dev/null
+++ b/dev-haskell/vector/Manifest
@@ -0,0 +1,3 @@
+DIST vector-0.9.1.tar.gz 104997 RMD160 0d85065d116ba4e7557634ef2fedcb4c92feeefd SHA1 b6764277b1a80f34e47b3bcb21112623fd3bb606 SHA256 5a2507f633c8b61a203b34ca29a30fca20fde1d6261f1f8417903b447c4bd7d4
+EBUILD vector-0.9.1.ebuild 564 RMD160 ea6ec22bf9f2307f53c597a529b5aeffc5f28fbe SHA1 618e2dc0b676bd0863f27bf24f3bc5276c211386 SHA256 869bcd88d2ccdbd43d418fca425b7169ade34127e1b8bd061f7a49a7b2c4781e
+MISC metadata.xml 2201 RMD160 728d43c7eb813c5608e338b5c7d97b063d9da378 SHA1 4cd0abef5655e9a217888f1167e6710df40f366f SHA256 38ae0c13011144d4cd2c8d66be29c027d775be0fbc1a2a57f9a20f8092495eb8
diff --git a/dev-haskell/vector/metadata.xml b/dev-haskell/vector/metadata.xml
new file mode 100644
index 000000000000..3c930fcd7c88
--- /dev/null
+++ b/dev-haskell/vector/metadata.xml
@@ -0,0 +1,69 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+
+ An efficient implementation of Int-indexed arrays (both mutable
+ and immutable), with a powerful loop optimisation framework .
+
+ It is structured as follows:
+
+ [&quot;Data.Vector&quot;] Boxed vectors of arbitrary types.
+
+ [&quot;Data.Vector.Unboxed&quot;] Unboxed vectors with an adaptive
+ representation based on data type families.
+
+ [&quot;Data.Vector.Storable&quot;] Unboxed vectors of &#39;Storable&#39; types.
+
+ [&quot;Data.Vector.Primitive&quot;] Unboxed vectors of primitive types as
+ defined by the @primitive@ package. &quot;Data.Vector.Unboxed&quot; is more
+ flexible at no performance cost.
+
+ [&quot;Data.Vector.Generic&quot;] Generic interface to the vector types.
+
+ Each module has a @Safe@ version with is marked as @Trustworthy@
+ (see &lt;http://hackage.haskell.org/trac/ghc/wiki/SafeHaskell&gt;).
+
+ There is also a (draft) tutorial on common uses of vector.
+
+ * &lt;http://haskell.org/haskellwiki/Numeric_Haskell:_A_Vector_Tutorial&gt;
+
+ Please use the project trac to submit bug reports and feature
+ requests.
+
+ * &lt;http://trac.haskell.org/vector&gt;
+
+ Changes in version 0.9
+
+ * &#39;MonadPlus&#39; instance for boxed vectors
+
+ * Export more @construct@ and @constructN@ from @Safe@ modules
+
+ * Require @primitive-0.4.0.1@
+
+ Changes in version 0.8
+
+ * New functions: @constructN@, @constructrN@
+
+ * Support for GHC 7.2 array copying primitives
+
+ * New fixity for @(!)@
+
+ * Safe Haskell support (contributed by David Terei)
+
+ * &#39;Functor&#39;, &#39;Monad&#39;, &#39;Applicative&#39;, &#39;Alternative&#39;, &#39;Foldable&#39; and
+ &#39;Traversable&#39; instances for boxed vectors
+ (/WARNING: they tend to be slow and are only provided for completeness/)
+
+ * &#39;Show&#39; instances for immutable vectors follow containers conventions
+
+ * &#39;Read&#39; instances for all immutable vector types
+
+ * Performance improvements
+
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/vector/vector-0.9.1.ebuild b/dev-haskell/vector/vector-0.9.1.ebuild
new file mode 100644
index 000000000000..7a0f111f3295
--- /dev/null
+++ b/dev-haskell/vector/vector-0.9.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/vector/vector-0.9.1.ebuild,v 1.1 2012/01/12 16:55:23 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient Arrays"
+HOMEPAGE="http://code.haskell.org/vector"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=dev-haskell/primitive-0.4*
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3"