summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-25 14:25:09 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-25 14:25:09 +0000
commit0f58f0718b9b41a5be65deb94ba287ca6d037cbf (patch)
tree3a90bba38c542962ce2115feffacd4ae927f9fe4 /dev-haskell
parentMarking Module-Runtime-0.13.0 ~ppc64 for bug 403413 (diff)
downloadgentoo-2-0f58f0718b9b41a5be65deb94ba287ca6d037cbf.tar.gz
gentoo-2-0f58f0718b9b41a5be65deb94ba287ca6d037cbf.tar.bz2
gentoo-2-0f58f0718b9b41a5be65deb94ba287ca6d037cbf.zip
Get rid of dev-haskell/happy and dev-haskell/alex depends (reported by judu).
(Portage version: 2.2.0_alpha91/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/haddock/ChangeLog6
-rw-r--r--dev-haskell/haddock/files/haddock-2.10.0-drop-tools.patch26
-rw-r--r--dev-haskell/haddock/haddock-2.10.0.ebuild18
3 files changed, 44 insertions, 6 deletions
diff --git a/dev-haskell/haddock/ChangeLog b/dev-haskell/haddock/ChangeLog
index a34d0b6db92c..0e3731dbfc42 100644
--- a/dev-haskell/haddock/ChangeLog
+++ b/dev-haskell/haddock/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/haddock
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.89 2012/03/18 19:42:44 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.90 2012/03/25 14:25:09 slyfox Exp $
+
+ 25 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/haddock-2.10.0-drop-tools.patch, haddock-2.10.0.ebuild:
+ Get rid of dev-haskell/happy and dev-haskell/alex depends (reported by judu).
18 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org>
+files/haddock-2.9.2-cabal-1.10.patch, haddock-2.9.2.ebuild:
diff --git a/dev-haskell/haddock/files/haddock-2.10.0-drop-tools.patch b/dev-haskell/haddock/files/haddock-2.10.0-drop-tools.patch
new file mode 100644
index 000000000000..f7f7f4a3ee1e
--- /dev/null
+++ b/dev-haskell/haddock/files/haddock-2.10.0-drop-tools.patch
@@ -0,0 +1,26 @@
+diff --git a/haddock.cabal b/haddock.cabal
+index 84d3c2a..9587450 100644
+--- a/haddock.cabal
++++ b/haddock.cabal
+@@ -78,10 +78,6 @@ flag test
+
+ executable haddock
+ default-language: Haskell2010
+- -- In a GHC tree - in particular, in a source tarball - we don't
+- -- require alex or happy
+- if !flag(in-ghc-tree)
+- build-tools: alex >= 2.3, happy >= 1.18
+ build-depends:
+ base >= 4.3 && < 4.6,
+ filepath,
+@@ -140,10 +136,6 @@ executable haddock
+
+ library
+ default-language: Haskell2010
+- -- In a GHC tree - in particular, in a source tarball - we don't
+- -- require alex or happy
+- if !flag(in-ghc-tree)
+- build-tools: alex >= 2.3, happy >= 1.18
+ build-depends:
+ base >= 4.3 && < 4.6,
+ filepath,
diff --git a/dev-haskell/haddock/haddock-2.10.0.ebuild b/dev-haskell/haddock/haddock-2.10.0.ebuild
index 1e1db8651e71..3b186138d788 100644
--- a/dev-haskell/haddock/haddock-2.10.0.ebuild
+++ b/dev-haskell/haddock/haddock-2.10.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.10.0.ebuild,v 1.1 2012/03/06 05:31:21 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.10.0.ebuild,v 1.2 2012/03/25 14:25:09 slyfox Exp $
EAPI="4"
CABAL_FEATURES="bin lib profile haddock hscolour"
-inherit haskell-cabal pax-utils
+inherit eutils haskell-cabal pax-utils
DESCRIPTION="A documentation-generation tool for Haskell libraries"
HOMEPAGE="http://www.haskell.org/haddock/"
@@ -22,14 +22,22 @@ RDEPEND="dev-haskell/ghc-paths[profile?]
=dev-haskell/xhtml-3000.2*[profile?]
>=dev-lang/ghc-7.4"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10"
+ >=dev-haskell/cabal-1.14"
RESTRICT="test" # avoid depends on QC
CABAL_EXTRA_BUILD_FLAGS="--ghc-options=-rtsopts"
-# haddock is disabled as Cabal seems to be buggy about building docs with itself.
-# however, other packages seem to work
+src_prepare() {
+ # we would like to avoid happy and alex depends
+ epatch "${FILESDIR}"/${P}-drop-tools.patch
+
+ for f in Lex Parse; do
+ rm "src/Haddock/$f."*
+ mv "dist/build/haddock/haddock-tmp/Haddock/$f.hs" src/Haddock/
+ done
+}
+
src_configure() {
# create a fake haddock executable. it'll set the right version to cabal
# configure, but will eventually get overwritten in src_compile by