summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-05-13 08:37:32 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-05-13 08:37:32 +0000
commit0e8ad47d0b684bd59e12379566c634cd8e607f1a (patch)
treeafa1557fea8f1dead8fd111e57195f13fbdf7810 /dev-haskell
parentVersion bump, also fixes #410927 (diff)
downloadgentoo-2-0e8ad47d0b684bd59e12379566c634cd8e607f1a.tar.gz
gentoo-2-0e8ad47d0b684bd59e12379566c634cd8e607f1a.tar.bz2
gentoo-2-0e8ad47d0b684bd59e12379566c634cd8e607f1a.zip
Version bump (ghc-7.4 compatible)
(Portage version: 2.2.0_alpha101_p6/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/cairo/ChangeLog10
-rw-r--r--dev-haskell/cairo/cairo-0.12.3.ebuild36
-rw-r--r--dev-haskell/cairo/files/cairo-0.12.3-fixincl.patch19
-rw-r--r--dev-haskell/cairo/metadata.xml5
4 files changed, 68 insertions, 2 deletions
diff --git a/dev-haskell/cairo/ChangeLog b/dev-haskell/cairo/ChangeLog
index a2623f2a80fd..dbc165a195d3 100644
--- a/dev-haskell/cairo/ChangeLog
+++ b/dev-haskell/cairo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/cairo
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cairo/ChangeLog,v 1.3 2011/06/21 11:01:35 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cairo/ChangeLog,v 1.4 2012/05/13 08:37:32 slyfox Exp $
+
+*cairo-0.12.3 (13 May 2012)
+
+ 13 May 2012; Sergei Trofimovich <slyfox@gentoo.org> +cairo-0.12.3.ebuild,
+ +files/cairo-0.12.3-fixincl.patch, metadata.xml:
+ Version bump (ghc-7.4 compatible)
21 Jun 2011; Markos Chandras <hwoarang@gentoo.org> cairo-0.12.0.ebuild:
Stable on amd64 wrt bug #314059
diff --git a/dev-haskell/cairo/cairo-0.12.3.ebuild b/dev-haskell/cairo/cairo-0.12.3.ebuild
new file mode 100644
index 000000000000..557ba1ec58b4
--- /dev/null
+++ b/dev-haskell/cairo/cairo-0.12.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cairo/cairo-0.12.3.ebuild,v 1.1 2012/05/13 08:37:32 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI=4
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hscolour hoogle nocabaldep"
+inherit base haskell-cabal
+
+DESCRIPTION="Binding to the Cairo library."
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+svg"
+
+RDEPEND="dev-haskell/mtl
+ >=dev-lang/ghc-6.10.1
+ x11-libs/cairo[svg?]"
+DEPEND="${RDEPEND}
+ dev-haskell/gtk2hs-buildtools"
+
+PATCHES=("${FILESDIR}"/${P}-fixincl.patch)
+
+src_configure() {
+ # x11-libs/cairo seems to build pdf and ps by default
+ cabal_src_configure \
+ --flags=cairo_pdf \
+ --flags=cairo_ps \
+ $(cabal_flag svg cairo_svg)
+}
diff --git a/dev-haskell/cairo/files/cairo-0.12.3-fixincl.patch b/dev-haskell/cairo/files/cairo-0.12.3-fixincl.patch
new file mode 100644
index 000000000000..1b531a1932ea
--- /dev/null
+++ b/dev-haskell/cairo/files/cairo-0.12.3-fixincl.patch
@@ -0,0 +1,19 @@
+Fix include path on cabal-1.14
+
+Building cairo-0.12.3...
+Preprocessing library cairo-0.12.3...
+dist/build/Graphics/Rendering/Cairo/Matrix.h:1:26: fatal error: cairo-gtk2hs.h: No such file or directory
+compilation terminated.
+gtk2hsC2hs: Error during preprocessing custom header file
+diff --git a/cairo.cabal b/cairo.cabal
+index af7cee9..62fe84b 100644
+--- a/cairo.cabal
++++ b/cairo.cabal
+@@ -69,6 +69,7 @@ Library
+ Graphics.Rendering.Cairo.Internal.Surfaces.PS
+ Graphics.Rendering.Cairo.Internal.Surfaces.SVG
+ extensions: ForeignFunctionInterface
++ Include-dirs: .
+ x-c2hs-Header: cairo-gtk2hs.h
+ pkgconfig-depends: cairo >= 1.2.0
+ if flag(cairo_pdf)
diff --git a/dev-haskell/cairo/metadata.xml b/dev-haskell/cairo/metadata.xml
index 2f5607ea9893..adc163231c20 100644
--- a/dev-haskell/cairo/metadata.xml
+++ b/dev-haskell/cairo/metadata.xml
@@ -5,4 +5,9 @@
<maintainer>
<email>haskell@gentoo.org</email>
</maintainer>
+ <longdescription>
+ Cairo is a library to render high quality vector graphics. There
+ exist various backends that allows rendering to Gtk windows, PDF,
+ PS, PNG and SVG documents, amongst others.
+ </longdescription>
</pkgmetadata>