summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-10-26 17:47:26 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-10-26 17:47:26 +0000
commit0bf6db92276a40c7c0f5f599522381f204c77b95 (patch)
tree42553ba6f17ea5e15adc3939ad3333fdeef0068a /dev-haskell
parentaccidently marked it x86 (Manifest recommit) (diff)
downloadgentoo-2-0bf6db92276a40c7c0f5f599522381f204c77b95.tar.gz
gentoo-2-0bf6db92276a40c7c0f5f599522381f204c77b95.tar.bz2
gentoo-2-0bf6db92276a40c7c0f5f599522381f204c77b95.zip
Initial import (bug #56997).
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/WASH/ChangeLog10
-rw-r--r--dev-haskell/WASH/Manifest2
-rw-r--r--dev-haskell/WASH/WASH-2.0.5.ebuild97
-rw-r--r--dev-haskell/WASH/files/digest-WASH-2.0.51
-rw-r--r--dev-haskell/WASH/metadata.xml8
5 files changed, 118 insertions, 0 deletions
diff --git a/dev-haskell/WASH/ChangeLog b/dev-haskell/WASH/ChangeLog
new file mode 100644
index 000000000000..07c5c406e5be
--- /dev/null
+++ b/dev-haskell/WASH/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/WASH
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/WASH/ChangeLog,v 1.1 2004/10/26 17:47:26 kosmikus Exp $
+
+*WASH-2.0.5 (26 Oct 2004)
+
+ 26 Oct 2004; Andres Loeh <kosmikus@gentoo.org> WASH-2.0.5.ebuild,
+ metadata.xml:
+ Initial import, as requested in bug #56997.
+
diff --git a/dev-haskell/WASH/Manifest b/dev-haskell/WASH/Manifest
new file mode 100644
index 000000000000..ffb15d1688b6
--- /dev/null
+++ b/dev-haskell/WASH/Manifest
@@ -0,0 +1,2 @@
+MD5 e0117e07ef9baf7c0f0f8fcf370a99ba WASH-2.0.5.ebuild 1371
+MD5 17b177468da822de7bb9ba89a644b9ce files/digest-WASH-2.0.5 62
diff --git a/dev-haskell/WASH/WASH-2.0.5.ebuild b/dev-haskell/WASH/WASH-2.0.5.ebuild
new file mode 100644
index 000000000000..3a0a12e0b894
--- /dev/null
+++ b/dev-haskell/WASH/WASH-2.0.5.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/WASH/WASH-2.0.5.ebuild,v 1.1 2004/10/26 17:47:26 kosmikus Exp $
+
+# the installation bundle is called WashNGo
+MY_P="WashNGo"
+MY_PV=${MY_P}-${PV}
+
+DESCRIPTION="WASH is a family of embedded domain-specific languages for programming Web applications"
+HOMEPAGE="http://www.informatik.uni-freiburg.de/~thiemann/haskell/WASH/"
+SRC_URI="http://www.informatik.uni-freiburg.de/~thiemann/haskell/WASH/${MY_PV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc postgres"
+
+DEPEND=">=virtual/ghc-6.2
+ postgres? ( dev-haskell/c2hs
+ >=dev-db/postgresql-7.4.3 )"
+
+# RDEPEND: c2hs needed?
+
+S=${WORKDIR}/${MY_PV}
+
+src_compile() {
+ local myopts
+ myopts="${myopts} `use_enable postgres dbconnect`"
+ myopts="${myopts} `use_enable doc build-docs`"
+ # determine ghc library directory
+ ghc_version=`best_version virtual/ghc | sed "s:.*/::"`
+ test -n ${ghc_version} && ghclibdir="/usr/lib/${ghc_version}"
+ test -n ${ghclibdir} || ghclibdir="/usr/lib"
+ test -n ${ghclibdir} && myopts="${myopts} --libdir=${D}${ghclibdir}"
+ ./configure \
+ --prefix="${D}usr" \
+ --host=${CHOST} \
+ ${myopts} \
+ --enable-register-package="${S}/${MY_PV}.conf" \
+ || die "configure failed"
+ make depend || die "make depend failed"
+ make all || die "make all failed"
+}
+
+src_install() {
+ mkdir -p ${D}${ghclibdir}
+ echo "[]" > ${S}/${MY_PV}.conf
+ make install || die "make install failed"
+ # fix references to D in temporary package configuration file
+ cat ${S}/${MY_PV}.conf | sed "s:${D}::" \
+ > ${D}${ghclibdir}/${MY_PV}.conf
+
+ dodoc README
+ if use doc; then
+ cp -r Examples ${D}/usr/share/doc/${PF}
+ cd doc
+ dohtml -r *
+ fi
+}
+
+pkg_postinst() {
+ # packages: WASH/WASHHTML cgi/WASH-CGI dbconnect/DBCONNECT
+ # Utility/Utility Mail/WASHMail
+ register_ghc_package Utility
+ register_ghc_package WASHHTML
+ register_ghc_package WASHMail
+ register_ghc_package WASH-CGI
+ register_ghc_package WASH
+ use postgres && register_ghc_package DBCONNECT
+}
+
+pkg_postrm() {
+ # check if another version is still there
+ has_version "<${CATEGORY}/${PF}" \
+ || has_version ">${CATEGORY}/${PF}" \
+ || unregister_ghc_packages
+}
+
+register_ghc_package() {
+ einfo "Registering $1 package"
+ /usr/bin/ghc-pkg -f ${ghclibdir}/${MY_PV}.conf -s $1 \
+ | /usr/bin/ghc-pkg -u --auto-ghci-libs
+}
+
+unregister_ghc_packages() {
+ unregister_ghc_package DBCONNECT
+ unregister_ghc_package WASH
+ unregister_ghc_package WASH-CGI
+ unregister_ghc_package WASHMail
+ unregister_ghc_package WASHHTML
+ unregister_ghc_package Utility
+}
+
+unregister_ghc_package() {
+ einfo "Unregistering $1 package (warnings are safe to ignore)"
+ /usr/sbin/ghc-pkg -r $1
+}
diff --git a/dev-haskell/WASH/files/digest-WASH-2.0.5 b/dev-haskell/WASH/files/digest-WASH-2.0.5
new file mode 100644
index 000000000000..479a2fa3a9d9
--- /dev/null
+++ b/dev-haskell/WASH/files/digest-WASH-2.0.5
@@ -0,0 +1 @@
+MD5 c438ae77c564310188700a962d922fec WashNGo-2.0.5.tgz 424676
diff --git a/dev-haskell/WASH/metadata.xml b/dev-haskell/WASH/metadata.xml
new file mode 100644
index 000000000000..a53a18c06081
--- /dev/null
+++ b/dev-haskell/WASH/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>haskell</herd>
+<maintainer>
+ <email>kosmikus@gentoo.org</email>
+</maintainer>
+</pkgmetadata>