summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-02-09 19:10:11 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-02-09 19:10:11 +0000
commit08575cd8a6cf6567aa96bc1811bea98aee73e34b (patch)
treef7df1d030a90186b6a0bc52bf31f4d0d92d54571 /dev-haskell
parentSwitch to EAPI=5. (diff)
downloadgentoo-2-08575cd8a6cf6567aa96bc1811bea98aee73e34b.tar.gz
gentoo-2-08575cd8a6cf6567aa96bc1811bea98aee73e34b.tar.bz2
gentoo-2-08575cd8a6cf6567aa96bc1811bea98aee73e34b.zip
Version bump.
(Portage version: 2.2.0_alpha153_p6/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/texmath/ChangeLog9
-rw-r--r--dev-haskell/texmath/texmath-0.6.1.3.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-haskell/texmath/ChangeLog b/dev-haskell/texmath/ChangeLog
index c664d6ce3d49..d1b4f9a04ee8 100644
--- a/dev-haskell/texmath/ChangeLog
+++ b/dev-haskell/texmath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/texmath
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/ChangeLog,v 1.6 2012/11/25 06:09:58 gienah Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/ChangeLog,v 1.7 2013/02/09 19:10:11 slyfox Exp $
+
+*texmath-0.6.1.3 (09 Feb 2013)
+
+ 09 Feb 2013; Sergei Trofimovich <slyfox@gentoo.org> +texmath-0.6.1.3.ebuild:
+ Version bump.
*texmath-0.6.1.1 (25 Nov 2012)
diff --git a/dev-haskell/texmath/texmath-0.6.1.3.ebuild b/dev-haskell/texmath/texmath-0.6.1.3.ebuild
new file mode 100644
index 000000000000..a020df2f5542
--- /dev/null
+++ b/dev-haskell/texmath/texmath-0.6.1.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.1.3.ebuild,v 1.1 2013/02/09 19:10:11 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion of LaTeX math formulas to MathML or OMML."
+HOMEPAGE="http://github.com/jgm/texmath"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="cgi test"
+
+RDEPEND=">=dev-haskell/parsec-3:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/xml:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ cgi? ( dev-haskell/json:=[profile?]
+ dev-haskell/cgi:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag cgi) \
+ $(cabal_flag test)
+}
+
+src_install() {
+ cabal_src_install
+
+ # remove test and it's data
+ rm -f "${ED}/usr/bin/texmath" 2> /dev/null
+ rm -rf "${ED}/usr/share/${P}"/ghc-*/tests 2> /dev/null
+}