summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2010-09-04 13:59:36 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2010-09-04 13:59:36 +0000
commit01f879dac6f837b33d5bab5d6ceed2845a93ecb7 (patch)
tree3983440c79e0027127648a33fe74e576514a6166 /dev-haskell
parentVersion bump. (diff)
downloadgentoo-2-01f879dac6f837b33d5bab5d6ceed2845a93ecb7.tar.gz
gentoo-2-01f879dac6f837b33d5bab5d6ceed2845a93ecb7.tar.bz2
gentoo-2-01f879dac6f837b33d5bab5d6ceed2845a93ecb7.zip
Add dev-haskell/wxcore. Bindings to native libraries used by dev-haskell/wxhaskell.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/wxcore/ChangeLog10
-rw-r--r--dev-haskell/wxcore/metadata.xml8
-rw-r--r--dev-haskell/wxcore/wxcore-0.12.1.6.ebuild28
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/wxcore/ChangeLog b/dev-haskell/wxcore/ChangeLog
new file mode 100644
index 000000000000..6d190b157d67
--- /dev/null
+++ b/dev-haskell/wxcore/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/wxcore
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/ChangeLog,v 1.1 2010/09/04 13:59:36 kolmodin Exp $
+
+*wxcore-0.12.1.6 (04 Sep 2010)
+
+ 04 Sep 2010; Lennart Kolmodin <kolmodin@gentoo.org>
+ +wxcore-0.12.1.6.ebuild, +metadata.xml:
+ Initial import of wxcore, the wrappers to the native wxGTK library.
+
diff --git a/dev-haskell/wxcore/metadata.xml b/dev-haskell/wxcore/metadata.xml
new file mode 100644
index 000000000000..8c66906af531
--- /dev/null
+++ b/dev-haskell/wxcore/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>haskell</herd>
+<maintainer>
+ <email>haskell@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-haskell/wxcore/wxcore-0.12.1.6.ebuild b/dev-haskell/wxcore/wxcore-0.12.1.6.ebuild
new file mode 100644
index 000000000000..b1a0c97deb9e
--- /dev/null
+++ b/dev-haskell/wxcore/wxcore-0.12.1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/wxcore-0.12.1.6.ebuild,v 1.1 2010/09/04 13:59:36 kolmodin Exp $
+
+EAPI="2"
+
+WX_GTK_VER="2.8"
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal wxwidgets
+
+DESCRIPTION="wxHaskell core"
+HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/parsec
+ dev-haskell/stm
+ dev-haskell/time
+ >=dev-haskell/wxdirect-0.12.1.3
+ >=dev-lang/ghc-6.10
+ x11-libs/wxGTK:2.8[X]"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"