summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-01-23 12:14:57 +0000
committerMark Wright <gienah@gentoo.org>2012-01-23 12:14:57 +0000
commit0ecf7babb758f9172c889e36efbbc2ce13417116 (patch)
tree4c005e8c3b9717ebab6b77ab718f81c60fc064cd /dev-haskell/xhtml
parentRename sql.1 manpage to sql.1grass (file collision with sys-process/parallel)... (diff)
downloadgentoo-2-0ecf7babb758f9172c889e36efbbc2ce13417116.tar.gz
gentoo-2-0ecf7babb758f9172c889e36efbbc2ce13417116.tar.bz2
gentoo-2-0ecf7babb758f9172c889e36efbbc2ce13417116.zip
Bump xhtml to 3000.2.0.4
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/xhtml')
-rw-r--r--dev-haskell/xhtml/ChangeLog9
-rw-r--r--dev-haskell/xhtml/xhtml-3000.2.0.4.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-haskell/xhtml/ChangeLog b/dev-haskell/xhtml/ChangeLog
index 82f83ed89cb5..3bdf347d68b4 100644
--- a/dev-haskell/xhtml/ChangeLog
+++ b/dev-haskell/xhtml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/xhtml
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xhtml/ChangeLog,v 1.21 2011/12/21 08:46:50 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xhtml/ChangeLog,v 1.22 2012/01/23 12:14:57 gienah Exp $
+
+*xhtml-3000.2.0.4 (23 Jan 2012)
+
+ 23 Jan 2012; Mark Wright <gienah@gentoo.org> +xhtml-3000.2.0.4.ebuild:
+ Bump xhtml to 3000.2.0.4.
21 Dec 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> xhtml-3000.2.0.1.ebuild:
x86 stable wrt bug #393933
diff --git a/dev-haskell/xhtml/xhtml-3000.2.0.4.ebuild b/dev-haskell/xhtml/xhtml-3000.2.0.4.ebuild
new file mode 100644
index 000000000000..ca18b7f49e79
--- /dev/null
+++ b/dev-haskell/xhtml/xhtml-3000.2.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xhtml/xhtml-3000.2.0.4.ebuild,v 1.1 2012/01/23 12:14:57 gienah Exp $
+
+EAPI="3"
+
+# haddock-2.9.2 has xhtml as a dep, so disable haddock feature
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal
+
+DESCRIPTION="An XHTML combinator library"
+HOMEPAGE="https://github.com/haskell/xhtml"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ if has_version '>=dev-lang/ghc-7.2.1' && has_version '<dev-haskell/ghc-7.4.0'; then
+ if ghc-pkg describe base | grep -q "trusted: False"; then
+ eerror "Due to an oversight, the base package isn't trusted by default in ghc-7.2.1."
+ eerror "To avoid the build failing with the error:"
+ eerror "base:Prelude can't be safely imported! The package (base) the module resides in isn't trusted."
+ eerror "it is necessary to run, once:"
+ eerror "ghc-pkg trust base"
+ die "base is not trusted"
+ fi
+ fi
+ sed -e 's@base >= 4.0 && < 4.5@base >= 4.0 \&\& < 4.6@' \
+ -i "${S}/${PN}.cabal" || die "Could not loosen dependencies"
+}