summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-06-02 04:01:03 +0000
committerMark Wright <gienah@gentoo.org>2012-06-02 04:01:03 +0000
commite0b8dd9bc4731bff650f124dc251e97d453f13f4 (patch)
treee9f56b31c75ae21b79d1ec672f5b2b5821441c3d /dev-haskell/texmath/texmath-0.6.0.6.ebuild
parentBump highlighting-kate to 0.5.1 (diff)
downloadgentoo-2-e0b8dd9bc4731bff650f124dc251e97d453f13f4.tar.gz
gentoo-2-e0b8dd9bc4731bff650f124dc251e97d453f13f4.tar.bz2
gentoo-2-e0b8dd9bc4731bff650f124dc251e97d453f13f4.zip
Bump texmath to 0.6.0.6
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/texmath/texmath-0.6.0.6.ebuild')
-rw-r--r--dev-haskell/texmath/texmath-0.6.0.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/texmath/texmath-0.6.0.6.ebuild b/dev-haskell/texmath/texmath-0.6.0.6.ebuild
new file mode 100644
index 000000000000..103e143eeb0b
--- /dev/null
+++ b/dev-haskell/texmath/texmath-0.6.0.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.0.6.ebuild,v 1.1 2012/06/02 04:01:03 gienah Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion of LaTeX math formulas to MathML or OMML."
+HOMEPAGE="http://github.com/jgm/texmath"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cgi test"
+
+RDEPEND=">=dev-haskell/parsec-3[profile?]
+ dev-haskell/syb[profile?]
+ >=dev-haskell/xml-1.3.12[profile?]
+ >=dev-lang/ghc-6.8.2
+ cgi? ( dev-haskell/json[profile?]
+ dev-haskell/cgi[profile?]
+ dev-haskell/utf8-string[profile?]
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag cgi) \
+ $(cabal_flag test)
+}
+
+src_install() {
+ cabal_src_install
+
+ # remove test and it's data
+ rm -f "${ED}/usr/bin/texmath" 2> /dev/null
+ rm -rf "${ED}/usr/share/${P}"/ghc-*/tests 2> /dev/null
+}