summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2010-07-12 17:39:07 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2010-07-12 17:39:07 +0000
commit95f765dc9cbcc4ce8612c7c64b1437a3d64f9bdf (patch)
tree7e3e524a64333935e137632e6c32d8a860dbfaee /dev-haskell/stream/stream-0.2.6-r1.ebuild
parentStable on amd64 wrt bug #295256 (diff)
downloadgentoo-2-95f765dc9cbcc4ce8612c7c64b1437a3d64f9bdf.tar.gz
gentoo-2-95f765dc9cbcc4ce8612c7c64b1437a3d64f9bdf.tar.bz2
gentoo-2-95f765dc9cbcc4ce8612c7c64b1437a3d64f9bdf.zip
Switched to EAPI=1 and moved to slotted quickcheck:1 dep
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/stream/stream-0.2.6-r1.ebuild')
-rw-r--r--dev-haskell/stream/stream-0.2.6-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-haskell/stream/stream-0.2.6-r1.ebuild b/dev-haskell/stream/stream-0.2.6-r1.ebuild
new file mode 100644
index 000000000000..3e17dcfcb4e8
--- /dev/null
+++ b/dev-haskell/stream/stream-0.2.6-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/stream/stream-0.2.6-r1.ebuild,v 1.1 2010/07/12 17:39:07 slyfox Exp $
+
+EAPI=1
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+MY_PN="Stream"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library for manipulating infinite lists."
+HOMEPAGE="http://www.cs.nott.ac.uk/~wss/repos/Stream/dist/doc/html/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.6.1
+ dev-haskell/quickcheck:1"
+
+DEPEND="${RDEPEND}
+ dev-haskell/cabal"
+
+S="${WORKDIR}/${MY_P}"