summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-05-03 08:59:38 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-05-03 08:59:38 +0000
commitfbe4ce41caf89ed089e03202ad37a0256242bf80 (patch)
treeef5eb0e7a148fdf773c392afa78017f641a1c776 /dev-haskell/quickcheck
parentRemove old development versions (diff)
downloadgentoo-2-fbe4ce41caf89ed089e03202ad37a0256242bf80.tar.gz
gentoo-2-fbe4ce41caf89ed089e03202ad37a0256242bf80.tar.bz2
gentoo-2-fbe4ce41caf89ed089e03202ad37a0256242bf80.zip
Port to ghc-7.10.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/quickcheck')
-rw-r--r--dev-haskell/quickcheck/ChangeLog10
-rw-r--r--dev-haskell/quickcheck/files/quickcheck-1.2.0.1-ghc-7.10.patch13
-rw-r--r--dev-haskell/quickcheck/quickcheck-1.2.0.1-r1.ebuild33
3 files changed, 54 insertions, 2 deletions
diff --git a/dev-haskell/quickcheck/ChangeLog b/dev-haskell/quickcheck/ChangeLog
index 4d9f38c32342..9d13741ee595 100644
--- a/dev-haskell/quickcheck/ChangeLog
+++ b/dev-haskell/quickcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/quickcheck
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.71 2014/12/14 05:38:50 gienah Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.72 2015/05/03 08:59:38 slyfox Exp $
+
+*quickcheck-1.2.0.1-r1 (03 May 2015)
+
+ 03 May 2015; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/quickcheck-1.2.0.1-ghc-7.10.patch, +quickcheck-1.2.0.1-r1.ebuild:
+ Port to ghc-7.10.
*quickcheck-2.7.6 (14 Dec 2014)
diff --git a/dev-haskell/quickcheck/files/quickcheck-1.2.0.1-ghc-7.10.patch b/dev-haskell/quickcheck/files/quickcheck-1.2.0.1-ghc-7.10.patch
new file mode 100644
index 000000000000..61056fc3ef46
--- /dev/null
+++ b/dev-haskell/quickcheck/files/quickcheck-1.2.0.1-ghc-7.10.patch
@@ -0,0 +1,13 @@
+diff --git a/Test/QuickCheck.hs b/Test/QuickCheck.hs
+index 1f8b3b9..27138ab 100644
+--- a/Test/QuickCheck.hs
++++ b/Test/QuickCheck.hs
+@@ -75 +75,2 @@ import Data.List( group, sort, intersperse )
+-import Control.Monad( liftM2, liftM3, liftM4 )
++import Control.Applicative
++import Control.Monad( liftM2, liftM3, liftM4, ap )
+@@ -115,0 +117,4 @@ instance Functor Gen where
++instance Applicative Gen where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
diff --git a/dev-haskell/quickcheck/quickcheck-1.2.0.1-r1.ebuild b/dev-haskell/quickcheck/quickcheck-1.2.0.1-r1.ebuild
new file mode 100644
index 000000000000..e114dc0de7f5
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-1.2.0.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-1.2.0.1-r1.ebuild,v 1.1 2015/05/03 08:59:38 slyfox Exp $
+
+EAPI=5
+
+CABAL_FEATURES="lib profile haddock"
+inherit eutils haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="http://www.math.chalmers.se/~rjmh/QuickCheck/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.6.1
+ dev-haskell/random:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}