summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-07-27 19:58:46 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-07-27 19:58:46 +0000
commitec579f777f17c9e6eae5c1d1bc7f33146907cb5f (patch)
treee92f3fbd9657014fba72131a7fa6715218b7fd90 /dev-haskell/quickcheck
parentFix building with gcc-4.4, bug #273506 (diff)
downloadgentoo-2-ec579f777f17c9e6eae5c1d1bc7f33146907cb5f.tar.gz
gentoo-2-ec579f777f17c9e6eae5c1d1bc7f33146907cb5f.tar.bz2
gentoo-2-ec579f777f17c9e6eae5c1d1bc7f33146907cb5f.zip
Fix dev-haskell/quickcheck-1.1.0.0 to compile with dev-lang/ghc-6.10
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/quickcheck')
-rw-r--r--dev-haskell/quickcheck/ChangeLog8
-rw-r--r--dev-haskell/quickcheck/files/quickcheck-1.1.0.0-ghc-6.10-build-fix.patch13
-rw-r--r--dev-haskell/quickcheck/quickcheck-1.1.0.0.ebuild6
3 files changed, 24 insertions, 3 deletions
diff --git a/dev-haskell/quickcheck/ChangeLog b/dev-haskell/quickcheck/ChangeLog
index 118b23e637f7..7cd226ad8061 100644
--- a/dev-haskell/quickcheck/ChangeLog
+++ b/dev-haskell/quickcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/quickcheck
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.32 2009/04/19 10:26:03 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.33 2009/07/27 19:58:46 kolmodin Exp $
+
+ 27 Jul 2009; Lennart Kolmodin <kolmodin@gentoo.org>
+ +files/quickcheck-1.1.0.0-ghc-6.10-build-fix.patch,
+ quickcheck-1.1.0.0.ebuild:
+ Fix 1.1.0.0 (latest stable) to compile with ghc-6.10.x.
+ Patch by Sergei Trofimovich <slyfox@inbox.ru>.
*quickcheck-1.2.0.0 (19 Apr 2009)
diff --git a/dev-haskell/quickcheck/files/quickcheck-1.1.0.0-ghc-6.10-build-fix.patch b/dev-haskell/quickcheck/files/quickcheck-1.1.0.0-ghc-6.10-build-fix.patch
new file mode 100644
index 000000000000..2b74a3b90c30
--- /dev/null
+++ b/dev-haskell/quickcheck/files/quickcheck-1.1.0.0-ghc-6.10-build-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/QuickCheck.cabal b/QuickCheck.cabal
+index b08e03a..f84a32f 100644
+--- a/QuickCheck.cabal
++++ b/QuickCheck.cabal
+@@ -33,7 +33,7 @@ library
+ Test.QuickCheck.Utils,
+ Test.QuickCheck
+ if flag(split-base)
+- build-depends: base >= 3, random
++ build-depends: base >= 3 && < 4, random
+ else
+ build-depends: base < 3
+ extensions: CPP
diff --git a/dev-haskell/quickcheck/quickcheck-1.1.0.0.ebuild b/dev-haskell/quickcheck/quickcheck-1.1.0.0.ebuild
index 3af354230c1b..79da2d7294a2 100644
--- a/dev-haskell/quickcheck/quickcheck-1.1.0.0.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-1.1.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-1.1.0.0.ebuild,v 1.5 2008/10/04 17:55:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-1.1.0.0.ebuild,v 1.6 2009/07/27 19:58:46 kolmodin Exp $
CABAL_FEATURES="lib profile haddock"
CABAL_MIN_VERSION=1.2
@@ -21,3 +21,5 @@ IUSE=""
DEPEND=">=dev-lang/ghc-6.6"
S="${WORKDIR}/${MY_P}"
+
+PATCHES=("${FILESDIR}/${P}-*")