summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-01-10 09:18:55 +0000
committerMark Wright <gienah@gentoo.org>2015-01-10 09:18:55 +0000
commit03eb7b48c461655eab9939dadf501b58fe16ff11 (patch)
tree4e2972fff8123b840eba7e3738a4d0ade8a4c4fb /dev-haskell/pandoc-citeproc
parentrevbump; conversion -> distutils-r1, rm old (diff)
downloadgentoo-2-03eb7b48c461655eab9939dadf501b58fe16ff11.tar.gz
gentoo-2-03eb7b48c461655eab9939dadf501b58fe16ff11.tar.bz2
gentoo-2-03eb7b48c461655eab9939dadf501b58fe16ff11.zip
Patch pandoc-citeproc for ghc 7.10.1 RC1 https://github.com/jgm/pandoc-citeproc/pull/99
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/pandoc-citeproc')
-rw-r--r--dev-haskell/pandoc-citeproc/ChangeLog7
-rw-r--r--dev-haskell/pandoc-citeproc/files/pandoc-citeproc-0.6-ghc-7.10.patch115
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.6.ebuild8
3 files changed, 126 insertions, 4 deletions
diff --git a/dev-haskell/pandoc-citeproc/ChangeLog b/dev-haskell/pandoc-citeproc/ChangeLog
index bc1ec5dfad6d..10b3d67c5b93 100644
--- a/dev-haskell/pandoc-citeproc/ChangeLog
+++ b/dev-haskell/pandoc-citeproc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/pandoc-citeproc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-citeproc/ChangeLog,v 1.7 2015/01/02 10:33:11 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-citeproc/ChangeLog,v 1.8 2015/01/10 09:18:55 gienah Exp $
+
+ 10 Jan 2015; Mark Wright <gienah@gentoo.org>
+ +files/pandoc-citeproc-0.6-ghc-7.10.patch, pandoc-citeproc-0.6.ebuild:
+ Patch pandoc-citeproc for ghc 7.10.1 RC1 https://github.com/jgm/pandoc-
+ citeproc/pull/99
02 Jan 2015; Sergei Trofimovich <slyfox@gentoo.org>
pandoc-citeproc-0.3.1.ebuild:
diff --git a/dev-haskell/pandoc-citeproc/files/pandoc-citeproc-0.6-ghc-7.10.patch b/dev-haskell/pandoc-citeproc/files/pandoc-citeproc-0.6-ghc-7.10.patch
new file mode 100644
index 000000000000..cee2d93bc213
--- /dev/null
+++ b/dev-haskell/pandoc-citeproc/files/pandoc-citeproc-0.6-ghc-7.10.patch
@@ -0,0 +1,115 @@
+--- pandoc-citeproc-0.6-orig/src/Text/CSL/Pandoc.hs 2014-09-22 14:04:21.000000000 +1000
++++ pandoc-citeproc-0.6/src/Text/CSL/Pandoc.hs 2015-01-10 11:57:26.900041860 +1100
+@@ -201,10 +201,10 @@
+ && isEndPunct c -> True
+ (c:_) | isEndPunct c -> True
+ | otherwise -> False
+- where isEndPunct c = c `elem` ".,;:!?"
++ where isEndPunct c = c `elem` (".,;:!?" :: String)
+
+ startWithPunct :: [Inline] -> Bool
+-startWithPunct = and . map (`elem` ".,;:!?") . headInline
++startWithPunct = and . map (`elem` (".,;:!?" :: String)) . headInline
+
+ deNote :: Pandoc -> Pandoc
+ deNote = topDown go
+@@ -324,7 +324,7 @@
+ sp <- option "" (pSpace >> return " ")
+ r <- many1 (notFollowedBy pSpace >> notFollowedBy pLocatorPunct >> anyToken)
+ let s = stringify r
+- guard $ any isDigit s || all (`elem` "IVXLCM") s
++ guard $ any isDigit s || all (`elem` ("IVXLCM" :: String)) s
+ return $ punct ++ sp ++ s
+
+ pDigit :: Parsec [Inline] st ()
+--- pandoc-citeproc-0.6-orig/src/Text/CSL/Proc.hs 2014-09-22 14:04:21.000000000 +1000
++++ pandoc-citeproc-0.6/src/Text/CSL/Proc.hs 2015-01-10 11:56:18.797456065 +1100
+@@ -288,7 +288,7 @@
+ case ys of
+ Formatted [] -> xs
+ Formatted (Note _ : _) -> xs <> ys
+- Formatted (Str [c]:_) | c `elem` ", ;:" -> xs <> ys
++ Formatted (Str [c]:_) | c `elem` (", ;:" :: String) -> xs <> ys
+ _ -> xs <> Formatted [Space] <> ys
+ formatAuth = formatOutput . localMod
+ formatCits = (if isNote then toNote else id) .
+@@ -328,7 +328,7 @@
+ | otherwise = id
+ where
+ isPunct' [] = False
+- isPunct' xs = all (`elem` ".,;:!? ") xs
++ isPunct' xs = all (`elem` (".,;:!? " :: String)) xs
+ check o = case cleanOutput o of
+ [] -> ONull
+ x -> case trim' x of
+--- pandoc-citeproc-0.6-orig/src/Text/CSL/Eval/Names.hs 2014-09-22 14:04:21.000000000 +1000
++++ pandoc-citeproc-0.6/src/Text/CSL/Eval/Names.hs 2015-01-10 11:55:41.839119783 +1100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE PatternGuards #-}
++{-# LANGUAGE PatternGuards, FlexibleContexts #-}
+ -----------------------------------------------------------------------------
+ -- |
+ -- Module : Text.CSL.Eval.Names
+--- pandoc-citeproc-0.6-orig/src/Text/CSL/Eval.hs 2014-09-22 14:04:21.000000000 +1000
++++ pandoc-citeproc-0.6/src/Text/CSL/Eval.hs 2015-01-10 11:55:23.090597159 +1100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE PatternGuards #-}
++{-# LANGUAGE PatternGuards, FlexibleContexts #-}
+ -----------------------------------------------------------------------------
+ -- |
+ -- Module : Text.CSL.Eval
+--- pandoc-citeproc-0.6-orig/src/Text/CSL/Parser.hs 2014-09-22 14:04:21.000000000 +1000
++++ pandoc-citeproc-0.6/src/Text/CSL/Parser.hs 2015-01-10 11:54:59.755477862 +1100
+@@ -144,7 +144,7 @@
+
+ parseCslTerm :: Cursor -> CslTerm
+ parseCslTerm cur =
+- let body = unpack $ T.dropAround (`elem` " \t\r\n") $
++ let body = unpack $ T.dropAround (`elem` (" \t\r\n" :: String)) $
+ T.concat $ cur $/ content
+ in CT
+ { cslTerm = stringAttr "name" cur
+--- pandoc-citeproc-0.6-orig/src/Text/CSL/Style.hs 2014-09-22 14:04:21.000000000 +1000
++++ pandoc-citeproc-0.6/src/Text/CSL/Style.hs 2015-01-10 11:53:23.641828264 +1100
+@@ -130,7 +130,7 @@
+ -- this is needed for versions of pandoc that don't turn
+ -- a span with font-variant:small-caps into a SmallCaps element:
+ where handleSmallCapsSpans (Span ("",[],[("style",sty)]) ils)
+- | filter (`notElem` " \t;") sty == "font-variant:small-caps" =
++ | filter (`notElem` (" \t;" :: String)) sty == "font-variant:small-caps" =
+ SmallCaps ils
+ handleSmallCapsSpans x = x
+
+@@ -206,15 +206,15 @@
+ appendWithPunct (Formatted left) (Formatted right) =
+ Formatted $
+ case concat [lastleft, firstright] of
+- [' ',d] | d `elem` ",.:;" -> initInline left ++ right
+- [c,d] | c `elem` " ,.:;", d == c -> left ++ tailInline right
+- [c,'.'] | c `elem` ",.!:;?" -> left ++ tailInline right
+- [c,':'] | c `elem` ",!:;?" -> left ++ tailInline right -- Mich.: 2005
+- [c,'!'] | c `elem` ",.!:;?" -> left ++ tailInline right
+- [c,'?'] | c `elem` ",.!:;?" -> left ++ tailInline right
+- [c,';'] | c `elem` ",:;" -> left ++ tailInline right -- et al.;
+- [':',c] | c `elem` ",.!:;?" -> left ++ tailInline right
+- [';',c] | c `elem` ",.!:;?" -> left ++ tailInline right
++ [' ',d] | d `elem` (",.:;" :: String) -> initInline left ++ right
++ [c,d] | c `elem` (" ,.:;" :: String), d == c -> left ++ tailInline right
++ [c,'.'] | c `elem` (",.!:;?" :: String) -> left ++ tailInline right
++ [c,':'] | c `elem` (",!:;?" :: String) -> left ++ tailInline right -- Mich.: 2005
++ [c,'!'] | c `elem` (",.!:;?" :: String) -> left ++ tailInline right
++ [c,'?'] | c `elem` (",.!:;?" :: String) -> left ++ tailInline right
++ [c,';'] | c `elem` (",:;" :: String) -> left ++ tailInline right -- et al.;
++ [':',c] | c `elem` (",.!:;?" :: String) -> left ++ tailInline right
++ [';',c] | c `elem` (",.!:;?" :: String) -> left ++ tailInline right
+ -- ".;" -> right -- e.g. et al.;
+ _ -> left ++ right
+ where lastleft = lastInline left
+--- pandoc-citeproc-0.6-orig/src/Text/CSL/Util.hs 2014-09-22 14:04:21.000000000 +1000
++++ pandoc-citeproc-0.6/src/Text/CSL/Util.hs 2015-01-10 11:51:31.789057499 +1100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE ScopedTypeVariables, PatternGuards #-}
++{-# LANGUAGE ScopedTypeVariables, PatternGuards, FlexibleContexts #-}
+ module Text.CSL.Util
+ ( safeRead
+ , readNum
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.6.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.6.ebuild
index f43ae449ba56..9df6fafc14bc 100644
--- a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.6.ebuild
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.6.ebuild,v 1.1 2014/12/14 08:46:43 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.6.ebuild,v 1.2 2015/01/10 09:18:55 gienah Exp $
EAPI=5
@@ -8,7 +8,7 @@ EAPI=5
#hackport: flags: -small_base
CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
+inherit base haskell-cabal
DESCRIPTION="Supports using pandoc with citeproc"
HOMEPAGE="http://hackage.haskell.org/package/pandoc-citeproc"
@@ -46,6 +46,8 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.12
"
+PATCHES=("${FILESDIR}/${PN}-0.6-ghc-7.10.patch")
+
src_configure() {
# workaround bug on ghc-7.6.3:
# > [13 of 24] Compiling Text.CSL.Input.Bibtex ...