summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-04-03 11:49:27 +0000
committerMark Wright <gienah@gentoo.org>2013-04-03 11:49:27 +0000
commitc405c28fce6262982f77b601e07ddf76d30698ff (patch)
tree3b18738c76b7e879f668ba8bf19ee78691fed657 /dev-haskell/openal
parentBump x11 to 1.6.1.1 (diff)
downloadgentoo-2-c405c28fce6262982f77b601e07ddf76d30698ff.tar.gz
gentoo-2-c405c28fce6262982f77b601e07ddf76d30698ff.tar.bz2
gentoo-2-c405c28fce6262982f77b601e07ddf76d30698ff.zip
Bump openal to 1.4.0.2. Hoping the bump might fix: Bug 458362 - dev-haskell/openal-1.4.0.1: fails to build. I tested compiling it with ghc 7.6.2 (and 7.4.2).
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/openal')
-rw-r--r--dev-haskell/openal/ChangeLog11
-rw-r--r--dev-haskell/openal/openal-1.4.0.2.ebuild32
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-haskell/openal/ChangeLog b/dev-haskell/openal/ChangeLog
index 0009f67fd386..72434f2a1395 100644
--- a/dev-haskell/openal/ChangeLog
+++ b/dev-haskell/openal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/openal
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/openal/ChangeLog,v 1.14 2012/09/12 15:52:08 qnikst Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/openal/ChangeLog,v 1.15 2013/04/03 11:49:27 gienah Exp $
+
+*openal-1.4.0.2 (03 Apr 2013)
+
+ 03 Apr 2013; Mark Wright <gienah@gentoo.org> +openal-1.4.0.2.ebuild:
+ Bump openal to 1.4.0.2. Hoping the bump might fix: Bug 458362 - dev-
+ haskell/openal-1.4.0.1: fails to build. I tested compiling it with ghc 7.6.2
+ (and 7.4.2).
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org> openal-1.3.1.1.ebuild,
openal-1.4.0.1.ebuild:
diff --git a/dev-haskell/openal/openal-1.4.0.2.ebuild b/dev-haskell/openal/openal-1.4.0.2.ebuild
new file mode 100644
index 000000000000..b9ab55592257
--- /dev/null
+++ b/dev-haskell/openal/openal-1.4.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/openal/openal-1.4.0.2.ebuild,v 1.1 2013/04/03 11:49:27 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="OpenAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding to the OpenAL cross-platform 3D audio API"
+HOMEPAGE="http://connect.creativelabs.com/openal/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/objectname:=[profile?]
+ dev-haskell/statevar:=[profile?]
+ dev-haskell/tensor:=[profile?]
+ media-libs/openal
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ dev-haskell/cabal"
+
+S="${WORKDIR}/${MY_P}"