summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-03-04 03:37:58 +0000
committerMark Wright <gienah@gentoo.org>2012-03-04 03:37:58 +0000
commitda046f0a326665fe5f5cbf2243d642486421090e (patch)
tree61ace86e0024482045524d2e47918344efa6d9b0 /dev-haskell/http
parentAdd hpc for ghc 7.4.1 (diff)
downloadgentoo-2-da046f0a326665fe5f5cbf2243d642486421090e.tar.gz
gentoo-2-da046f0a326665fe5f5cbf2243d642486421090e.tar.bz2
gentoo-2-da046f0a326665fe5f5cbf2243d642486421090e.zip
Fix http-4000.1.2 build with ghc 7.4.1. Add http-4000.2.2 for ghc 7.4.1
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/http')
-rw-r--r--dev-haskell/http/ChangeLog14
-rw-r--r--dev-haskell/http/http-4000.1.2.ebuild17
-rw-r--r--dev-haskell/http/http-4000.2.2.ebuild43
3 files changed, 65 insertions, 9 deletions
diff --git a/dev-haskell/http/ChangeLog b/dev-haskell/http/ChangeLog
index a8269db3a138..e38222229115 100644
--- a/dev-haskell/http/ChangeLog
+++ b/dev-haskell/http/ChangeLog
@@ -1,8 +1,16 @@
# ChangeLog for dev-haskell/http
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.19 2011/12/04 17:26:32 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.20 2012/03/04 03:37:58 gienah Exp $
-*http-4000.1.2 (04 Dec 2011)
+*http-4000.2.2 (04 Mar 2012)
+
+ 04 Mar 2012; Mark Wright <gienah@gentoo.org> +http-4000.2.2.ebuild:
+ Add http-4000.2.2 for ghc 7.4.1
+
+*http-4000.1.2 (04 Mar 2012)
+
+ 04 Mar 2012; Mark Wright <gienah@gentoo.org> http-4000.1.2.ebuild,
+ Fix http-4000.1.2 build with ghc 7.4.1.
04 Dec 2011; Sergei Trofimovich <slyfox@gentoo.org> +http-4000.1.2.ebuild:
Version bump.
diff --git a/dev-haskell/http/http-4000.1.2.ebuild b/dev-haskell/http/http-4000.1.2.ebuild
index 68073d6722ff..45458e60dba9 100644
--- a/dev-haskell/http/http-4000.1.2.ebuild
+++ b/dev-haskell/http/http-4000.1.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-4000.1.2.ebuild,v 1.1 2011/12/04 17:26:32 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-4000.1.2.ebuild,v 1.2 2012/03/04 03:37:58 gienah Exp $
# ebuild generated by hackport 0.2.13
-EAPI="3"
+EAPI="4"
CABAL_FEATURES="lib profile haddock hscolour hoogle"
inherit haskell-cabal
@@ -21,11 +21,16 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
IUSE=""
-RDEPEND="dev-haskell/mtl
- dev-haskell/network
- dev-haskell/parsec
+RDEPEND="dev-haskell/mtl[profile?]
+ dev-haskell/network[profile?]
+ dev-haskell/parsec[profile?]
>=dev-lang/ghc-6.8.2"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.2"
S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -e 's@base >= 2 && < 4.5@base >= 2 \&\& < 4.6@' \
+ -i "${S}/${MY_PN}.cabal" || die "Could not loosen dependencies"
+}
diff --git a/dev-haskell/http/http-4000.2.2.ebuild b/dev-haskell/http/http-4000.2.2.ebuild
new file mode 100644
index 000000000000..cf3fd239aa10
--- /dev/null
+++ b/dev-haskell/http/http-4000.2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-4000.2.2.ebuild,v 1.1 2012/03/04 03:37:58 gienah Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="4"
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit base haskell-cabal
+
+MY_PN="HTTP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library for client-side HTTP"
+HOMEPAGE="https://github.com/haskell/HTTP"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="=dev-haskell/mtl-2.0*[profile?]
+ dev-haskell/network[profile?]
+ dev-haskell/parsec[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/cabal-1.10
+ dev-haskell/hunit[profile?]
+ dev-haskell/httpd-shed[profile?]
+ =dev-haskell/split-0.1*[profile?]
+ dev-haskell/test-framework[profile?]
+ dev-haskell/test-framework-hunit[profile?]
+ )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ cabal_src_configure $(use test && use_enable test tests) #395351
+}