summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-13 00:47:17 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-13 00:47:17 +0000
commitd6c161be1e2989ab80e39e4217a822ea602bc842 (patch)
tree1a94f5f1476d3e44fa044f727653a229595358c0 /dev-haskell/haxml
parentRemove unnecessary blocker. (diff)
downloadgentoo-2-d6c161be1e2989ab80e39e4217a822ea602bc842.tar.gz
gentoo-2-d6c161be1e2989ab80e39e4217a822ea602bc842.tar.bz2
gentoo-2-d6c161be1e2989ab80e39e4217a822ea602bc842.zip
Remove unnecessary blocker. Fix shell quoting.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-haskell/haxml')
-rw-r--r--dev-haskell/haxml/ChangeLog5
-rw-r--r--dev-haskell/haxml/haxml-1.12.ebuild16
-rw-r--r--dev-haskell/haxml/haxml-1.13-r1.ebuild5
3 files changed, 14 insertions, 12 deletions
diff --git a/dev-haskell/haxml/ChangeLog b/dev-haskell/haxml/ChangeLog
index 0d27a77364fb..364726fe5bbb 100644
--- a/dev-haskell/haxml/ChangeLog
+++ b/dev-haskell/haxml/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-haskell/haxml
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/ChangeLog,v 1.25 2007/10/31 12:59:40 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/ChangeLog,v 1.26 2007/12/13 00:47:17 dcoutts Exp $
+
+ 12 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> haxml-1.13-r1.ebuild:
+ Remove unnecessary blocker.
31 Oct 2007; Duncan Coutts <dcoutts@gentoo.org> haxml-1.12.ebuild,
haxml-1.13-r1.ebuild, haxml-1.13.2.ebuild:
diff --git a/dev-haskell/haxml/haxml-1.12.ebuild b/dev-haskell/haxml/haxml-1.12.ebuild
index f1cfa8b5f9da..f3550bb25855 100644
--- a/dev-haskell/haxml/haxml-1.12.ebuild
+++ b/dev-haskell/haxml/haxml-1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/haxml-1.12.ebuild,v 1.9 2007/10/31 12:59:40 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/haxml-1.12.ebuild,v 1.10 2007/12/13 00:47:17 dcoutts Exp $
inherit ghc-package fixheadtails
@@ -27,15 +27,15 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
- ht_fix_file ${S}/configure
+ ht_fix_file "${S}/configure"
}
src_compile() {
- ./configure --prefix=${D}/usr/bin \
+ ./configure --prefix="${D}/usr/bin" \
|| die "./configure failed"
# we only support ghc currently; overrides auto-detection
- echo ghc > ${S}/obj/compilers
+ echo ghc > "${S}/obj/compilers"
emake -j1 || die "make failed"
@@ -49,7 +49,7 @@ src_compile() {
ghc-setup-pkg
$(ghc-getghcpkg) -f "${S}/$(ghc-localpkgconf)" --force register "${FILESDIR}/${MY_P}.cabal"
else
- ghc-setup-pkg ${S}/obj/ghc/pkg.conf
+ ghc-setup-pkg "${S}/obj/ghc/pkg.conf"
fi
# make sure the libdir is correct
ghc-fixlibpath '$libdir'
@@ -57,10 +57,10 @@ src_compile() {
src_install() {
# fix so it installs into image dir
- echo ${D}/$(ghc-libdir) > ${S}/obj/ghc/ghclibdir
- echo ${D}/$(ghc-libdir)/imports > ${S}/obj/ghc/ghcincdir
+ echo "${D}/$(ghc-libdir) > "${S}/obj/ghc/ghclibdir"
+ echo "${D}/$(ghc-libdir)/imports > "${S}/obj/ghc/ghcincdir"
# make sure all installation directories are there
- mkdir -p ${D}/$(ghc-libdir)/imports
+ mkdir -p "${D}/$(ghc-libdir)/imports"
emake -j1 install-filesonly || die "make install failed"
diff --git a/dev-haskell/haxml/haxml-1.13-r1.ebuild b/dev-haskell/haxml/haxml-1.13-r1.ebuild
index 1d1775efa254..152e5842fb1b 100644
--- a/dev-haskell/haxml/haxml-1.13-r1.ebuild
+++ b/dev-haskell/haxml/haxml-1.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/haxml-1.13-r1.ebuild,v 1.13 2007/10/31 12:59:40 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/haxml-1.13-r1.ebuild,v 1.14 2007/12/13 00:47:17 dcoutts Exp $
CABAL_FEATURES="lib bin profile haddock"
inherit base haskell-cabal
@@ -20,8 +20,7 @@ IUSE=""
# actually, >=ghc-5.02 should be ok (if not using cabal)
# hugs and nhc98 are ok too, somebody might want to add support for them
-DEPEND=">=dev-lang/ghc-6.2
- !>=dev-lang/ghc-6.6
+DEPEND="<dev-lang/ghc-6.6
>=dev-haskell/cabal-1.1.3-r1"
S=${WORKDIR}/${MY_P}