summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-10-11 19:01:57 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-10-11 19:01:57 +0000
commitdc68fcc4f0637a9c6f256dc422b4bdbc4db24d84 (patch)
tree07431d1e00393ecedd9235ac0d34305ae50026e9 /dev-haskell/haxml/haxml-1.13.2.ebuild
parentAdded patch to fix building with ghc-6.6 (diff)
downloadgentoo-2-dc68fcc4f0637a9c6f256dc422b4bdbc4db24d84.tar.gz
gentoo-2-dc68fcc4f0637a9c6f256dc422b4bdbc4db24d84.tar.bz2
gentoo-2-dc68fcc4f0637a9c6f256dc422b4bdbc4db24d84.zip
New minor version to fix compatability with ghc-6.6
(Portage version: 2.1.1-r1)
Diffstat (limited to 'dev-haskell/haxml/haxml-1.13.2.ebuild')
-rw-r--r--dev-haskell/haxml/haxml-1.13.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-haskell/haxml/haxml-1.13.2.ebuild b/dev-haskell/haxml/haxml-1.13.2.ebuild
new file mode 100644
index 000000000000..f667f091ae62
--- /dev/null
+++ b/dev-haskell/haxml/haxml-1.13.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haxml/haxml-1.13.2.ebuild,v 1.1 2006/10/11 19:01:57 dcoutts Exp $
+
+CABAL_FEATURES="lib bin profile haddock"
+inherit base haskell-cabal
+
+MY_PN=HaXml
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Haskell utilities for parsing, filtering, transforming and generating XML documents"
+HOMEPAGE="http://www.haskell.org/HaXml/"
+SRC_URI="http://www.haskell.org/HaXml/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+
+# actually, >=ghc-5.02 should be ok (if not using cabal)
+# hugs and nhc98 are ok too, somebody might want to add support for them
+DEPEND=">=virtual/ghc-6.2
+ >=dev-haskell/cabal-1.1.3-r1"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ base_src_unpack
+
+ # Don't warn so much, and don't compile with -O2
+ sed -i 's/GHC-Options: -Wall -O2/GHC-Options: -O/' "${S}/HaXml.cabal"
+}
+
+src_install() {
+ cabal_src_install
+
+ if use doc; then
+ dohtml -r docs/*
+ dodoc docs/icfp99.dvi docs/icfp99.ps.gz
+ fi
+}
+