summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-04-22 08:23:02 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-04-22 08:23:02 +0000
commit9a0b3ae9e7cbe7e2ebe0bac5eb4c0d0fe61d6606 (patch)
treea6d25487c93bcdb87fa9f194c4c8096aebbc2b14 /dev-haskell/happy
parentVersion bump to solve buffer overflow and other bugs. (diff)
downloadgentoo-2-9a0b3ae9e7cbe7e2ebe0bac5eb4c0d0fe61d6606.tar.gz
gentoo-2-9a0b3ae9e7cbe7e2ebe0bac5eb4c0d0fe61d6606.tar.bz2
gentoo-2-9a0b3ae9e7cbe7e2ebe0bac5eb4c0d0fe61d6606.zip
added dev-haskell category and happy ebuild
Diffstat (limited to 'dev-haskell/happy')
-rw-r--r--dev-haskell/happy/ChangeLog11
-rw-r--r--dev-haskell/happy/files/digest-happy-1.131
-rw-r--r--dev-haskell/happy/happy-1.13.ebuild26
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/happy/ChangeLog b/dev-haskell/happy/ChangeLog
new file mode 100644
index 000000000000..3a88f01a0c3d
--- /dev/null
+++ b/dev-haskell/happy/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-haskell/happy
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.1 2003/04/22 08:23:02 kosmikus Exp $
+
+*happy-1.13 (22 Apr 2003)
+
+ 22 Apr 2003; Andres Loeh <kosmikus@gentoo.org> all :
+
+ Initial import. Thanks to Peter Simons <simons+gentoo@cryp.to> for
+ submitting an ebuild. happy is a yacc-like parser generator for Haskell.
+ This should close bug #12836.
diff --git a/dev-haskell/happy/files/digest-happy-1.13 b/dev-haskell/happy/files/digest-happy-1.13
new file mode 100644
index 000000000000..60877aeeae3a
--- /dev/null
+++ b/dev-haskell/happy/files/digest-happy-1.13
@@ -0,0 +1 @@
+MD5 d17619ae6e2caf883651d88be38dfd8a happy-1.13-src.tar.gz 329764
diff --git a/dev-haskell/happy/happy-1.13.ebuild b/dev-haskell/happy/happy-1.13.ebuild
new file mode 100644
index 000000000000..a77392289f8a
--- /dev/null
+++ b/dev-haskell/happy/happy-1.13.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.13.ebuild,v 1.1 2003/04/22 08:23:02 kosmikus Exp $
+
+DESCRIPTION="A yacc-like parser generator for Haskell"
+HOMEPAGE="http://haskell.org/happy/"
+SRC_URI="http://haskell.cs.yale.edu/happy/dist/1.13/happy-1.13-src.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/ghc"
+RDEPEND=""
+
+src_compile() {
+ econf || die
+
+ # "emake" does not work reliably. Probably due to the classic
+ # dependency problem in make with parallel builds.
+ make || die
+}
+
+src_install() {
+ einstall || die
+}