summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-05-26 04:07:08 +0000
committerMark Wright <gienah@gentoo.org>2013-05-26 04:07:08 +0000
commit9f4d3b5b74e253e7506df1bf42ff56b9f26d4422 (patch)
tree0d9a9407bc3ea1785b1910fbfe49c7c76ab375f2 /dev-haskell/haddock
parentBump haskell-platform to 2013.2.0.0 (diff)
downloadgentoo-2-9f4d3b5b74e253e7506df1bf42ff56b9f26d4422.tar.gz
gentoo-2-9f4d3b5b74e253e7506df1bf42ff56b9f26d4422.tar.bz2
gentoo-2-9f4d3b5b74e253e7506df1bf42ff56b9f26d4422.zip
Bump haddock to 2.13.2
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/haddock')
-rw-r--r--dev-haskell/haddock/ChangeLog7
-rw-r--r--dev-haskell/haddock/haddock-2.13.2.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/dev-haskell/haddock/ChangeLog b/dev-haskell/haddock/ChangeLog
index e7a92b54e46a..9f9ce6b99f1e 100644
--- a/dev-haskell/haddock/ChangeLog
+++ b/dev-haskell/haddock/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/haddock
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.106 2013/04/25 18:48:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.107 2013/05/26 04:07:08 gienah Exp $
+
+*haddock-2.13.2 (26 May 2013)
+
+ 26 May 2013; Mark Wright <gienah@gentoo.org> +haddock-2.13.2.ebuild:
+ Bump haddock to 2.13.2
25 Apr 2013; Agostino Sarubbo <ago@gentoo.org> haddock-2.10.0-r2.ebuild:
Stable for sparc, wrt bug #457780
diff --git a/dev-haskell/haddock/haddock-2.13.2.ebuild b/dev-haskell/haddock/haddock-2.13.2.ebuild
new file mode 100644
index 000000000000..d121c81cb836
--- /dev/null
+++ b/dev-haskell/haddock/haddock-2.13.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.13.2.ebuild,v 1.1 2013/05/26 04:07:08 gienah Exp $
+
+EAPI=5
+
+CABAL_FEATURES="bin lib profile haddock hscolour nocabaldep"
+inherit eutils haskell-cabal pax-utils
+
+DESCRIPTION="A documentation-generation tool for Haskell libraries"
+HOMEPAGE="http://www.haskell.org/haddock/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# ia64 lost as we don't have ghc-7 there yet
+# ppc64 needs to be rekeyworded due to xhtml not being keyworded
+# x86-fbsd is lost due xhtml
+KEYWORDS="~amd64 -ia64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/ghc-paths:=[profile?]
+ =dev-haskell/xhtml-3000.2*:=[profile?]
+ >=dev-lang/ghc-7.6.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.14"
+
+RESTRICT="test" # avoid depends on QC
+
+CABAL_EXTRA_BUILD_FLAGS="--ghc-options=-rtsopts"
+
+src_prepare() {
+ # we would like to avoid happy and alex depends
+ epatch "${FILESDIR}"/${PN}-2.13.1-drop-tools.patch
+ # Fix: Ticket #213 Haddock fails when advanced typesystem features are used
+ # epatch "${FILESDIR}"/${PN}-2.13.1-renameType.patch
+ if use doc && [ ! -e "${S}/html" ]; then
+ ln -s "${S}/resources/html" "${S}/html" || die "Could not create symbolic link ${S}/html"
+ fi
+}
+
+src_configure() {
+ # create a fake haddock executable. it'll set the right version to cabal
+ # configure, but will eventually get overwritten in src_compile by
+ # the real executable.
+ local exe="${S}/dist/build/haddock/haddock"
+ mkdir -p $(dirname "${exe}")
+ echo -e "#!/bin/sh\necho Haddock version ${PV}" > "${exe}"
+ chmod +x "${exe}"
+
+ # we use 'nocabaldep' to use ghc's bundled Cabal
+ # as external one is likely to break our haddock
+ # (known to work on 1.16.0 and breaks on 1.16.0.1!)
+ haskell-cabal_src_configure \
+ --with-haddock="${exe}" \
+ --constraint="Cabal == $(cabal-version)"
+}
+
+src_compile() {
+ # when building the (recursive..) haddock docs, change the datadir to the
+ # current directory, as we're using haddock inplace even if it's built to be
+ # installed into the system first.
+ haddock_datadir="${S}" haskell-cabal_src_compile
+}
+
+src_install() {
+ cabal_src_install
+ # haddock uses GHC-api to process TH source.
+ # TH requires GHCi which needs mmap('rwx') (bug #299709)
+ pax-mark -m "${D}/usr/bin/${PN}"
+}